RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-26-2006, 09:26 AM   #1
Member
 
Uncle Sam's Avatar
 
Join Date: Apr 2000
Location: New Port Richey, Fl USA
Posts: 93
I have a 2004 Gulfstream on a workhorse. This weekend I had the crap scared out of me. I was pulling into a campground and had to shift from forward to reverse. All at once I had a warning light on the instrument cluster that said something about shift. At this time I put into drive and engine speeded up but no drive, as if it was in neutral. Well I played with the shifter and finally it went forward . But then when I put into reverse it did the same thing. I finally shut off the engine and restarted and then it was fine. I think I may have caused the problem by shifting into reverse when it was moving slowly forward. Is this what caused it to happen?? Also what is the correct way to reset the transmission shift. I couldn't find much about it in the manual, but I do beleive it has something to do with the transmission computer. Yes it does have the Allison transmission. Yes it did scare the crap out of me, I could see huge dollar signs in my head.Any informaion on this subject would be appricated.
__________________
2004 37ft Gulfstream Sun Voyager / W22
Uncle Sam is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-26-2006, 09:26 AM   #2
Member
 
Uncle Sam's Avatar
 
Join Date: Apr 2000
Location: New Port Richey, Fl USA
Posts: 93
I have a 2004 Gulfstream on a workhorse. This weekend I had the crap scared out of me. I was pulling into a campground and had to shift from forward to reverse. All at once I had a warning light on the instrument cluster that said something about shift. At this time I put into drive and engine speeded up but no drive, as if it was in neutral. Well I played with the shifter and finally it went forward . But then when I put into reverse it did the same thing. I finally shut off the engine and restarted and then it was fine. I think I may have caused the problem by shifting into reverse when it was moving slowly forward. Is this what caused it to happen?? Also what is the correct way to reset the transmission shift. I couldn't find much about it in the manual, but I do beleive it has something to do with the transmission computer. Yes it does have the Allison transmission. Yes it did scare the crap out of me, I could see huge dollar signs in my head.Any informaion on this subject would be appricated.
__________________
2004 37ft Gulfstream Sun Voyager / W22
Uncle Sam is offline   Reply With Quote
Old 03-26-2006, 09:49 AM   #3
Senior Member
 
YosemiteBobR's Avatar
 
Thor Owners Club
Ford Super Duty Owner
Join Date: Apr 2005
Location: Washington
Posts: 803
That is differently a nono. Shift Inhibit light came on right? It is a safety feature set up by Allison and a good one. Yes, just turn you engine off wait and turn it back on and please do not do that again. It would cost big bucks if for some reason it did pop in.
__________________
2015 Four Winds Super C 33SW, w 6.7 Diesel 300HP - 660 lbs of torque
2011 Jeep Wrangler Sport as towed vehicle
Good Sam Club Life Member
YosemiteBobR is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument Cluster TAN Workhorse and Chevrolet Chassis Motorhome Forum 7 01-30-2009 05:10 AM
Instrument Cluster??? Rocket Heart Workhorse and Chevrolet Chassis Motorhome Forum 8 10-22-2008 01:21 PM
Instrument Cluster ?? Rocket Heart Winnebago Industries Owner's Forum 3 10-19-2008 05:14 PM
Instrument cluster Jimammo MH-General Discussions & Problems 3 07-09-2008 01:53 PM
Instrument Cluster obbm Workhorse and Chevrolet Chassis Motorhome Forum 7 11-16-2007 07:20 AM


All times are GMT -6. The time now is 09:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.