Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Ford Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-07-2013, 11:59 AM   #1
Junior Member
 
Join Date: Apr 2013
Posts: 24
1995 Coachmen Santara Speedometer, odometer, cruise not working

1995 Coachmen Santara speedometer, odometer, cruise not working
We just bought a new to us 1995 Coachmen Santara Class A, that the speedometer, odometer and cruise are not working on. The cluster has been replaced and the garage (who replaced them) thinks it may be an amplifier but said they are not made anymore and they can't get one from Coachmen. HELP We are moving back to Canada and need to get it working. Any suggestions would be greatly appreciated. side note: the lights and TV above the dash are also not working. Could this be related? Thanks
canadianmama is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-07-2013, 12:20 PM   #2
Senior Member
 
subford's Avatar
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Easton, Ks
Posts: 2,766
The Speed Control (cruise) and the PSOM (Speedometer & odometer) are both feed a signal generated by the VSS mounted on the emergency brake housing.
None of these have anything to do with Coachmen. They are all Ford parts.

The only amplifier is the Speed Control Servo Amplifier in the system.

The the lights above the dash are controlled by rotating the headlight switch. The lights also have a switch on them also. No they are not related.

You may have a bad VSS. You could try replacing it.
__________________
Bill
1995 COACHMEN Santara 350FL on a 1994 Ford F53
subford@gmail.com
subford is offline   Reply With Quote
Old 04-07-2013, 01:00 PM   #3
Junior Member
 
Idaho Rockhauler's Avatar
 
Thor Owners Club
Ford Super Duty Owner
Join Date: Feb 2003
Location: Boise, Idaho
Posts: 15
In my 95 ford pickup all of the speed functions cruse, speedo and abs are controlled by a vehicle speed sensor located on rear axel. real easy to change one electrical connector one bolt. Costs less than $30 at your local parts store. I know the F53 Has the same sensor I would think it would have the same function. I hope this helps
Mike
__________________
99 Hurricane 30Q
Idaho Rockhauler is offline   Reply With Quote
Old 04-07-2013, 01:06 PM   #4
Senior Member
 
subford's Avatar
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Easton, Ks
Posts: 2,766
If replacing the VSS does not fix it try unplugging the Speed Control Servo Amplifier and see if the speedometer starts working.
The VSS:


The Speed Control Servo Amplifier:


The VSS wiring:



/
__________________
Bill
1995 COACHMEN Santara 350FL on a 1994 Ford F53
subford@gmail.com
subford is offline   Reply With Quote
Old 04-07-2013, 01:13 PM   #5
Senior Member
 
subford's Avatar
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Easton, Ks
Posts: 2,766
Quote:
Originally Posted by Idaho Rockhauler View Post
In my 95 ford pickup all of the speed functions cruse, speedo and abs are controlled by a vehicle speed sensor located on rear axel. real easy to change one electrical connector one bolt. Costs less than $30 at your local parts store. I know the F53 Has the same sensor I would think it would have the same function. I hope this helps
Mike
No it is not the same sensor (generator), not even close.
And no it is not on the rear axle. Also the PSOM does not send any signal to the PCM or the Speed Control Servo Amplifier like it does on your truck.





Where the F53 wiring plugs in:
__________________
Bill
1995 COACHMEN Santara 350FL on a 1994 Ford F53
subford@gmail.com
subford is offline   Reply With Quote
Old 04-09-2013, 06:55 PM   #6
Junior Member
 
Join Date: Apr 2013
Posts: 24
Thank you so much for your informative posts! I have searched and found a speed sensor on ebay. It is a
Motorcraft DY1123 Speed Sensor New



We bought this motor home with all original paperwork and it shows it as having a 1994 Ford F53 Stripped RV chassis. I hope this is the correct sensor for my unit. This is suppose to be good for a Ford F53 stripped extended so I hope that means RV as well. My husband is busy with a job for the next 3 weeks so can't work on it but I plan to order the part and have it ready for when he can. This is our first motor home so it is a little intimidating. What a great forum! Thank you all again!
canadianmama is offline   Reply With Quote
Old 04-09-2013, 08:32 PM   #7
Senior Member
 
subford's Avatar
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Easton, Ks
Posts: 2,766
Nope, that is the wrong sensor.
That is for a PU truck that has the sensor in the rear end, yours does not.
That one will not fit any F53 with a 460.

You want the one in this link:
http://www.rockauto.com/catalog/more...682&cc=1367388
/
__________________
Bill
1995 COACHMEN Santara 350FL on a 1994 Ford F53
subford@gmail.com
subford is offline   Reply With Quote
Old 04-10-2013, 07:02 AM   #8
Junior Member
 
Join Date: Apr 2013
Posts: 24
Thanks Subford. I had a feeling the one I had was not the right one so was waiting to hear from you as I know your picture showed a different one. Weirdly the one in your picture was not on the compatible list that would fit a Ford F53 stripped XL......but there was also a complaint that their list was wrong. Your help is very much appreciated. I will order the part today.
canadianmama is offline   Reply With Quote
Old 04-10-2013, 07:10 AM   #9
Junior Member
 
Join Date: Apr 2013
Posts: 24
Is this the right one?
Tru-Tech SC37T ABS Transmission Speed Sensor : Amazon.com : Automotive
Thanks
canadianmama is offline   Reply With Quote
Old 04-10-2013, 08:29 AM   #10
Senior Member
 
subford's Avatar
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Easton, Ks
Posts: 2,766
I have never heard of Tru-Tech or the SC37T. The photo of it looks right but that is all I can tell you on that one. I would not buy it for my F53.

A SC37 without the "T" on the end is a STANDARD MOTOR PRODUCTS number and it looks like they are copying that number and adding a "T" on it.

The Ford MOTORCRAFT Part is # E9LZ-9E731-A or # DY588 and you should be able to buy the VSS sensor at any auto parts store or Ford dealer by giving them these numbers.

Here is a list of the other brands and their part numbers.


Did you try unplugging the Speed Control Module and see if the speedometer works with it not plugged in?
/
__________________
Bill
1995 COACHMEN Santara 350FL on a 1994 Ford F53
subford@gmail.com
subford is offline   Reply With Quote
Old 04-10-2013, 08:48 AM   #11
Senior Member
 
subford's Avatar
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Easton, Ks
Posts: 2,766
Quote:
Originally Posted by canadianmama View Post
Weirdly the one in your picture was not on the compatible list that would fit a Ford F53 stripped XL......but there was also a complaint that their list was wrong.
Sadly when getting parts for the F53 you have to know the part number or know what else it fits when getting parts.
Most look up computers at auto part stores, on line and at the Ford dealer are wrong for the F53.

For a few examples take the Ignition Control Module (ICM) for your F53. All of the places listed above will try to sell you the wrong one that is Gray in color. Your unit is only wire to take the Black one and if you put the one they sell you in the MPG will drop along with the engine power an it will also be harder to start. The Gray one only fits the 1993 and older F53 MH, E-series & F-series trucks.

Another example is the Transmission filter, they will try to sell you the one with the short tube and yours takes the long one. Ford will even put in the wrong one in the F53. Then you will have transmission problems. Yours takes the filter for a 4X4 with a E4OD Transmission.

And as you know they will also try to sell the wrong VSS among other things.
__________________
Bill
1995 COACHMEN Santara 350FL on a 1994 Ford F53
subford@gmail.com
subford is offline   Reply With Quote
Old 04-10-2013, 11:26 AM   #12
Registered User
 
Join Date: Mar 2013
Posts: 1,919
if there is no VSS from the sensor and it looks new, suspect the worm gear in the ebrake assembly is stripped. seen that a few times. especially if there was a leak at one time.
jamesrxx951 is offline   Reply With Quote
Old 04-11-2013, 01:41 AM   #13
Junior Member
 
Join Date: Apr 2013
Posts: 24
Thanks Subford. I was able to get the link to work on the earlier sensor you sent me and ordered it from Rock auto. I will definitely keep in mind what you say about parts.

They already emailed me to inform me the part has been shipped. I wish I could put it on myself but I will leave that for my husband. I am in charge of internet research for parts and solutions and revamping the interior of the unit.....he can crawl underneath. (especially after I found a fresh snake skin under the drawer of the closet/nightstand, on the right side of the bed)

I feel with all your help we will have this speedometer/odometer situation worked out soon. This forum is fantastic! Thanks!
canadianmama is offline   Reply With Quote
Old 04-11-2013, 06:36 AM   #14
Senior Member
 
Excell's Avatar
 
Ford Super Duty Owner
Georgie Boy Owners Club
Join Date: Aug 2012
Location: Winnipeg Manitoba
Posts: 327
Where are you moving to in Canada?
__________________
Excell
1999 Georgie Boy Landau 3512 on Ford F53
2006 Mazda Tribute ,2001 Goldwing
Excell is offline   Reply With Quote
Reply

Tags
coachmen



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:52 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.