Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Ford Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-11-2014, 10:01 PM   #1
BSD
Junior Member
 
BSD's Avatar
 
National RV Owners Club
Ford Super Duty Owner
Join Date: Nov 2013
Posts: 10
1999 National RV Tropical Ford Chassis blowing fuses

Has anyone had trouble with the 20 amp fuses blowing?

The MH was purchased used last September, At that time the speedometer was not working. The dealer said to bring it back in a week and leave it to be rebuilt. They had the coach for 2 weeks to get the gages rebuilt and back.


The speedometer stopped working a second time. The instrument cluster was sent out a second time and the coach sat for another week at the dealer.


The second cluster was installed. On the way home wife was following me in the car. She noticed I had no brake lights. We noticed that we also lost the turn signals.


The motorhome went back again. Another week past. We had the motorhome winterized and they said the issue was resolved. We pick up the MH drove it home and the same issue occurred.


The dealer sent their service manager over in an effort to get the issued fixed before we went on a trip in late November. All he did was replace the fuses that kept blowing in the prior issues. We did drive it and replaced the fuses 2 times during the trip.


The MH was stored at the dealer over the winter. Prior to picking it up in the spring we had them try to resolve the issue. Again no resolution. Another trip and another time my wife was under the dash replacing 20 amp fuses.


So now it is back again. This time they have had it 2.5 weeks. Last communication last week is they were 50% done and have found nothing.


The fuses blow when you have the headlights on and press the brake peddle and engage the turn signals. This blows the brake and turn signal fuse.


We literally can not drive the MH after dark. Any ideas greatly appreciated!
BSD is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-11-2014, 10:26 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 27,894
Both the brake light wiring and the turn signal wiring go up the steering column to the switch and can be effected by using the tilt , how and where the headlights figure in , unless the dimmer switch is on the turn signal arm is a bit of a mystery .
Wiring repair 99% of the time spent is finding the exact cause of the problem.
JMHO: I'd be pulling the turn signal switch & wiring, out of the steering column. And examining all the wiring in the trailer connector . These would be common places where the three wiring systems run together , and I would hope they were the first places checked.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 08-12-2014, 06:57 AM   #3
Senior Member
 
subford's Avatar
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Easton, Ks
Posts: 2,806
Quote:
Originally Posted by BSD View Post
This blows the brake and turn signal fuse.
The Brake fuse (#9) and the turn signal fuse (#1) are two different fuses. They are both 20Amp fuses.

Can you tell us the number of the fuse that is blowing?

First I would unplug C400 & C401 and see if you still have the problem. If so unplug C177 and check again.

I have my doubts that there was ever anything wrong with the cluster. Most of the problems with the speedometer of your type has been the speed sensors at the rear end.

I take it you are taking it back to an RV dealer and not a Ford dealer.
__________________
Bill
1995 COACHMEN Santara 350FL on a 1994 Ford F53
subford@gmail.com
subford is offline   Reply With Quote
Old 08-12-2014, 10:16 AM   #4
BSD
Junior Member
 
BSD's Avatar
 
National RV Owners Club
Ford Super Duty Owner
Join Date: Nov 2013
Posts: 10
Both fuses are blowing! We have it at the RV dealer but I am wondering if it should be at the Ford dealer.
BSD is offline   Reply With Quote
Old 08-14-2014, 11:13 AM   #5
BSD
Junior Member
 
BSD's Avatar
 
National RV Owners Club
Ford Super Duty Owner
Join Date: Nov 2013
Posts: 10
Thank you both for your replies. Any idea where I would find a diagram that would help me understand the location of C400, C401, and C177?
BSD is offline   Reply With Quote
Old 08-14-2014, 02:46 PM   #6
Senior Member
 
subford's Avatar
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Easton, Ks
Posts: 2,806
C400 & c401:


C177:


Pin outs C177 & C400:
/
__________________
Bill
1995 COACHMEN Santara 350FL on a 1994 Ford F53
subford@gmail.com
subford is offline   Reply With Quote
Old 08-14-2014, 08:46 PM   #7
BSD
Junior Member
 
BSD's Avatar
 
National RV Owners Club
Ford Super Duty Owner
Join Date: Nov 2013
Posts: 10
Thanks!!!
BSD is offline   Reply With Quote
Reply

Tags
chassis, ford, fuse, national



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Headlight issues on Ford Chassis trode Ford Motorhome Chassis Forum 21 09-08-2014 07:11 PM
Front power jacks motor blowing fuses SultanGris 5th Wheel Discussion 9 08-02-2014 04:47 PM
Slide out won't open and keeps blowing fuses foreverfree RV Systems & Appliances 5 07-01-2014 02:06 PM
Ford chassis and coach maintenance gboyle Ford Motorhome Chassis Forum 4 03-20-2014 12:03 PM
1999 Sea View - Fuses? Back Up Camera? Radio? Krawling National RV Owner's Forum 3 02-10-2014 05:14 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.