Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Ford Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-19-2012, 07:28 PM   #1
Junior Member
 
Holiday Rambler Owners Club
Join Date: Feb 2012
Posts: 23
!999 HR vacationer windshield wiper issues

Had to use the wipers on our 1999 HR Vacationer (f53 ford chassis)for the 1st time since we bought it and had this problem....,first noticed that the wiper delay function did not work,High low speed did work ok, then after pushing sprayer button the wipers would not turn off.I stopped turned off the engine and restarted it, the wipers turned off and worked ok again(high and low speed but no delay),I hit the washer button again and same thing happened wipers would not turn off until I shut off the engine and restarted it.At first I was thinking the multifunction switch..wiper, t/s, washer , brights ...was bad but I would first like to see if there could be a bad relay somewhere in the wiper circuit circuit, would anyone happen to know this system or have a schematic for the chassis?Thanks in advance for any information.
Royboy
rapidroy5858 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-20-2012, 07:14 AM   #2
Senior Member
 
subford's Avatar
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Easton, Ks
Posts: 2,807
Do you know what 1999 F53 wiper system you have?
Do you have Interval Wiper/Washer, Dual Wiper/Washer OR the Interval Wiper/Washer, Single Wiper/Washer Motor?

They have a different set of schematics and relays for each system.
The Interval Wiper/Washer, Dual Wiper/Washer has two relays and the Interval Wiper/Washer, Single Wiper/Washer Motor does not have any relays.

The relays are for high and low speeds.

Wipers and Washers — Motorhome

The wipers and washers are controlled by a wiper control module and the driver operated multi-function switch located on the steering column, with the ignition switch in the RUN or ACC position.

The wiper control module works with standard aftermarket wiper motors equipped with four different operating modes: OFF, the wipers move to and stay in the park position; Interval, the wiper control module causes the wipers to make single wipes, separated by pauses (the pause time length is determined by switch location); LO, the wipers operate at low speed continuously; HI, the wipers operate at high speed continuously.

Dual wipers are available and must be ordered with the dual wiper motor jumper.

Wipers and Washers — Motorhome
PINPOINT TEST P: THE WIPERS STAY ON CONTINUOUSLY
P1: CHECK THE MULTI-FUNCTION SWITCH
P2: CHECK CIRCUIT 590 (DB/W) FOR SHORT TO GROUND
CHECK CIRCUIT 589 (O) FOR SHORT TO GROUND
P4: CHECK CIRCUIT 993 (BR/W) FOR SHORT TO GROUND
__________________
Bill
1995 COACHMEN Santara 350FL on a 1994 Ford F53
subford@gmail.com
subford is offline   Reply With Quote
Old 06-20-2012, 04:10 PM   #3
Junior Member
 
Holiday Rambler Owners Club
Join Date: Feb 2012
Posts: 23
I believe I have the single wiper ,washer interval system, both wipers are controlled by the multifunction switch,It would be a huge help if I knew where to locate the wiper control module...My wipers do not return to park pos., and if I use the washer I need to shut off the ign before they will turn off, after I restart the coach they work ok on hi/low but no interval.
rapidroy5858 is offline   Reply With Quote
Old 06-20-2012, 04:33 PM   #4
Senior Member
 
subford's Avatar
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Easton, Ks
Posts: 2,807
The wiper control module is behind I/P, under steering column.
__________________
Bill
1995 COACHMEN Santara 350FL on a 1994 Ford F53
subford@gmail.com
subford is offline   Reply With Quote
Old 06-20-2012, 10:20 PM   #5
Junior Member
 
Holiday Rambler Owners Club
Join Date: Feb 2012
Posts: 23
Wipers

Thanks again , this is VERY helpful,I am thinking my problem to be with the control module since the multi switch does seem to turn the wipers on and off except when I use the washer switch, of course I am just guessing, I did find a ford part number that is supposed to be for the module for the 99 f53 coach, I will locate module and take with me for comparison reasons.If you have any other advise or thoughts feel free to share...the more insight the better.
Thanks Royboy
rapidroy5858 is offline   Reply With Quote
Old 07-14-2012, 07:27 AM   #6
Member
 
Ford Super Duty Owner
Join Date: Dec 2010
Posts: 58
Wipers

Myself and a friend both have 2005 Coachmen Mirada 290Ks and each have experienced this problem and both have replaced the multifunction switch without solving the problem.

Personally I now believe the problem is related to the wiper control unit, probably a bad connection or bad earthing. I had a small modification done to my MH which required the control unit to be moved slightly and following this the wipers and washers worked perfectly for over two years
until just recently when they started to mis-perform again so I intend to check the control unit out carefully.

SUBFORD What is the I/P you mentioned in your reply?
baysidetas is offline   Reply With Quote
Old 07-14-2012, 07:42 AM   #7
Senior Member
 
subford's Avatar
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Easton, Ks
Posts: 2,807
I/P = Instrument Panel
__________________
Bill
1995 COACHMEN Santara 350FL on a 1994 Ford F53
subford@gmail.com
subford is offline   Reply With Quote
Old 07-15-2012, 08:21 AM   #8
Junior Member
 
Holiday Rambler Owners Club
Join Date: Feb 2012
Posts: 23
Fixed!!

I tried both the multifunction switch and wiper control module, made no difference, finally pulled wiper motor removed cover where electrical plug is attached and inside found thAt there are small brass contacts that run from each wire on the connector , 2 of them were fairly scorched/ burnt, i lightly filed them clean and made sure they still made contact with the brass disc/plate that they ride against... Reinstalled and to my great relief the wipers work perfect once again. I can see where this could be a common problem , i'd say give it a try.
Good luck Royboy
rapidroy5858 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:27 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.