Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Ford Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-11-2018, 04:39 PM   #1
Member
 
Join Date: Mar 2018
Posts: 32
Center Console Gauges Stay on After turning off

I have a 1995 Safari Sahara that sits on a magnum chassis. The tachtomoter stays on 1500 RPM and Speedo stays at 20 MPH when turned off. You turn it on and they go to zero and the tachtomoter hovers around 700RPM and Speedo is at zero. You turn it off and the tack goes back to 1500 RPM and speedo is 20 MPH. Any ideas?
chollenback is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-11-2018, 09:20 PM   #2
Senior Member
 
Bob Hyatt's Avatar
 
Tiffin Owners Club
Join Date: Apr 2018
Location: Pelham (Birmingham) AL
Posts: 400
I have seen digital instruments that do not sit at zero when powered down. The tach in my bass boat is one example. Sits roughly horizontal at about 1500 rather than at zero until ignition is on. Might not be a problem. If this has changed, it is worth looking into of course...
__________________
Bob Hyatt
2018 Tiffin Allegro 32SA
Bob Hyatt is offline   Reply With Quote
Old 04-12-2018, 07:00 PM   #3
Member
 
Join Date: Mar 2018
Posts: 32
this is the first time it has occured. Does this mean there is power still going through it somehow?
chollenback is offline   Reply With Quote
Reply

Tags
gauges



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
After long Trip How Long to Cool down engine before turning off 18Anthem Entegra Owner's Forum 15 02-03-2018 08:17 AM
Need help resetting console after changing oil O2BNMYRV Workhorse and Chevrolet Chassis Motorhome Forum 3 08-08-2015 07:02 AM
Ford E-Series console latch wont stay closed wanderso Class C Motorhome Discussions 3 03-23-2014 01:00 AM
03 Dynasty Center TV Console modifications texnet Monaco Owner's Forum 14 03-10-2012 07:25 PM
Center Console Need.... OGTerror iRV2.com General Discussion 8 12-19-2011 08:12 PM


All times are GMT -6. The time now is 01:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.