Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Ford Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-04-2007, 08:32 AM   #1
Member
 
Scrib's Avatar
 
Join Date: Apr 2007
Posts: 52
I have double-checked my wiring on the toad, but this has me flumaxed;

1. toad lights work
2. toad brake lights work
3. no left turn signal on the toad
4. right turn signal causes both toad lights to flash

I notice that Ford uses a Relay for the trailer turn signals, could I have a bad Relay, since the brake lights work fine?
__________________
https://i10.photobucket.com/albums/a122/Strike_Hold/sig-061407c.jpg
Scrib is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-04-2007, 08:32 AM   #2
Member
 
Scrib's Avatar
 
Join Date: Apr 2007
Posts: 52
I have double-checked my wiring on the toad, but this has me flumaxed;

1. toad lights work
2. toad brake lights work
3. no left turn signal on the toad
4. right turn signal causes both toad lights to flash

I notice that Ford uses a Relay for the trailer turn signals, could I have a bad Relay, since the brake lights work fine?
__________________
https://i10.photobucket.com/albums/a122/Strike_Hold/sig-061407c.jpg
Scrib is offline   Reply With Quote
Old 06-04-2007, 12:38 PM   #3
Senior Member
 
Richard S.'s Avatar
 
National RV Owners Club
Ford Super Duty Owner
Join Date: May 2007
Location: El Cajon CA
Posts: 2,055
Ithink you motorhome is a 4 wire system and your Suzuki is a 5 wire system.You need to go to the BLUE OX web site under wireing. Below you will find a portion I did a cut and paste.

Two basic platforms exist in automotive wiring, the 4-wire system and the 5-wire system. The 4-wire system, most commonly used for years in the United States, has a combined left turn/brake wire, a combined right turn/brake wire and a tail light wire. All rear lights in this system are normally red in color. The 5-wire system, common among imported vehicles, has a left turn wire, right turn wire, tail light wire and a brake wire. The turn signals are normally amber in color. With these two platforms, 4 basic combinations can be encountered as follows:
__________________
2007 Sea Breeze LX 8321 Ford Chassis
2004 Ford Ranger Edge
El Cajon CA.
Richard S. is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Right rear stop and turn signal light Uncle Sam Workhorse and Chevrolet Chassis Motorhome Forum 5 08-13-2008 05:39 AM
Braking Interfers With Turn Signal Lights Marc7747 MH-General Discussions & Problems 13 03-31-2008 06:55 PM
E450 Turn signal problem on "00 Shasta class C New Whale Class C Motorhome Discussions 3 03-06-2008 12:59 PM
No Stop/Turn signal at towing plug Belgique Winnebago Industries Owner's Forum 8 12-13-2007 05:19 AM
Side Signal Lights mis3s Winnebago Industries Owner's Forum 25 11-25-2006 08:32 AM


All times are GMT -6. The time now is 10:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.