Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Ford Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-20-2021, 06:48 PM   #1
Junior Member
 
Join Date: Aug 2011
Location: Gamaliel, Arkansas
Posts: 6
Ford V-10 Triton

Have a problem that just started. When I start the engine it idles at 1000rpm for about 20 seconds then starts to idle down but when it does that it acts like its only hitting on 6 or so cylinders and wants to stop. I start playing with throttle to keep it running then it pops like a little backfire then smooths out and idles ok. Any ideas? 36000 miles on it and has a banks intake and power exhaust system.

Thanks
EDDI is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-20-2021, 07:54 PM   #2
Senior Member
 
R.Wold's Avatar


 
Newmar Owners Club
Ford Super Duty Owner
Freightliner Owners Club
Retired Fire Service RVer's
Join Date: Jan 2019
Location: Rosemary Farm, Northern Ca
Posts: 5,015
Quote:
Originally Posted by EDDI View Post
Have a problem that just started. When I start the engine it idles at 1000rpm for about 20 seconds then starts to idle down but when it does that it acts like its only hitting on 6 or so cylinders and wants to stop. I start playing with throttle to keep it running then it pops like a little backfire then smooths out and idles ok. Any ideas? 36000 miles on it and has a banks intake and power exhaust system.

Thanks
It could be one bad coil- that would make it run rough and feel like theres a loss of power. Put a code reader on it and see what you get.
__________________
2016 Ventana 3427 with HWH Active Air, 1575w solar; 2001 Jeep toad.
R.Wold is offline   Reply With Quote
Old 09-20-2021, 08:15 PM   #3
Senior Member
 
Rob_M's Avatar
 
Join Date: Dec 2019
Location: Texas
Posts: 840
^^^^ what he said. Only issues Iíve had with my v10 over many years have been several coil packs and a mass air sensor. You need a scanner to diagnose, which cyl is missing or which sensor is bad. Guessing will get you nowhere. Several things can even give similar symptoms.
__________________
Rob & Laura
2002 American Tradition 40', 431hp Banks PowerPack
Mid-South TX
Rob_M is offline   Reply With Quote
Reply

Tags
ford



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Used Class A Gasser: Ford Triton V-10, or Ford 460 V-8? Peter Henry MH-General Discussions & Problems 14 12-02-2020 06:49 PM
1999 Damon/Ford Triton chassis electrical problem Darrell & Mel Ford Motorhome Chassis Forum 6 01-08-2011 06:19 PM
Cruise control recall/Ford V-10 Triton codgerbill Winnebago Industries Owner's Forum 6 02-23-2008 03:55 PM
Ford F53 Chassis/Triton V-10 Speed Sensor Darrell & Mel Ford Motorhome Chassis Forum 11 07-08-2007 04:57 AM
Ford Triton V-10 engines before 2000 shelly2koi MH-General Discussions & Problems 13 10-26-2005 07:28 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.