Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Ford Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-11-2021, 05:15 AM   #1
US1
Senior Member
 
Join Date: Jan 2020
Posts: 594
HydroMax brake motor

The hydra max boost pump on mine sounds like a garbage disposal grinding up a full course meal. Normal?

When the engine is running, I don’t hear it. I assume the PS pump is taking over for the electric motor? Fluid level is full and brakes operate fine.
The loud noise is main concern. I’m trying to run a scan of my motor with the motor off and the running pump is crazy loud. Are they normally noisy loud?

I listened to a guy that has the same RV but a WH chassis and his was just a hum
__________________
2001 Winnebago Brave SE29 Workhorse P32 7.4L (previous)
2007 Fleetwood Bounder 33R, F53 chassis, V10 (current)
US1 is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-11-2021, 06:34 AM   #2
Senior Member


 
Holiday Rambler Owners Club
Join Date: Aug 2015
Posts: 5,449
US1-

The HydroMax unit should run only when the engine is off.

Yes, it sounds awful. My coach's runs while I'm leveling the coach. Makes me move through the process quickly. ;-)
__________________
Mark
2008 Holiday Rambler Admiral 30PDD (Ford F-53 chassis)
2009 Honda Fit Sport
l1v3fr33ord1 is offline   Reply With Quote
Old 05-11-2021, 06:46 AM   #3
US1
Senior Member
 
Join Date: Jan 2020
Posts: 594
Thanks for the clarification. Another concern checked off.
__________________
2001 Winnebago Brave SE29 Workhorse P32 7.4L (previous)
2007 Fleetwood Bounder 33R, F53 chassis, V10 (current)
US1 is online now   Reply With Quote
Reply

Tags
brake, motor



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atwood Hydro Flame Furnace blower motor stuck Ampedspyder RV Systems & Appliances 0 02-29-2020 10:59 AM
Hydro-Max Brake Pump/Motor Info Please! wihakowi Ford Motorhome Chassis Forum 8 10-28-2015 08:59 AM
Hydro Hot Motor Controller bruceisla Newmar Owner's Forum 1 08-07-2015 01:19 PM
Hydro Brake, Parking Brake theartist Freightliner Motorhome Chassis Forum 0 08-02-2015 10:18 AM
no brake lights or hydro boost on 04 limited lefever Alpine Coach Owner's Forum 1 08-12-2007 05:38 PM


All times are GMT -6. The time now is 06:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.