Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Ford Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-31-2021, 11:03 AM   #29
Senior Member
 
Join Date: Aug 2020
Posts: 305
F53 Chassis Front Wheel Alignment and Adjusting Safe-T-Plus

Quote:
Originally Posted by wncrowder View Post
I've got to say it's a bit tiring having to constantly apply pressure even with no wind so I'm about to take off the Safe-T-Plus to see if the condition continues.
Before you remove the Safe-T-Plus I highly encourage you to watch this video that I found on YT about a year ago. This fella goes into a lot of what you're talking about. Watch the whole video because the info builds as he goes along.

__________________
Traveling Full Timers
Gas Motorhome
Escapees, Maintenance Freak
mr.tommy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-01-2021, 07:27 AM   #30
Junior Member
 
Newmar Owners Club
Join Date: Mar 2021
Posts: 7
Another F53 Service AdvanceTrac Light

Very informative video! My F53 is in the shop getting the low differential oil recall fixed so I'll have to wait to try it but I'm certainly going to give it a go! I wasn't really thinking of taking the Safe T Plus off permanently, just long enough to see if the light stayed off, but now I'm just going to give it a few taps. I know there's a sweet spot but nobody has been willing to take the time to find it. Now, with the knowledge from the video, I'm confident enough to try it myself. Thanks so much for the info!
wncrowder is offline   Reply With Quote
Old 06-12-2021, 08:39 AM   #31
Junior Member
 
Join Date: Dec 2020
Posts: 23
I have been dealing with this issue and itís time for all to call the Ford RV line and start a case with them.

1). The local dealers are not documenting the issue for warranty purposes. (After 7 months I realized this).

2). They are not closing out tickets for their own purposes of leaving a problem ďunrepairedĒ.

3). Bald face lies. There is NO software update!
This is a deceptive practice. Keep waiting?

4). Heavy truck center started telling me itís an RV problem. When he couldnít explain, the head mechanic came to explain but, in listening decided to re-examine the computer download and found that although steering sensor tested fine the steering module was at fault when cruise control is on steering wheel.

Itís a KNOWN ISSUE

Call Ford RV 800 number and letís get this reported enough to reduce the stress.
CruzinAround is offline   Reply With Quote
Old 06-14-2021, 06:10 AM   #32
Junior Member
 
Join Date: Dec 2020
Posts: 23
My tire and repair shop dealt with ‘kickback’ but, no change in advance trac issue.
They checked alignment and rotated front tires to rear and balanced front. That changed ride considerably.

Hopefully if you read my other posts you’ll see my advancetrac issues. I’m hoping to hear from others.
CruzinAround is offline   Reply With Quote
Old 06-15-2021, 12:29 PM   #33
Junior Member
 
Newmar Owners Club
Join Date: Mar 2021
Posts: 7
Another F53 Service AdvanceTrac Light

I'll bet the "RV problem" they're referring to is the wind against the large side. It's a F53, it's supposed to carry an RV! The problem is NOT just with F53s, it started with F350/450s. The software fix is real but it's for the F450 and no one knows if it will work on the F53. Unfortunately the software fix doesn't work all the time on the 350/450s. You know, I had a MB Sprinter and they NEVER have these "unrepaired" problems and ALL the (sprinter) dealers service the B+ Sprinter based motorhomes. We wanted a larger rig and just assumed Ford would be like MB. Obviously, we were Very wrong! If I get the F450 software fix I'll let everyone know the results. I think we might be forgetting that we lose cruise control, traction control, hill start and, I think, ABS. Lots of functionality we paid real money for. Besides, you can't clear the screen to get info.
wncrowder is offline   Reply With Quote
Old 06-16-2021, 08:18 AM   #34
Junior Member
 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Aug 2020
Location: Palm Coast, FL
Posts: 23
Here I thought I was the only one having the ABS & Traction Control lights come on. During out test drive in July of 2020 they were on. That was 10K plus miles ago, 5 visits to Ford dealers & 1 to Rush Truck Center. Ford told me there is a Special Service Message out about this. Rush found mine had a damaged Tone Ring & bad Wheel Speed Sensor. Mine was the third Rush had done in 2 weeks & all on the right rear. We are now out on a 4+ week road trip & still having the issue. My work around lights on & not going out is, drop into N turn key off & back on, then back to D. This resets computer. Got tired of pulling over stopping to do this. Guess just old & like my cruise control. My one question are all to these Class Aís on the 2020-21 chassis? Ours a 21 Fleetwood Bounder.
Cloudbuster is offline   Reply With Quote
Old 06-16-2021, 10:08 AM   #35
D20
Senior Member
 
Join Date: Oct 2020
Location: Florida
Posts: 288
Quote:
Originally Posted by Cloudbuster View Post
Here I thought I was the only one having the ABS & Traction Control lights come on. During out test drive in July of 2020 they were on. That was 10K plus miles ago, 5 visits to Ford dealers & 1 to Rush Truck Center. Ford told me there is a Special Service Message out about this. Rush found mine had a damaged Tone Ring & bad Wheel Speed Sensor. Mine was the third Rush had done in 2 weeks & all on the right rear. We are now out on a 4+ week road trip & still having the issue. My work around lights on & not going out is, drop into N turn key off & back on, then back to D. This resets computer. Got tired of pulling over stopping to do this. Guess just old & like my cruise control. My one question are all to these Class Aís on the 2020-21 chassis? Ours a 21 Fleetwood Bounder.
As I understand it, only the new '20 - '21 V8 chassis has the AdvanceTrac. It is a new feature with the redesigned chassis.

I am heading to Rush Truck Orlando next week. I will ask if there is any update regarding this issue.
__________________
2021 Newmar Bay Star 3626
D20 is offline   Reply With Quote
Old 06-26-2021, 09:08 AM   #36
Senior Member
 
Join Date: Jun 2020
Posts: 104
I'm half way through my 6 western state trip and after 2000 miles on my '20 22k chassis (22.5 wheels) and it coming on maybe 5 or 6 times I think I have 2 hypothesis for what is happening. Previously I wrote about it coming on during a previous trip in high wind, that is incorrect. I drove the same stretch again with no wind and it came on again in the same spot. I pulled the code and it was showing for a implausible signal from the drivers rear wheel speed sensor. I forgot to write down the exact code but will get it in a couple days.

Theory 1. Big chop causes an error with the wheel speed sensors. Perhaps there is a harmonic or maybe the mounting bracket for the sensor isn't strong enough. But I can recall a time when there was a couple miles of heavy chop from big trucks and the light came on after a mile or so. The wind spot I referenced before was in a heavy chop section. After driving it again without wind, the only variable is the crappy road.

Theory 2. This one I am 100% sure of. A couple times I have let the speed run up to 80 or so (big long straight downhill) since it is governed at 76 or so you can't actually get up there unless you are coasting, but it will always come on if you get up to 80's. I can't remember the exact mph that triggers it (80, 81 or 82). But since I haven't let it drift up past 77 for the last 1k miles it has not turned on. My guess here is there is a maximum rpm value the speed sensor says is plausible. When you get up around 80 (which you probably shouldn't ever do since the tires are only rated for 75...) it is probably exceeding this max value and triggers the fault.

Would be interested to hear if others have had situations that match my hypothesis above.

Now that I haven't gone past 77 mph it has been a very enjoyable last 1k miles on the road. Even with this little issue I would take the v8 chassis over the V10 every day of the week, it is a very very good step forward for the f53
mack73 is offline   Reply With Quote
Old 06-26-2021, 12:46 PM   #37
Senior Member
 
Join Date: Apr 2020
Posts: 127
I think I posted this earlier but will do it again:

I have a Thor Axis 24.1 on a Ford E350 chassis. I have gotten that error message twice and have driven it about 2,500 miles so far. The second time it happened I was going down a smooth interstate at 60-65 mph.

My steering wheel is offset at about 10 degrees. I suspect that may have something to do with the problem. I thought about getting an alignment to straighten the wheel, but I like the handling and so far I haven't done it.

I have driven 1,000 miles since the second incident and no problems knock on wood.

David
DavidEM is offline   Reply With Quote
Old 06-27-2021, 07:15 AM   #38
Junior Member
 
Newmar Owners Club
Join Date: Mar 2021
Posts: 7
Another F53 Service AdvanceTrac Light

My saga continues with an interesting development. My 2021 Newmar 3014 is still in the Ford shop. The recall has been fixed and now they are working on the Advancetrac problem. They found error codes for both rear wheel sensors. In addition, there seems to be a service bulletin on this problem from Ford. Unfortunately, it's not a software fix. According to the tech, I guess it requires some pretty extensive work on the rear end...yep, same rear end that was just fixed...ouch. The dealer is very thorough so they are looking at everything including the under dash harness connector, front to rear wiring, etc. I think they're trying everything before taking the rear end apart.
Quick Update: The service bulletin is SSM 49315 located at https://static.nhtsa.gov/odi/tsbs/20...83565-0001.pdf
It essentially applies to 2020 F-53 16-22K chassis with an "ABS light" and DTCs C0037 and/or C0038. The problem is bent or damaged rear axle tone rings. The remedy is R&R tone rings.
wncrowder is offline   Reply With Quote
Old 06-27-2021, 08:39 AM   #39
D20
Senior Member
 
Join Date: Oct 2020
Location: Florida
Posts: 288
Quote:
Originally Posted by wncrowder View Post
My saga continues with an interesting development. My 2021 Newmar 3014 is still in the Ford shop. The recall has been fixed and now they are working on the Advancetrac problem. They found error codes for both rear wheel sensors. In addition, there seems to be a service bulletin on this problem from Ford. Unfortunately, it's not a software fix. According to the tech, I guess it requires some pretty extensive work on the rear end...yep, same rear end that was just fixed...ouch. The dealer is very thorough so they are looking at everything including the under dash harness connector, front to rear wiring, etc. I think they're trying everything before taking the rear end apart.
Quick Update: The service bulletin is SSM 49315 located at https://static.nhtsa.gov/odi/tsbs/20...83565-0001.pdf
It essentially applies to 2020 F-53 16-22K chassis with an "ABS light" and DTCs C0037 and/or C0038. The problem is bent or damaged rear axle tone rings. The remedy is R&R tone rings.
Yeah apparently those tone rings are fragile. They can easily be damaged when performing the axle recall as well. Too bad they didn't find the tone ring problem before they changed the bearings. Now they have to remove the hubs again.
__________________
2021 Newmar Bay Star 3626
D20 is offline   Reply With Quote
Old 06-27-2021, 09:08 AM   #40
Senior Member
 
Join Date: Jun 2020
Posts: 104
Quote:
Originally Posted by wncrowder View Post
My saga continues with an interesting development. My 2021 Newmar 3014 is still in the Ford shop. The recall has been fixed and now they are working on the Advancetrac problem. They found error codes for both rear wheel sensors. In addition, there seems to be a service bulletin on this problem from Ford. Unfortunately, it's not a software fix. According to the tech, I guess it requires some pretty extensive work on the rear end...yep, same rear end that was just fixed...ouch. The dealer is very thorough so they are looking at everything including the under dash harness connector, front to rear wiring, etc. I think they're trying everything before taking the rear end apart.
Quick Update: The service bulletin is SSM 49315 located at https://static.nhtsa.gov/odi/tsbs/20...83565-0001.pdf
It essentially applies to 2020 F-53 16-22K chassis with an "ABS light" and DTCs C0037 and/or C0038. The problem is bent or damaged rear axle tone rings. The remedy is R&R tone rings.
Thanks for the service bulletin. Guess I'll just deal with the light till the end of the season for all the wheel bearing rigs to get through the line and give the tech's some practice R&R these rings
mack73 is offline   Reply With Quote
Old 06-27-2021, 01:43 PM   #41
Junior Member
 
Join Date: Jun 2021
Posts: 5
Quote:
Originally Posted by Cloudbuster View Post
Here I thought I was the only one having the ABS & Traction Control lights come on. During out test drive in July of 2020 they were on. That was 10K plus miles ago, 5 visits to Ford dealers & 1 to Rush Truck Center. Ford told me there is a Special Service Message out about this. Rush found mine had a damaged Tone Ring & bad Wheel Speed Sensor. Mine was the third Rush had done in 2 weeks & all on the right rear. We are now out on a 4+ week road trip & still having the issue. My work around lights on & not going out is, drop into N turn key off & back on, then back to D. This resets computer. Got tired of pulling over stopping to do this. Guess just old & like my cruise control. My one question are all to these Class Aís on the 2020-21 chassis? Ours a 21 Fleetwood Bounder.
Hi Cloudbuster and Everyone Else,

Youíre not alone. My wife and I bought a 2021 Newmar Bay Star w/ the F53 in Dec 2020, just after Newmar drove it 2000 miles from the factory to the dealership w/ reportedly ďno issues.Ē As soon as we drove the RV off the lot and reached freeway speeds, the ABS and TCS lights came on. Over the next 120 days, it was in Ford service depts 3 times and 42 days (and another 23 days at the Newmar dealership).

First, the ABS sensor was replaced. Then the ECBM was replaced. Then a partial wire harness overlay was done, followed by a complete wire harness overlay. None of these repairs fixed the problem. Finally the tone ring assembly was replaced and this turned off the ABS and TCS lights...for about 200 miles when they came back on. Not triggered by wind. In fact, no trigger we could identify except freeway speeds (65-70 mph). So the wire harness overlay was once again removed and replaced and, so far, no warning lights have come on.

Newmar says itís a Ford issue b/c Ford wires the chassis. Ford says itís a Newmar issue b/c Newmar alters the wiring when it assembles and attaches the coach to the chassis. So weíre not sure where the problem originates.

We took SoCal Mikeís suggestion and filed a complaint with the National Highway Transportation Safety Administration. Quick and easy. While entering the VIN, we discovered that the coach is a model year 2021 but the chassis is a model year 2020.

Thank you JimBones for starting this thread, and for everybody else who contributed helpful information. I hope we were able to add something with our personal experience.
ClydeNBonnie is offline   Reply With Quote
Old 06-28-2021, 06:42 AM   #42
Junior Member
 
Join Date: Dec 2020
Posts: 23
I would think Ford would be quick to blame the Saf-T-Plus if any reason existed to think so.
I donít see how it would interfere.
Iím pissed that the first dealer wouldnít share the readings with me. ďItís just for usĒ.
About ready to pay an independent shop just to get a look at the info.
Ford will not!
CruzinAround is offline   Reply With Quote
Reply

Tags
ford, service



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2021 Anthem vs 2021 Aspire lands Entegra Owner's Forum 13 06-07-2020 01:04 PM
2021 Catalog of parts = Corrections Made= Changes for 2021 N.A. "007" Newmar Owner's Forum 1 05-09-2020 05:23 PM
Service Due message (what service?) Craig36 Spartan Motorhome Chassis Forum 7 12-19-2017 07:28 AM
How to cancel "Service due" message after scheduled service? Mauro Entegra Owner's Forum 2 07-16-2015 09:51 AM


All times are GMT -6. The time now is 10:45 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.