Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Ford Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-04-2021, 12:33 PM   #1
Junior Member
 
Join Date: Feb 2021
Posts: 10
P1131 - oxygen sensor replacement

Hello all,

I have looked through other threads and maybe I missed it (probably did). I am looking for the location of the bank 1 oxygen sensor. I have a 1999 Fleetwood Southwind 35s. Do I go at it from the doghouse or underneath? Also, I need to figure out how to locate the correct sensor, so if anyone has the part number or can explain how to go about looking for this part or any other part I may need down the road. Any help is greatly appreciated.
GATQ is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-04-2021, 01:21 PM   #2
Senior Member
 
Taffeys's Avatar
 
Join Date: Feb 2018
Location: Oceanside, California
Posts: 160
What Chassis?

You need to tell us what chassis is under your Fleetwood Southwind.
__________________
Charles
2007 Lazy Daze 23 1/2' Twin King (2007 Ford E450 SuperDuty Chassis)
Taffeys is offline   Reply With Quote
Old 02-04-2021, 03:49 PM   #3
Registered User
 
Ford Super Duty Owner
Join Date: Jun 2008
Location: Melbourne Fl
Posts: 2,590
Driver side is underneath in down pipe. Passenger side from dog house. Both easy. Spray penatrint night before use Ford brand for longer life. Use proper tool. Careful removing wire connectors. Plug and play.
# is 321 999 4555
1999 F53
Russ Silber is offline   Reply With Quote
Old 02-05-2021, 09:02 AM   #4
Junior Member
 
Join Date: Feb 2021
Posts: 10
Quote:
Originally Posted by Russ Silber View Post
Driver side is underneath in down pipe. Passenger side from dog house. Both easy. Spray penatrint night before use Ford brand for longer life. Use proper tool. Careful removing wire connectors. Plug and play.
# is 321 999 4555
1999 F53
Thank you. I’m guessing I should just replace both sensors? And part numbers should be on the sensors themselves?
GATQ is offline   Reply With Quote
Old 02-05-2021, 09:39 AM   #5
Senior Member
 
GypsyR's Avatar
 
Join Date: Jul 2019
Location: Upstate SC
Posts: 1,857
Every once in a while this code does actually indicate a faulty O2 sensor so it's probably worth a shot. The Bank 1 upstream sensor is the one closest to the engine on the passenger side.

If after replacement the code returns then there are other causes but the first thing on the list I'd look at is a vacuum leak at the intake.
GypsyR is offline   Reply With Quote
Old 02-05-2021, 12:01 PM   #6
Junior Member
 
Join Date: Feb 2021
Posts: 10
Quote:
Originally Posted by GypsyR View Post
Every once in a while this code does actually indicate a faulty O2 sensor so it's probably worth a shot. The Bank 1 upstream sensor is the one closest to the engine on the passenger side.

If after replacement the code returns then there are other causes but the first thing on the list I'd look at is a vacuum leak at the intake.
Thanks. I verified looking at live date that the sensor is showing 0 volts while the bank 2 sensor is showing .78 volts. So I think this time it is the sensor. Itís the most simple option. Cross your fingers I donít get the code back. 🤞🏽
GATQ is offline   Reply With Quote
Old 02-05-2021, 01:57 PM   #7
Senior Member
 
GypsyR's Avatar
 
Join Date: Jul 2019
Location: Upstate SC
Posts: 1,857
Thumbs up for actually troubleshooting versus just going by the code.
GypsyR is offline   Reply With Quote
Old 02-06-2021, 10:32 AM   #8
Senior Member
 
Join Date: Nov 2014
Location: TEJAS
Posts: 742
Just out of curiosity, what was the code number?
spyderRV is offline   Reply With Quote
Old 02-06-2021, 10:39 AM   #9
Senior Member
 
GypsyR's Avatar
 
Join Date: Jul 2019
Location: Upstate SC
Posts: 1,857
P1131, in the thread title.
GypsyR is offline   Reply With Quote
Old 02-07-2021, 12:18 PM   #10
Senior Member
 
Join Date: Nov 2014
Location: TEJAS
Posts: 742
Thanks! Eye got gOoD rEEdinG sKillZ!
spyderRV is offline   Reply With Quote
Old 02-07-2021, 01:50 PM   #11
Senior Member
 
GypsyR's Avatar
 
Join Date: Jul 2019
Location: Upstate SC
Posts: 1,857
I'm not pointing any fingers, I'm blind in that eye from time to time myself.
GypsyR is offline   Reply With Quote
Old 02-07-2021, 07:28 PM   #12
Junior Member
 
Join Date: Feb 2021
Posts: 10
I haven’t gotten the chance to get back over to the motorhome yet. As soon as I swap out the sensor and test drive 8 will advise. I will be there tomorrow but we are having a new fridge installed and our new microwave installed as well. Plus a new cabinet built. No driving it until later this week. But I will update how this goes. ��
GATQ is offline   Reply With Quote
Old 02-27-2021, 12:34 PM   #13
Junior Member
 
Join Date: Feb 2021
Posts: 10
Sooooooo, they had the coach longer than expected. **shocked**

I just raised the doghouse to visually inspect the sensor, what did I find? The sensor had detached from the nut. So yeah, definitely the sensor. Picking one up in a few minutes and Iím going to say itís safe to say that was the issue 🤣
GATQ is offline   Reply With Quote
Reply

Tags
ace, replace, replacement



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 Chevy 3500 Oxygen Sensor Error lynch763 Workhorse and Chevrolet Chassis Motorhome Forum 4 04-10-2017 10:34 PM
F53 Oxygen Sensor jdr37 Ford Motorhome Chassis Forum 7 11-06-2014 05:56 PM
On oxygen !! john65 RV Systems & Appliances 12 04-07-2007 02:26 PM
Traveling with oxygen D and S MH-General Discussions & Problems 4 01-03-2006 04:46 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:10 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.