Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Spartan Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-06-2021, 04:40 PM   #1
Member
 
Join Date: Oct 2015
Posts: 35
2003 Newmar DSDP Spartan side radiator heating problem under load

I posted this about 2 months ago and have more info. Scan gauge confirms the gauge is pretty accurate and got to the top of the hill and scan gauge said 215. Stopped at the top and checked top of thermostat with heat gun and it was 214. Bottom hose was 190, and runs 180 on flat, just changed both hyd. Filters in and out of tank. 4 years ago install new radiator, charge air cooler new had a leak thermostats and they are in right side up. Just wandering if anybody has one of these chassis, (they came under 2000 to 2003 newmar ds, fleetwoods any coach with a spartan chassis with the 350 isc and side radiator) and is having the same problem. I have checked cooling system pressure with a 15# cap never gets over 13#. Ambient temp that day was 95. I have rebuilt over 100 diesel engines and don't believe it's a head or head gasket problem and spartan is no help.
__________________
2003 NEWMAR DUTCH STAR 4005, 350 ISC, SPARTAN
2000 BMW 540I 6 SPEED
RV Wally is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-06-2021, 04:54 PM   #2
Senior Member
 
Mr_D's Avatar
 
Country Coach Owners Club
Solo Rvers Club
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 37,592
Had a 2002 DSDP on the Spartan, traded it in in the present rig in 2016. I installed the Banks Power Pack in 2006. Never had any overheating trouble before or after the Banks install. In fact it was the most trouble free unit I've ever owned.
__________________
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft, HWH Active Air
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '21 Jeep JLU Rubicon Ecodiesel
Mr_D is offline   Reply With Quote
Old 06-06-2021, 04:55 PM   #3
Senior Member
 
rvbiker45's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Apr 2015
Location: Dallas, TX area
Posts: 543
What was the RPM while going over the hill? And, the speed?
__________________
Don and Marilynn
'04 Newmar Dutch Star 4010
Spartan Chassis/Cummins ISL 400
rvbiker45 is offline   Reply With Quote
Old 06-07-2021, 11:20 AM   #4
Member
 
Join Date: Oct 2015
Posts: 35
2100 4th gear 45 mph
__________________
2003 NEWMAR DUTCH STAR 4005, 350 ISC, SPARTAN
2000 BMW 540I 6 SPEED
RV Wally is offline   Reply With Quote
Old 06-07-2021, 12:09 PM   #5
Senior Member
 
rvbiker45's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Apr 2015
Location: Dallas, TX area
Posts: 543
It could be possible that the fan is not getting into the high speed mode. It is my understanding that the fan has two speeds, controlled by a fan controller that is automatic. I do not know what causes the fan to go to high speed, but RPM is the probable trigger. I have heard of several operators where the controller malfunctioned.
__________________
Don and Marilynn
'04 Newmar Dutch Star 4010
Spartan Chassis/Cummins ISL 400
rvbiker45 is offline   Reply With Quote
Old 06-07-2021, 07:28 PM   #6
Member
 
Join Date: Oct 2015
Posts: 35
According to spartan the 2003 with 350 isc only has 1 speed and runs with engine rpm. Yours with the isl has a computer controlled valve that monitors temp and speeds up the fan when temp hits 210 and you have a bigger cooling package, your lucky i all ways seem to by 1 year to early. But because mr d had the same thing and never had a heating problem even after the banks install is getting me thinking. When i installed the new radiator i re plumbed the the cooling piping so that the water would flow from the thermostat to the top of the radiator and from the bottom back to the engine like all other cooling systems are plumbed. It was plumbed from the bottom to the top from the factory, maybe now the water is going to fast through the radiator and not getting cooled enough, we had that problem on the race cars and had to install a restriction in the top hose.
__________________
2003 NEWMAR DUTCH STAR 4005, 350 ISC, SPARTAN
2000 BMW 540I 6 SPEED
RV Wally is offline   Reply With Quote
Old 06-20-2021, 09:39 PM   #7
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 23,276
Quote:
Originally Posted by RV Wally View Post
According to spartan the 2003 with 350 isc only has 1 speed and runs with engine rpm. Yours with the isl has a computer controlled valve that monitors temp and speeds up the fan when temp hits 210 and you have a bigger cooling package, your lucky i all ways seem to by 1 year to early. But because mr d had the same thing and never had a heating problem even after the banks install is getting me thinking. When i installed the new radiator i re plumbed the the cooling piping so that the water would flow from the thermostat to the top of the radiator and from the bottom back to the engine like all other cooling systems are plumbed. It was plumbed from the bottom to the top from the factory, maybe now the water is going to fast through the radiator and not getting cooled enough, we had that problem on the race cars and had to install a restriction in the top hose.
Return coolant flow to normal bottom entry, top exit for better cooling efficiency.
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX,Infantry retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is offline   Reply With Quote
Old 06-21-2021, 10:30 AM   #8
Member
 
Join Date: Oct 2015
Posts: 35
Quote:
Originally Posted by ray,in View Post
return coolant flow to normal bottom entry, top exit for better cooling efficiency.
yes i have been thinking about doing that, does yours have the side radiator and have no heating problems
__________________
2003 NEWMAR DUTCH STAR 4005, 350 ISC, SPARTAN
2000 BMW 540I 6 SPEED
RV Wally is offline   Reply With Quote
Old 06-21-2021, 11:37 PM   #9
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 23,276
Quote:
Originally Posted by RV Wally View Post
yes i have been thinking about doing that, does yours have the side radiator and have no heating problems
Correct!
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX,Infantry retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is offline   Reply With Quote
Old 07-11-2021, 08:47 AM   #10
Senior Member
 
MoePo's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Join Date: May 2015
Posts: 235
I had a 02 DSDP that had opposite issues of what your having. My motor wasnít getting up to operating temp. There is a priority valve that diverts hydraulic fluid to the power steering and cooling fan. Follow the hose from the hydraulic motor on the fan you will see a manifold block. Thatís your priority valve Perhaps your cooling fan isnít spinning fast enough? I ended having to slow my fan down with a few turns of a Allen key. Maybe you need to do the opposite.
__________________
2004 Travel Supreme DS04
2014 Jeep Grand Cherokee Summit
2002 Newmar DSDP 4095 Cummins ISC 350
MoePo is offline   Reply With Quote
Old 07-12-2021, 10:04 AM   #11
Member
 
Join Date: Oct 2015
Posts: 35
Yes i have seen that valve did not know it was adjustable, i will check it out. Did you turn it in or out.
__________________
2003 NEWMAR DUTCH STAR 4005, 350 ISC, SPARTAN
2000 BMW 540I 6 SPEED
RV Wally is offline   Reply With Quote
Old 07-12-2021, 05:46 PM   #12
Senior Member
 
MoePo's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Join Date: May 2015
Posts: 235
Quote:
Originally Posted by RV Wally View Post
Yes i have seen that valve did not know it was adjustable, i will check it out. Did you turn it in or out.


I canít remember. I want to say I turned it counter clockwise. But It definitely slowed it down. Operating temps went from 180 to 195. Hard pull would bring me up to around 208ish. Never higher than that. Most of my travels were up and down i77 in the Smokey mountains
__________________
2004 Travel Supreme DS04
2014 Jeep Grand Cherokee Summit
2002 Newmar DSDP 4095 Cummins ISC 350
MoePo is offline   Reply With Quote
Old 07-13-2021, 10:41 AM   #13
Member
 
Join Date: Oct 2015
Posts: 35
I ordered a digital rpm laser gun to check rpm, I will play with it when I get it.
__________________
2003 NEWMAR DUTCH STAR 4005, 350 ISC, SPARTAN
2000 BMW 540I 6 SPEED
RV Wally is offline   Reply With Quote
Old 07-14-2021, 10:16 AM   #14
Member
 
Join Date: Oct 2015
Posts: 35
Did oil leak out when you unscrewed the allen plug?
__________________
2003 NEWMAR DUTCH STAR 4005, 350 ISC, SPARTAN
2000 BMW 540I 6 SPEED
RV Wally is offline   Reply With Quote
Reply

Tags
heat, heating, newmar, problem, radiator, spartan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 W22 Under Load produces "pop", "pop", then OK geofferyh Workhorse and Chevrolet Chassis Motorhome Forum 16 05-27-2021 04:37 PM
Onan 5500 Generator runs fine under load shuts off with no load zduffie iRV2.com General Discussion 6 02-13-2019 05:01 PM
Load range F vs. Load range G Txcirclem Class A Motorhome Discussions 18 06-17-2013 04:03 AM
Load Range D vs Load Range E royjeri 5th Wheel Discussion 29 07-29-2011 04:30 AM
engine heating up-side radiator Motorhome05 Winnebago Industries Owner's Forum 6 03-13-2009 11:07 PM


All times are GMT -6. The time now is 09:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.