Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Spartan Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-15-2010, 06:04 PM   #1
TGA
Junior Member
 
Join Date: Aug 2010
Posts: 2
J1939 Communication Fault

Has anyone experienced a "J1939 Communication Fault"? We experienced a warning (light and shrill sound) after pulling into our site. There were no issues during the drive, but the warning sound continued even after we removed the key from the ignition. We started the RV again, put it in gear and put back in gear, etc. but the warning sound continued.
TGA is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-16-2010, 05:33 AM   #2
Senior Member
 
CC38EL's Avatar
 
Join Date: Aug 2002
Location: same
Posts: 540
A little more information is needed. What kind of RV, engine, chassis, transmission, year?

What light is showing? How did you get a J1939 error displayed? Do you have a Road Relay or some other kind of engine monitor?

J1939 is the data link protocol that allows the engine, transmission, and other electronic devices on your coach communicate. If you're getting this error, it's possible you have a disconnected cable somewhere around the engine control module, fuel pump, transmission controller, engine computer monitor, etc.

From what you said, it sounds like the engine still starts and runs.

Are the jacks down when you start your engine? ( I hate that noise)
__________________
Jim
2019 Coachmen Mirada Select 37LS
CC38EL is online now   Reply With Quote
Old 08-18-2010, 10:31 AM   #3
TGA
Junior Member
 
Join Date: Aug 2010
Posts: 2
We have a 2008 42ft. phaeton with diesel Cumings 360 HP, Spartan chassis, Allison transmission. The warning message and sound appeared after we pulled into our site after an 8 -9 hour drive. The sound continued even after shutting off the engine and removing the key. The levels were down. After almost an hour, the noise finally stopped. We called Spartan and the technician asked if we had driven through any rain during the day. He said that most likely that was the cause for the message and alarm and that is is nothing to worry about.
TGA is offline   Reply With Quote
Old 08-18-2010, 08:44 PM   #4
Senior Member
 
CC38EL's Avatar
 
Join Date: Aug 2002
Location: same
Posts: 540
His answer seems logical, but it also means you have a cable or connector that is exposed to water. You'll probably experience this again.

You might want to have someone crawl under the engine compartment and just take a look at your ECM connections and cables.

Hope you find the cause and don't have this happen anymore.
__________________
Jim
2019 Coachmen Mirada Select 37LS
CC38EL is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Magnum Inverter Fault Gordon Monaco Owner's Forum 9 07-07-2013 09:25 AM
Retreiving engine fault codes bdpreece Freightliner Motorhome Chassis Forum 14 12-16-2010 11:11 AM
Fault Codes - Guide? markpj23 Monaco Owner's Forum 6 06-21-2010 10:28 AM
Inverter in Fault Mode - Water Pump Issue Renipladlo Alpine Coach Owner's Forum 13 04-19-2010 11:19 PM
Check Engine J1939 fault plootsa Freightliner Motorhome Chassis Forum 1 03-16-2010 08:22 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.