Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Spartan Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-20-2022, 10:10 PM   #1
Member
 
Join Date: Aug 2021
Posts: 49
Onan not starting

10HDCAA11608A Model, lots of clicking when I hit the start button, two different sounds, none coming from the start, a rapid clicking either on start or pre start and then a single click that maybe a fuel shut off? Cleaned battery hook up, no change, got the top cover off, tapped on the starter, no change. So does anyone have a service manual or an algorithm to diagnose? My next step would be to pull the muffler and remove the starter to test? Thank you for all help!!
Wedlt is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-21-2022, 04:17 AM   #2
Senior Member


 
Join Date: Oct 2016
Location: Rendon, Texas
Posts: 1,394
I sometimes have to hold the start button down for 30 seconds before it will actually turn over and start. During that 39 seconds, there will be all kinds of clicking then the starter engages and it starts very quickly.

Before you blindly start working on the generator, check the starter button light codes. These codes will give you a good indication of the problem at hand. You can find the chart for these codes in the manual or on the web.
__________________
May your smiles be many and the miles be plenty.

Karen & Allen Van Zandt
txcpl is offline   Reply With Quote
Old 05-21-2022, 10:28 AM   #3
Senior Member
 
Join Date: Mar 2019
Posts: 1,235
How long are you holding down the switch? As stated, it can take a while.
bentjm is online now   Reply With Quote
Old 05-21-2022, 09:07 PM   #4
Senior Member
 
Rob_M's Avatar
 
Join Date: Dec 2019
Location: Canyon Lake, Texas
Posts: 2,483
The clicking you hear is the fuel pump. Depending on how cold it is, the longer you have to hold down the start button while it pre-heats. In cold weather it can seem like a really long time.
__________________
2002 American Tradition 40'
Cummins 8.3, Banks 431hp, 1260 tq
Canyon Lake, TX
Rob_M is online now   Reply With Quote
Old 06-06-2022, 03:09 PM   #5
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 8,144
Quote:
Originally Posted by Rob_M View Post
The clicking you hear is the fuel pump. Depending on how cold it is, the longer you have to hold down the start button while it pre-heats. In cold weather it can seem like a really long time.


One other thing if you donít have around 1/4 it will just click because it canít prime.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 06-06-2022, 10:45 PM   #6
Member
 
Join Date: Aug 2021
Posts: 49
Thanks for the ideas

KISS principal strikes again, 300amp in line fuse from the batteries, looked good but when continuity checked proved to be bad. New fuse, starting fine!!
Wedlt is offline   Reply With Quote
Old 06-10-2022, 12:23 PM   #7
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 8,144
Quote:
Originally Posted by Wedlt View Post
KISS principal strikes again, 300amp in line fuse from the batteries, looked good but when continuity checked proved to be bad. New fuse, starting fine!!


If fuse was blown how did it have power to make the clicking fuel pump noise? Inquiring minds would like to know.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 06-10-2022, 11:33 PM   #8
Member
 
Join Date: Aug 2021
Posts: 49
Amperage across the fuse was not normal although fuse looked good. I can only assume enough power for fuel pump but not starter?
Wedlt is offline   Reply With Quote
Reply

Tags
not starting, onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan Genset NHE not starting... 88Shasta RV Systems & Appliances 6 10-04-2013 03:18 PM
pace arrow 1990 onan generator not starting grits58 Fleetwood Owner's Forum 38 06-30-2013 10:47 AM
4000 microlite Onan not starting art(alamoc) MH-General Discussions & Problems 4 07-15-2009 08:27 PM
Onan Genset 5500 gas HGJAB model not starting always udbe2 RV Systems & Appliances 9 05-19-2009 06:55 PM
onan not starting jerry davis Alpine Coach Owner's Forum 5 10-23-2005 01:49 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 08:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.