Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Spartan Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-09-2014, 02:51 PM   #1
Senior Member
 
Dave Killey's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Langley, BC
Posts: 275
Wiper & Cruise controls do not work on steering wheel

Hello. I have had this problem before, but it just fixed itself until now. The steering control for the wipers and the cruise control are going funky. Sometime one button works, then sometime another button works. Then they all might work for a few minutes. I have taken the cover off the steering column and check for loose wires but nothing seems to trigger it. My steering wheel has two sets of controls, right side has wipers and left side has cruise controls. I have also noticed the 4 way flashers are going on once I start engine but shut off after about 15 seconds.
Should I buy a new coach or is this fixable....LOL. Any help would be appreciated and welcomed.
__________________
David Killey
2004 Newmar, Mountain Aire 40ft, DP
Langley, BC, Canada, 2011 GMC Sierra Pick UP is our toad.
Dave Killey is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-09-2014, 02:58 PM   #2
Senior Member
 
palehorse89's Avatar
 
Newmar Owners Club
Join Date: Oct 2009
Posts: 9,094
Hi Dave, here is some threads https://www.google.com/search?q=func...+site:irv2.com with smart wheel problems for you to look at till others chime in......
__________________
2012 Essex 4544 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006 Ultra & 1989 Springer
palehorse89 is offline   Reply With Quote
Old 03-09-2014, 04:21 PM   #3
Senior Member
 
Cat320's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Join Date: Mar 2011
Posts: 6,037
Some 'smart' engineer assembled part of my Smart Wheel backwards. On the cruise control side, to "accel" I push "decel" and to "decel" I push "accel."
__________________
2014 American Eagle 45T
DD 13, 500 HP
Pulling a Honda CRV
Cat320 is offline   Reply With Quote
Old 03-09-2014, 04:41 PM   #4
Junior Member
 
Krazy grandpa's Avatar
 
Join Date: Jul 2010
Posts: 5
I had something similar, called smart wheel they diagnosed the problem and sent new button assembly's. Reasonable price and easy to replace.
__________________
Crazy Grandpa
2009 allegro Bus
43 QRP.
Krazy grandpa is offline   Reply With Quote
Old 03-10-2014, 06:07 AM   #5
Senior Member
 
Join Date: Apr 2011
Location: South Chesterfield, Virginia
Posts: 363
l had a problem with my smart wheel a few years back and it was the motherboard.
Catch14me is offline   Reply With Quote
Old 03-16-2014, 08:03 PM   #6
Senior Member
 
DA_BUS's Avatar
 
Join Date: Sep 2011
Location: SE Minnesota
Posts: 383
I had a similar problem and eventually the wipers wouldn't work. I called and ordered a new "ring" that fits in the steering wheel....easy to replace - fixed everything.
DA_BUS is offline   Reply With Quote
Old 04-04-2014, 07:32 AM   #7
Senior Member
 
Spartan Chassis
Join Date: Dec 2011
Location: Anywhere, USA
Posts: 431
If your control box gets exposed to any moisture, say from the Newmar extendable windshield squeegee in the electrical compartment, the wheel controls can get iffy. If this has occurred get some electrical contact cleaner and clean the box connection points and dry the compartment.

My sewer slinky was dirty so I hosed it off and stored it in the electrical compartment and went down the road. Guess what happened to my wiper mounted controls?
shaman52 is offline   Reply With Quote
Old 04-24-2014, 02:37 PM   #8
Junior Member
 
Join Date: Apr 2014
Posts: 1
The same thing happened to us today. We went to Shortys Bear Safety Service in Amarillo, TX and they discovered that some of the connections on the board in the steering wheel were broken. They soldered them back. All systems are now a go. Thanks to Shortys!
Poberman is offline   Reply With Quote
Old 04-24-2014, 02:42 PM   #9
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,772
Quote:
Originally Posted by Poberman View Post
The same thing happened to us today. We went to Shortys Bear Safety Service in Amarillo, TX and they discovered that some of the connections on the board in the steering wheel were broken. They soldered them back. All systems are now a go. Thanks to Shortys!


Poberman; First post I see.
Great to have you with us.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is online now   Reply With Quote
Old 04-13-2017, 12:12 PM   #10
Junior Member
 
Join Date: Apr 2017
Posts: 6
My cruise control will not work and all other controls on the steering will not work either. This is on a 2014 tiffin bus. Any ideas
garmat is offline   Reply With Quote
Old 04-13-2017, 12:33 PM   #11
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,772
Quote:
Originally Posted by garmat View Post
My cruise control will not work and all other controls on the steering will not work either. This is on a 2014 tiffin bus. Any ideas
Garmat; Welcome to iRV2.

The signals from the switches on the steering wheel to the smart wheel control box are carried through a " Clock Spring " assembly under the steering wheel , the clock spring is a spiral wire that coils and uncoils as you turn the wheel and can develop cracks and broken wires that COULD be your problem. First you should check for proper power and ground at the control box .
What chassis is your coach built on, is it Spartan ? Same as the original poster?
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is online now   Reply With Quote
Old 04-13-2017, 03:47 PM   #12
Junior Member
 
Join Date: Apr 2017
Posts: 6
Yes it is a 2014 tiffin bus on the spartan Chassis. Is the clock spring easy to replace by myself.
garmat is offline   Reply With Quote
Old 04-14-2017, 08:14 PM   #13
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,772
Steering wheel has to be removed to access the clock spring assembly then wiring has to be pulled up the steering column , but there would be testing to be done before you dive in .
A call to Spartan with your serial number , would provide info on checking fuses and grounds on the control module , that the clock spring supplies info to.

Spartan motor home support.

1-800-543-4277
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is online now   Reply With Quote
Old 04-17-2017, 06:43 AM   #14
Senior Member
 
Mainuh's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: May 2015
Posts: 163
Smart wheel issues

Hi Guys and gals,

Dave, I'm not sure this is your issue but it may well be worth checking for you and garmat.

When I was in the process of purchasing my 08 MADP, the smartwheel controls weren't working at all. The dealer investigated and said they ended up replacing to control modules for them after taking it all apart. I was told those modules were $600/ea (CDN). So after we picked it up and it all worked, life was good. But, within a couple months I was going down the road and noticed my cruise wasn't working. Tried my wipers and they didn't work either. On my MA, I have electric controls for wheel elevation and tilt on tabs beside the cruise and wipers and they didn't work either. I was very upset that the new controls stopped working so quickly.

But after some investigation and forum searches, I went down into the basement compartment under the driver where the 12vdc controls are for the truck and in the lower right in there is a small black "wheel decoder" box with a few plugs going into it. I made sure all those plugs were properly seated, went back up top and tried my wheel controls and low and behold they worked. Subsequent times as it has had issues I've narrowed my issue down to the 4 pin plug on lower right of that box. The plug after 10 years just isn't seating quite as tight. All it ever takes is barely touching it with my fingers and the controls work fine again.

Just want to throw this out there for those of you with a total loss of function. Electrical connections are the bane of these units and 75+% of my issues have been electrical connection related. Get some good de-oxidizing spray and pull apart any connections that are suspect and give them a shot.

Here's a shot of the compartment with decoder box at lower right. You can't see the 4 pin plug at lower right of the box as it's obscured by wires, but you can see the 4 wires that go into it. All I do is wiggle that bad boy and the whole smart wheel works again. I guess I should see if I could get a new plug assembly that may fit tighter.
__________________
Cheers! Don
2019 Grand Design Imagine 2500RL
2020 Ram 1500 Limited 4X4
Mainuh is offline   Reply With Quote
Reply

Tags
cruise control, steering



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hi from SW CO - How much 5th Wheel Can I Tow? BOBCO 5th Wheel Discussion 34 02-20-2014 10:38 AM
From FT TT to 5th wheel... GretkasonRD Full-Timers 8 02-11-2014 06:47 PM
Freightliner Smart Wheel brian-nicola Fleetwood Owner's Forum 9 02-04-2014 09:14 PM
Cruise Control Failure '98 Tradewinds tradewinds98 National RV Owner's Forum 6 12-14-2013 03:47 PM
Steering wheel knob WineLuvrs Class A Motorhome Discussions 25 10-05-2013 09:51 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:06 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.