RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Forest River Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-14-2020, 02:27 PM   #1
Member
 
Join Date: Mar 2019
Posts: 51
2017 Pursuit Camera problem

[Mod Edit]
I have a problem, all my cameras quit at the same time. They were working when we left for Michigan this morning. The Monitor now displays nothing. The array of blue lights under monitor light up but power switch does nada. Checked all fuses under dash after we arrived, and all good.???
Any ideas or help appreciated.


2017 Forest River Pursuit F53 chassis Model FW30
Bytesponge is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-17-2020, 09:50 AM   #2
Senior Member
 
Stevegd007's Avatar
 
Forest River Owners Club
Ford Super Duty Owner
Join Date: Mar 2005
Location: San Diego County, California
Posts: 785
Is the monitor part of the radio display?
I ask cause mine is. An the setting to display the camera video can be frustratingly difficult to get to video display back on the screen. The turn single display will seemly always work. But the rear camera needs a "special" setting in the radio settings to show the rear camera while driving. Sometimes, for unknown reason, I have to reset the setting to recover the rear camera view. errr....
__________________
Steve & Leslie
Forest River 2018 Forester 3011DS
Honda 2010 CR-V AWD "Toad"
Stevegd007 is offline   Reply With Quote
Old 10-17-2020, 10:40 AM   #3
Member
 
Join Date: Mar 2019
Posts: 51
Question Camera out

Quote:
Originally Posted by Stevegd007 View Post
Is the monitor part of the radio display?
I ask cause mine is. An the setting to display the camera video can be frustratingly difficult to get to video display back on the screen. The turn single display will seemly always work. But the rear camera needs a "special" setting in the radio settings to show the rear camera while driving. Sometimes, for unknown reason, I have to reset the setting to recover the rear camera view. errr....
Thanks for replying to my post. Any help is welcome.
The latest is the Monitor (not part of radio) flashed on and off just before we got back home from Michigan. (It rained there and it rained here).
I need to figure out how to get behind the unit and look for loose connections!
All the cameras went out when we first bought rig on our way to 29Palms.
Took it back to LaMesa RV under expensive warranty. They said one fuse fell out??? and another was missing??? How did it ever work? Naturally fuses are not covered. Cost me $200. for a missing and fallen out fuse. Cancelled warranty shortly after that incident.

Camera came on momentarily stuck on right turn. Probably have to remove unit from dash?
Sorry about rambling!
Bytesponge is offline   Reply With Quote
Old 10-17-2020, 12:15 PM   #4
Senior Member
 
Stevegd007's Avatar
 
Forest River Owners Club
Ford Super Duty Owner
Join Date: Mar 2005
Location: San Diego County, California
Posts: 785
My last RV, a Class A, had a B/W monitor built into the drivers dash. The entire Dash could be lifted up, the forward part was hinged. But you had to use a stick to prop it open to work on it. An you almost had to stand on your head to get at stuff. Needless to say I never did. Just left it B/W. But it always worked.
Sorry yours if difficult. New should not be.
My current Class C has a Jensen house radio that is problematic. Don't do Jensen radios. There crap.
__________________
Steve & Leslie
Forest River 2018 Forester 3011DS
Honda 2010 CR-V AWD "Toad"
Stevegd007 is offline   Reply With Quote
Old 10-17-2020, 01:57 PM   #5
Member
 
Join Date: Mar 2019
Posts: 51
Nice looking rig you have there!
My dash is a bear to get behind! May have to employ DW's small limbs.
We shall see what we find. Will post findings. It may help others with similar rigs/problems.
Bytesponge is offline   Reply With Quote
Old 10-17-2020, 02:13 PM   #6
Senior Member
 
Stevegd007's Avatar
 
Forest River Owners Club
Ford Super Duty Owner
Join Date: Mar 2005
Location: San Diego County, California
Posts: 785
Thanks!
__________________
Steve & Leslie
Forest River 2018 Forester 3011DS
Honda 2010 CR-V AWD "Toad"
Stevegd007 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Coachmen: Camera and dash monitor broke: 2014 Coachmen Pursuit wfcentral Forest River Owners Forum 4 10-07-2014 02:52 PM


All times are GMT -6. The time now is 10:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.