RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Forest River Owners Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-27-2020, 07:20 PM   #1
Junior Member
 
Join Date: Mar 2020
Posts: 2
Furnace problem

First time poster. I have a 2008 coachman Catalina with very limited use that I picked up used. Furnace worked fine, then with no other changes, it blows the fuse as soon as it turns on now. Any ideas???
__________________

Schmir is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-27-2020, 07:41 PM   #2
Member
 
Winnebago Owners Club
Join Date: May 2019
Posts: 86
My first thought would be a short in the blower motor wiring.
__________________

__________________
2019 Winnebago Forza 36G
2018 Jeep Wrangler Sahara
2Newsomes is offline   Reply With Quote
Old 03-27-2020, 09:05 PM   #3
Senior Member
 
Ljwt330's Avatar
 
Join Date: Jan 2018
Location: Capistrano Beach, California
Posts: 1,845
Quote:
Originally Posted by 2Newsomes View Post
My first thought would be a short in the blower motor wiring.
This^^, or a seized motor. The motor is the first thing to run when the furnace goes on, so it makes sense the problem is with the motor circuit.
__________________
Larry, Eileen, and Finley
2004 Alpine 36FDDS
Third motor home, first Alpine, no need for another.
Ljwt330 is offline   Reply With Quote
Old 03-27-2020, 10:29 PM   #4
Senior Member
 
bob caldwell's Avatar


 
Join Date: May 2017
Location: Vancouver Wash
Posts: 5,961
Mud daubers have built a nest inside the non screened off intake, or exhaust....
__________________
2010 Rockwood Sig Ultra lite 5er 8280......'99 Ram 2500, Cummins. 4x4.....Pullrite Superglide.......Use to work in calender factory.....got fired for tak'n a few days off.....RV Mutant 186.....Bob the Builder...
bob caldwell is offline   Reply With Quote
Old 03-28-2020, 10:52 AM   #5
Junior Member
 
Join Date: Mar 2020
Posts: 2
Furnace is fixed

It was a birds nest in air intake. Thanks for the ideas!
Schmir is offline   Reply With Quote
Old 03-28-2020, 10:58 AM   #6
Senior Member
 
bob caldwell's Avatar


 
Join Date: May 2017
Location: Vancouver Wash
Posts: 5,961
Time for screens!.....Glad you found it....
Quote:
Originally Posted by Schmir View Post
It was a birds nest in air intake. Thanks for the ideas!
__________________
2010 Rockwood Sig Ultra lite 5er 8280......'99 Ram 2500, Cummins. 4x4.....Pullrite Superglide.......Use to work in calender factory.....got fired for tak'n a few days off.....RV Mutant 186.....Bob the Builder...
bob caldwell is offline   Reply With Quote
Old 03-28-2020, 11:00 AM   #7
Senior Member
 
bob caldwell's Avatar


 
Join Date: May 2017
Location: Vancouver Wash
Posts: 5,961
Nedd to screen off watwe
Quote:
Originally Posted by bob caldwell View Post
Time for screens!.....Glad you found it....
Need to screen off water heater, fridge, reefer, and A/C shroud openings also....
__________________

__________________
2010 Rockwood Sig Ultra lite 5er 8280......'99 Ram 2500, Cummins. 4x4.....Pullrite Superglide.......Use to work in calender factory.....got fired for tak'n a few days off.....RV Mutant 186.....Bob the Builder...
bob caldwell is offline   Reply With Quote
Reply

Tags
ace, furnace, problem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Furnace fan 2002 Alpine (Suburban gas furnace) dlmoo1 Alpine Coach Owner's Forum 5 01-21-2020 10:31 PM
Suburban NT-45S Furnace or Furnace motor Ronbstewart Monaco Owner's Forum 7 05-25-2018 08:15 PM
Furnace problem may not be in the furnace! turkeychuckt MH-General Discussions & Problems 3 02-03-2010 03:26 PM
Furnace problem? rlrich Excel Owner's Forum 8 01-15-2009 10:48 AM
furnace or thermostat problem georgetown350 MH-General Discussions & Problems 12 05-02-2007 03:57 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:07 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×