RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-27-2017, 01:04 PM   #1
Senior Member
 
Winnebago Owners Club
Join Date: May 2015
Posts: 109
2006 Beaver Coach Trans Temp Gauge issues

I have a 2006 Beaver Monterey Laguna IV coach. On a recent trip I noticed my Transmission Temp Gauge only moving up about 25% (1/4) on the gauge after driving over 100 miles. Usually in the past it has ran at about mid/center (50%) of the gauge. About the same as the Water Temp gauge. It has always taken about 10 miles for the Trans Temp to warm up to its normal operating temperature. The weather was in the upper 40s/50s. I haven't tracked down the sensor on the transmission yet to check its connection, etc. Any suggestions. Thanks
Navion 24J is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-27-2017, 01:40 PM   #2
Community Moderator
 
barmcd's Avatar


 
Monaco Owners Club
Texas Boomers Club
Join Date: Nov 2015
Location: Central Texas
Posts: 12,694
My transmission runs considerably cooler than my engine, especially in cooler weather. My Cummins runs somewhere around 190 degrees and the Allison temp usually hoovers around 175, but goes as low as 140 on flat and level terrain.
__________________
Dennis and Katherine
2000 Monaco Dynasty
barmcd is offline   Reply With Quote
Old 03-27-2017, 01:48 PM   #3
Senior Member
 
96 Wideglide's Avatar
 
Holiday Rambler Owners Club
Join Date: Aug 2010
Posts: 6,835
Does your Beaver have the Aladin system?
__________________
Ben & Sharon
2008 43' Holiday Rambler Scepter PDQ
96 Wideglide is offline   Reply With Quote
Old 03-27-2017, 02:08 PM   #4
Senior Member
 
Winnebago Owners Club
Join Date: May 2015
Posts: 109
Trans temp gauge issue

Yes it has the Aladdin, I will check to see what its showing on the Trans Temp reading for comparison purposes. I forgot to mention that I do have the Cat Engine (400hp) C9 (2005) Thanks
Navion 24J is offline   Reply With Quote
Old 03-27-2017, 02:19 PM   #5
Senior Member
 
336muffin's Avatar
 
Join Date: Apr 2011
Posts: 2,569
My C9 Cat runs at 204* trans runs at 206* -208*
__________________
American Tradition 42R-Cadillac SRX Blue Ox Koni 5050XL MCD Scangauge D Samsung rf197
Fulltime since 2012
336muffin is offline   Reply With Quote
Old 03-27-2017, 04:31 PM   #6
Senior Member
 
2 Stroker's Avatar
 
Join Date: Nov 2009
Location: Warren, Oregon
Posts: 2,467
The only real temps I see are from my Silverleaf because the dash gauges are way off, maybe up to 15 deg on the trans and 10 lbs on the motor. I started see motor temps going up to 210 last year it was 204 then my fan would come on then down to 196 and the trans would follow.
Had the wax valve installed what a difference. Now my motor run up to 194 deg then down to 170 deg and the trans runs 170 deg all the time now, plus when the fan come on you can hear it, worth every penny
2 stroker
__________________
2006 Country Coach Inspire 360 40ft Genoa Designer Series, Samsung 197 RR
Cat C9--STEEL & COPPER Bolt Together Radiator w/ updated rubber mounting
SilverLeaf 330 Magnum 2812 PSW 2011 Ford Edge Sport-Air Force One
2 Stroker is offline   Reply With Quote
Reply

Tags
beaver



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine temp/pressure and trans temp gauges are malfunctioning... chofujohn Cummins Engines 6 10-17-2015 10:32 PM
Engine temp gauge died, now trans. temp gauge dead. PeterBlack Monaco Owner's Forum 2 07-23-2012 10:17 PM
Scan Gauge Prog Trans Temp Ernie n Tara MH-General Discussions & Problems 3 07-09-2010 08:18 AM
Allison Trans Temp Gauge R.Shomo Workhorse and Chevrolet Chassis Motorhome Forum 10 11-19-2008 10:19 AM
allison trans temp gauge sal avitabile Workhorse and Chevrolet Chassis Motorhome Forum 31 09-07-2006 10:08 AM


All times are GMT -6. The time now is 05:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.