RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-10-2018, 09:05 PM   #1
Junior Member
 
Join Date: Jul 2018
Posts: 3
97 Fleetwood engine problem

Hello,

I’m not sure if this is the right place to ask this question… If it isn’t please forgive me. This is my first time posting anything.
My name is Billy, I have a 34 foot 1997 Fleetwood bounder with a P – 30 Chevy chassis. It has a 454 engine in it. When I was driving it home a while back the engine just died. It will crank but it will not turn over.
My friend he’s pretty mechanical has done the following:
- put a voltmeter on the fuses and they are all good
- said that he feels like there’s a spark because it’s backfiring intermittently
- we replace the ECM (computer), But that didn’t fix it.

Again, it just cranks but it won’t turn over. Has anyone had this problem or know what this might be ?
Bsarno is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-10-2018, 09:09 PM   #2
Senior Member
 
tderonne's Avatar
 
Join Date: Dec 2003
Location: Motor City, Mich
Posts: 2,990
Is the tach moving? Could be a bad crank sensor. They are known to go bad. No tach is a symptom of no RPM signal.

My sister's '99 went bad. It was kind of intermittent though. Still worth checking.
__________________
Tim.

tderonne is online now   Reply With Quote
Old 07-10-2018, 09:12 PM   #3
Junior Member
 
Join Date: Jul 2018
Posts: 3
Ok that’s helpful. Thank you. We will check that.
I also welcome any other thoughts you might have.
Bsarno is offline   Reply With Quote
Old 07-10-2018, 09:56 PM   #4
Senior Member
 
Join Date: Aug 2017
Posts: 305
How about fuel pump is the engine getting any fuel, is there spark at the plugs
keger is offline   Reply With Quote
Old 07-10-2018, 10:05 PM   #5
Senior Member
 
lonfu's Avatar
 
Newmar Owners Club
Winnebago Owners Club
Freightliner Owners Club
Join Date: Mar 2016
Location: Kingman Az
Posts: 1,219
Spark and fuel. Sounds like you have spark, I'd check the fuel pressure. Pull your wires and see if there is spark. start at these points.
__________________
May your black water hose never break!
lonfu is offline   Reply With Quote
Old 07-10-2018, 11:29 PM   #6
Junior Member
 
Join Date: Jul 2018
Posts: 3
Thank you, each of your posts have been helpful.
Bsarno is offline   Reply With Quote
Reply

Tags
engine, fleetwood



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Considering purchase of 2009 Fleetwood Excursion 40T or Fleetwood Storm 35SK Newbiervrr Fleetwood Owner's Forum 6 04-22-2016 12:52 PM
Fleetwood 2015 Fleetwood water tank not working stumac RV Systems & Appliances 6 11-19-2015 02:50 PM
Fleetwood To Break New Ground With Launch Of Fleetwood Vacation Club In Spring 2005 DriVer RV Industry Press 2 01-21-2005 01:34 AM


All times are GMT -6. The time now is 11:52 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.