Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-28-2017, 07:56 PM   #1
Member
 
Join Date: Oct 2016
Location: East Texas
Posts: 44
Question Aqua Heat problem

I have a 2007 Monaco Dynasty Emperor IV with the Aqua Heat system. Not sure what model I have but I used an inspection camera to come up with the following info: AHE100? AH060904? S/N (maybe) 721477. They have hid the info behind a panel that is not removable of course. I just had the Aqua Heat serviced Motor Homes of Texas to include a new nozzle and cleaning of the burner. I took the coach home and now I have a Zone 4 light,Pump 2 light, and Low Temp Cutoff status light on in the A/H bay. The small 12 volt fan is also constantly running. I tried to adjust the temp up and down but that doesn't seems to do anything to stop the fan from running or eliminate the lights. I also cut the shore power and also used the two disengage toggle switches to remove power which did cut of power and stop the fan but when reengaged the fan and lights returned. I also recycled all the HVAC zones in the thermostats in the coach and started and shut off the Aqua Heat diesel mode. First coach with an A/H system so I'm starting off at zero level of experience but I have read the coach manual and a pdf file for the A/H 525D. Not sure what model my A/H is but it looks like a 50,000 BTU unit. I will call the dealership back tomorrow and keep searching on the internet. Any suggestions would be appreciated. Thanks. Joe & Lynda
jturbo10 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-29-2017, 06:19 AM   #2
Senior Member
 
djhinds's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Golden, Colorado
Posts: 825
You need to join Roger Berke's "Aqua Hot Forum".. He is all knowing about Aqua Hots and answers questions very fast.

RV Hydronic Heater Forum


Dave
__________________
2004 Monaco Signature with a Detroit 60, Vorad Radar, Samsung Fridge, Induction cook top, 2020 GMC Denali
djhinds is offline   Reply With Quote
Old 03-29-2017, 06:47 AM   #3
Senior Member
 
Busskipper's Avatar
 
Join Date: Sep 2007
Location: Grasonville, MD -- Golden, CO
Posts: 6,222
Quote:
Originally Posted by jturbo10 View Post
I have a 2007 Monaco Dynasty Emperor IV with the Aqua Heat system.

Not sure what model I have but I used an inspection camera to come up with the following info: AHE100? AH060904? S/N (maybe) 721477.

They have hid the info behind a panel that is not removable of course. I just had the Aqua Heat serviced Motor Homes of Texas to include a new nozzle and cleaning of the burner. I took the coach home and now

I have a Zone 4 light,

Pump 2 light, and

Low Temp Cutoff status light on in the A/H bay.

The small 12 volt fan is also constantly running.

I tried to adjust the temp up and down but that doesn't seems to do anything to stop the fan from running or eliminate the lights.

I also cut the shore power and also used the two disengage toggle switches to remove power which did cut of power and stop the fan but when reengaged the fan and lights returned.

I also recycled all the HVAC zones in the thermostats in the coach and started and shut off the Aqua Heat diesel mode.

First coach with an A/H system so I'm starting off at zero level of experience but I have read the coach manual and a pdf file for the A/H 525D.

Not sure what model my A/H is but it looks like a 50,000 BTU unit.

I will call the dealership back tomorrow and keep searching on the internet. Any suggestions would be appreciated.

Thanks. Joe & Lynda
AHE100

http://www.aquahot.com/eSource/ecom/...09-27-2011.pdf

Love the fact that they have all those lights but what is the FIX?

I'm no expert but have read and worked on mine from the day we got it -and I still think it's the best system out there BUT they require a lot of attention and work.

After reading and doing so much on my system I am starting to think that the issue "Might be " Not enough use - causing the coolant used to just get bad - gummy - gritty - gunky - any word you can use to just say trashed up.

Mine unit has been sitting a lot as we were taking care of the Mother In Law and only traveled by air - it has many of the similar symptoms, thinking I just need to drain the Anti Freeze, clean and refill. Problem is $$$ but all the problems are $$$ as are the solutions.

https://www.chemworld.com/Boiler-Ant...e-p/cwba-5.htm

http://aquahot.com/FAQs.aspx#antifreezetypes

"Aqua-Hot Heating System Antifreeze

Terms

Antifreeze and Boiler antifreeze. These two very different. Boiler anti-freeze is intended for use in boiler systems and has a different chemical composition than antifreeze intended for RVs, automobiles and trucks. Camco has pink RV Plumbing and RV Freeze Ban antifreeze in addition to their pink boiler antifreeze; be sure to use the boiler antifreeze in your Aqua-Hot system.

Antifreeze and coolant
These terms are typically used interchangeably. Aqua-Hot heating systems use boiler-designated antifreeze that is rated GRAS — Generally Regarded As Safe.

GRAS
This is the Federal Drug Administration term for Generally Regarded As Safe. GRAS is the term to look for on antifreeze products. Anything else is likely to be harmful if swallowed.

Freeze Point is the temperature ice crystals will start to form in the antifreeze solution.

Burst Point is the temperature where damage will occur to the coach. "

There is much discussion on this part of the subject............so everyone has a theory.

Read a lot -

Search a lot

Think a lot.

Get out the CC and spend a lot.

Let us know how you do - tried to get you some info to start with.

Best of Luck,
__________________
Busskipper
Location - Grasonville, Maryland - and/or - Superior, Colorado
2005 Travel Supreme 42DS04 - GX470 Toad
Busskipper is offline   Reply With Quote
Reply

Tags
heat



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aqua Hot furnace vs. Heat Pumps for heat S-n-L RV Systems & Appliances 14 12-17-2015 06:36 PM
Aqua Hot Heat Problem Garth Rockey RV Systems & Appliances 8 02-27-2015 05:07 PM
Aqua-Hot AND a/c heat pump? BillyC Monaco Owner's Forum 7 05-03-2011 05:52 PM
poor heat production from my Aqua hot G.Peter Class A Motorhome Discussions 12 12-22-2010 10:32 AM
Aqua Hot basement heat dshogman Alpine Coach Owner's Forum 18 02-28-2010 05:11 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.