RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-07-2018, 04:54 PM   #1
Junior Member
 
Join Date: Feb 2018
Posts: 5
Battery,

I changed engine battery 1984 Pace Arrow 454 engine, hooked it up and nothing. Battery fully charged even switched batteries and have nothing. No lights, no clicking, have checked wires, clean posts, and all grounds.
JS Asbury is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-07-2018, 05:06 PM   #2
Senior Member
 
MTK46's Avatar
 
Join Date: Nov 2016
Location: Desert Hot Springs Ca.
Posts: 940
First of all welcome.
You need to get out a test light and see where you are losing connection. If you had power before with the old battery then my guess is a bad wire.
__________________
Mike & Trish Romans 10:9
2011 Mobile Suites 36RSSB3
2014 F-350 6.7L CC DRW
MTK46 is offline   Reply With Quote
Old 02-07-2018, 05:10 PM   #3
Senior Member


 
Join Date: Jun 2017
Posts: 2,792
Or a blown fusible link.
tfryman is online now   Reply With Quote
Old 02-07-2018, 05:59 PM   #4
Senior Member
 
Join Date: Sep 2016
Posts: 337
do you have battery switches by the entree door? Might have to flip the switch?
__________________
1988 gulfstream sunvista 36'
steppinstone is offline   Reply With Quote
Old 02-07-2018, 06:10 PM   #5
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 14,928
Wires are connected matching the picture you took before disconnecting the original?
__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is offline   Reply With Quote
Old 02-07-2018, 06:31 PM   #6
Senior Member
 
Join Date: Jul 2014
Posts: 24,738
Some of the older GMs had the extra 10 gauge wire on the battery terminal. Make sure that is OK.
twinboat is online now   Reply With Quote
Old 02-07-2018, 06:43 PM   #7
Senior Member


 
Join Date: Jun 2017
Posts: 2,792
Quote:
Originally Posted by steppinstone View Post
do you have battery switches by the entree door? Might have to flip the switch?
For the ENGINE battery?
tfryman is online now   Reply With Quote
Old 02-07-2018, 06:44 PM   #8
Senior Member


 
Join Date: Jun 2017
Posts: 2,792
Quote:
Originally Posted by twinboat View Post
Some of the older GMs had the extra 10 gauge wire on the battery terminal. Make sure that is OK.
Yep, that's the one that supplies everything but the starter itself through a fusible link.
tfryman is online now   Reply With Quote
Old 02-08-2018, 02:04 AM   #9
Senior Member
 
Join Date: Sep 2016
Posts: 337
Quote:
Originally Posted by tfryman View Post
For the ENGINE battery?
yup I'm not sure it op has toggle switches by the entry door like mine or not. Mine is equip with (2) toggle switches (1) for the house and (1) for the Chassis to turn on the power.
__________________
1988 gulfstream sunvista 36'
steppinstone is offline   Reply With Quote
Old 02-08-2018, 10:34 AM   #10
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 43,815
Hi ! Welcome to IRV2! We're sure glad you joined the gang!

Our rig has battery cutoff switches for BOTH chassis and house batteries.

Good luck, happy trails, and God bless!
__________________
Joe & Annette
Sometimes I sits and thinks, sometimes I just sits.....
2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is online now   Reply With Quote
Old 02-08-2018, 01:01 PM   #11
Senior Member
 
Join Date: Jun 2016
Location: Nine Mile Falls WA / Arizona City AZ
Posts: 1,041
plastic cap that's on the battery post... I've seen this mistake several times..
__________________
Retired Business Owner, Re-manufacturing HD Clutches, Brake Shoes, Air Compressors, Sales & Installation of PacBrake and other Industrial Friction
jelag is offline   Reply With Quote
Old 02-08-2018, 01:14 PM   #12
Senior Member
 
Sweetbriar's Avatar
 
Thor Owners Club
Ford Super Duty Owner
Join Date: Jul 2011
Posts: 3,144
Quote:
Originally Posted by jelag View Post
plastic cap that's on the battery post... I've seen this mistake several times..
, And that's all I got to say about that.
__________________
2006 Hurricane 31D built on a 2006 Ford F53
Sweetbriar is offline   Reply With Quote
Old 02-09-2018, 01:59 PM   #13
Junior Member
 
Join Date: Feb 2018
Posts: 5
Yes, it does but I can't find the fuse link.
JS Asbury is offline   Reply With Quote
Old 02-09-2018, 02:02 PM   #14
Junior Member
 
Join Date: Feb 2018
Posts: 5
Thanks everybody for the replies.
JS Asbury is offline   Reply With Quote
Reply

Tags
battery



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Cut-off Switch/House Battery Disconnect- 2002 Diplomat 40DST Schrimscher Monaco Owner's Forum 14 11-23-2011 11:09 PM
Battery disconnect on house battery? tekrsq Vintage RV's 3 04-28-2011 07:52 PM
Aux battery/battery boost DEG503 Monaco Owner's Forum 21 01-13-2011 09:05 AM
Battery Tender for house battery, any experience with this? troedw44 Vintage RV's 8 01-03-2011 06:10 PM
house battery corrosion and weird battery auto fill system ClarkBowen Alpine Coach Owner's Forum 8 07-09-2008 05:37 PM


All times are GMT -6. The time now is 05:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.