Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-20-2016, 10:41 PM   #1
Senior Member
 
RufussSewell's Avatar
 
Join Date: Sep 2013
Posts: 162
Both inverter and gen fault coding.

So, the other day my chassis batteries started being too low to start the engine. I used the battery coupler button the charge up and start. But each time I restarted the batteries were very low.

I'm on the road with my band so I have very little time to stop in to change batteries etc. Plus I run the gen all day.

Well, the next day the the gen would die from low chassis battery mid day. To try to keep the chassis battery charged I taped down the coupler button. That way the inverter/charger kept both battery sets charged.

This may have been a mistake. The next day the coupler button stopped working. The only way I could keep the chassis batteries charged was to connect them with jumper cables.

This worked for another day. But it may have been another huge mistake because today, both the gen and the inverter are giving fault codes.

The Onan QD7500 Genset has a 22 code. It starts and runs for a minute, then shuts down.

The Xantrex Freedom 458 inverter is basically blinking erratically and it makes the 12V lights inside the coach blink.

I checked the house battery water and it was low. I filled them with distilled water.

I replaced the chassis batteries and they seem to be working fine now.

Any clues what else I should try?!?
__________________
1997 Beaver Patriot, Cat 330 DP, Magnum Chassis, Allison MD3060 Tranny, 50 amp 120v AC, 12v DC.
RufussSewell is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-21-2016, 04:19 PM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,061
Run the dive engine for 15 or 20 minutes to help charge up the house batteries. Before shutting own the drive engine, start the generator. If you still have lights blinking on the inverter, unplug the data cable to the remote for a few seconds and then reconnect. Good luck and keep us posted.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Reply

Tags
inverter



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to tell if Gen charges both House and Chassis battery's? Dad Class A Motorhome Discussions 16 01-11-2016 10:58 AM
Inverter or battery problems or both? boltdave Winnebago Industries Owner's Forum 2 10-31-2015 10:30 PM
A/C units both work well for 15 t0 45 min then BOTH shut down baustin RV Systems & Appliances 2 09-26-2014 06:57 PM
Both A/C's will not work at same time on gen or shore power ggenewells77 Fleetwood Owner's Forum 43 01-04-2014 08:28 AM
Only 1 AC runs on gen, Both will run on shore oldpoke76 RV Systems & Appliances 14 08-10-2011 04:35 PM


All times are GMT -6. The time now is 04:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.