RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-06-2017, 10:19 PM   #1
Senior Member
 
Join Date: Aug 2016
Location: Seattle,WA/HB,CA./Fujieda-Japan
Posts: 576
Chevy 454 TBI P-30 ?s

1. I have a 1994 Fleetwood Southwind Storm (28ft) and would like to know how many O2 sensors there are? I'm only seeing (1) underneath. This is a TBI 454 P-30

2. Also would like to know if it's equipped with a MAF sensor as well.

3. Anyone know of an internet site that points out all the locations of such devices?

Coming back from Cultus lake and while waiting at the border (Abottsford) I glanced down and noticed the 'Engine' light was on. First I've seen it come on during the trip. Engine was running fine otherwise. I shutdown the engine waiting for the line to move and upon starting light was out. Light did not come on for remainder of trip home (Renton, WA.). I'm leaning at an O2 sensor but would like to know how many does the P-30 chassis have. I only see (1) underneath. Mileage was just over 8mpg (US).
__________________
1994 Southwind Storm 28ft 7.4L TBI P-32
64,377 miles and counting...as of 07/10/2020
VIN#1GBJP37N4R3314754
udidwht is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-07-2017, 02:56 PM   #2
Senior Member
 
Charlie 5320's Avatar
 
Join Date: Mar 2017
Posts: 651
Quote:
Originally Posted by udidwht View Post
1. I have a 1994 Fleetwood Southwind Storm (28ft) and would like to know how many O2 sensors there are? I'm only seeing (1) underneath. This is a TBI 454 P-30

2. Also would like to know if it's equipped with a MAF sensor as well.

3. Anyone know of an internet site that points out all the locations of such devices?

Coming back from Cultus lake and while waiting at the border (Abottsford) I glanced down and noticed the 'Engine' light was on. First I've seen it come on during the trip. Engine was running fine otherwise. I shutdown the engine waiting for the line to move and upon starting light was out. Light did not come on for remainder of trip home (Renton, WA.). I'm leaning at an O2 sensor but would like to know how many does the P-30 chassis have. I only see (1) underneath. Mileage was just over 8mpg (US).
I had a 95 Challenger with the tbi injected 454, it only had one 02 sensor. Don't know if it had a MAF sensor or not. Only problem I had with mine was wires, cap, and rotor. Always got between 8 and 10 mpg pulling a 18 ft steel trailer with a race car and a golf car. Lot better mileage than my Dolphin.
__________________
1996 Challenger 313

2003 Dolphin 5320 sold
Charlie 5320 is offline   Reply With Quote
Old 07-07-2017, 06:16 PM   #3
Senior Member
 
Join Date: Aug 2016
Location: Seattle,WA/HB,CA./Fujieda-Japan
Posts: 576
I did crawl underneath today and confirmed it has only (1) O2 sensor. Followed the exhaust all the way up to exhaust manifold/block. The 1 sensor is right after the 'Y' and before the muffler & cat. Going to put a new one in.

Replaced the Spark plugs, wires, cap and rotor roughly 6-7K ago (late 2014) and have heat shield covers for all wires. Using the NAPA premium wires and AC Delco cap & rotor.
__________________
1994 Southwind Storm 28ft 7.4L TBI P-32
64,377 miles and counting...as of 07/10/2020
VIN#1GBJP37N4R3314754
udidwht is offline   Reply With Quote
Old 07-08-2017, 09:15 AM   #4
Senior Member
 
Join Date: May 2017
Posts: 1,038
If you can find the OBD-I port (GM called it an ALDL*), you can jumper pins and pull the code thrown by the computer. It will be a series of flashes, and all OBD-I codes are two-digits.


* Assembly Line Diagnostic Link
DryCreek is offline   Reply With Quote
Old 07-29-2017, 03:08 AM   #5
Senior Member
 
Join Date: Aug 2016
Location: Seattle,WA/HB,CA./Fujieda-Japan
Posts: 576
Update:

Went ahead and replaced MAP sensor, TPS sensor, O2 sensor (1), PCV valve, new radiator cap. Runs great. Didn't bother checking for code given it's not occurred since then. Those CEL lights are almost exclusively related to O2 sensor issues more often than not.

The MAP sensor controls overall AFR for the TBI and the O2 sensors only involvement is trim for fuel AFR if (big if) the MAP throws error. Not likely going to happen given it is new now as well.
__________________
1994 Southwind Storm 28ft 7.4L TBI P-32
64,377 miles and counting...as of 07/10/2020
VIN#1GBJP37N4R3314754
udidwht is offline   Reply With Quote
Reply

Tags
454, chevy



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1992 Winnebago 454 TBI Fuel Pressure Kaweh Class A Motorhome Discussions 18 08-12-2015 09:20 AM
Timing a 1990 454 TBI - Itasca Windcruiser 37 Bluelagoon Workhorse and Chevrolet Chassis Motorhome Forum 7 05-22-2015 01:55 PM
1991 P30 Bounder 454 TBI, where is the fuel filter? sgosa Class A Motorhome Discussions 10 08-11-2014 03:33 PM
96 Itasca w/ 454 TBI check engine light jcgribks Workhorse and Chevrolet Chassis Motorhome Forum 5 07-13-2014 07:51 AM
Bounder: 93 bounder engine needed 454 tbi mrwrench Fleetwood Owner's Forum 4 07-24-2013 07:06 AM


All times are GMT -6. The time now is 07:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.