Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-25-2016, 04:01 PM   #1
Senior Member
 
Join Date: Sep 2015
Location: Jasper IN
Posts: 331
Clicking Sound on Generator

Folks,
I have 2002 Fleetwood Expedition DP...just got it...took first trip to Branson MO. I tried to start generator Onan diesel 7.5 on start and it just clicked. About 1 hour into trip it started and worked fine. On trip back, it just clicked when I tried to start it...tried many times over 8 hr period and did the same...when I got home, I hear the sound on back of genset...is that where starter is located? sound like starter relay? loose conn? thank you

ps...it worked fine at dealership and home
swagn is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-25-2016, 04:18 PM   #2
Senior Member
 
nukerj's Avatar
 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Sep 2016
Location: Monument, CO
Posts: 216
It's a diesel- fuel pump has to prime (that's the continuous clicking) and glow plugs have to heat up. Hold down the start switch until it fires up, should take no more than 10-20 seconds. If it doesn't fire up after 30 seconds, follow trouble shooting procedures.
__________________
2014 Fleetwood Discovery 40G -> '16 Yukon Denali
Mechanical and Electrical Engineer
"De Opresso Liber"
nukerj is offline   Reply With Quote
Old 10-25-2016, 04:50 PM   #3
Senior Member
 
Join Date: Jul 2014
Posts: 26,780
Find the battery cable, coming from the battery, to the generator and clean and tighten the connection at the battery.

One way to check for the dirty one is to let it click for 15 to 30 seconds and then feel the cable connections for a warmer one.

If you find nothing at the batteries, check the ground cable from the generator to the chassis. Could be loose.
twinboat is offline   Reply With Quote
Old 10-25-2016, 04:53 PM   #4
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 8,287
You can press the top part of the switch and it will just run the priming pump. If I haven't used mine in a while I usually will use prime for ~1 minute and then try to start.
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is online now   Reply With Quote
Old 10-28-2016, 05:16 AM   #5
Senior Member
 
Join Date: Sep 2015
Location: Jasper IN
Posts: 331
Clicking sound on generator

Quote:
Originally Posted by nukerj View Post
It's a diesel- fuel pump has to prime (that's the continuous clicking) and glow plugs have to heat up. Hold down the start switch until it fires up, should take no more than 10-20 seconds. If it doesn't fire up after 30 seconds, follow trouble shooting procedures.
It was "operator" error...thank you . It works fine!
swagn is offline   Reply With Quote
Reply

Tags
generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xantrex Pro Series 1800 - Clicking Sound johnnc RV Systems & Appliances 2 08-30-2011 05:03 PM
Clicking Sound from engine bterry123 Cummins Engines 1 05-21-2009 08:04 PM
Relay clicking sound from rear of MH movin-on Winnebago Industries Owner's Forum 4 08-04-2008 02:46 PM
Generator won't start and makes clicking sound Tom-NC Winnebago Industries Owner's Forum 17 07-18-2007 05:40 PM
Air gauges making clicking sound JasonD Newmar Owner's Forum 5 12-11-2006 10:43 AM


All times are GMT -6. The time now is 09:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.