Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-23-2021, 10:07 PM   #1
Junior Member
 
Join Date: Jul 2021
Posts: 1
Unhappy Communication error HR Neptune HELP Plz

We have a 2005 Holiday Rambler Neptune, Cummins 300 and Allison 1250MH. On way home from 1000 mile trip our service transmission light came on and stop engine. We pulled over, checked fluids and appeared low so we added proper fluids. Lights went off..took a bit but she started shifting right and we traveled a few hundred miles more. Lights come on again and she goes into limp mode. Pull over and check fluids which appear overfull. Drain a bit and limp to Allison certified tech facility. They checked wire harness and find bare wires in throttle position. They believe that caused issues and replace/fix them. While servicing transmission the addressed a few seals that need fixed and notice we need new batteries (house) so they replace those. They had to reprogram valve body to get her in shifting mode after all this but then ACTIVE CODE pops up..apparently it was inactive and has now become active. It says communication error from engine ECM to Transmission ECM. They have put in tester ECM (didn’t fix), check exhaust, batteries, filters, connections and such. Freightliner and Allison help told them to check chassis wire harness and they have checked 8 miles of wires, including chassis wire harness, and found a few bare wires that were addressed. Supposed to get her all put back together on Monday to see if it works..if it doesn’t….we are 85 hours of labor into this..please someone help!!
WPmom is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-23-2021, 10:26 PM   #2
Senior Member
 
Newmar Owners Club
Join Date: Aug 2014
Location: WA
Posts: 249
trans com fail

I have a new Newmar Dutch Star 2019 Freightliner chassis which is now one year old. So I do not know if my experience is pertinent to your situation. It drove fine for the first 10k miles. When I tried to start the engine 2500 miles away from home an error came up "trans com fail". The transmission was not communicating with the engine to tell it what gear it was in and what speed it was going. After a lot for diagnosing by others the Allison tech showed up connected one wire in 5 minutes and it started. After checking for all faults he wired he connected a permanent wire for the transmission with a fuse in it. It was the wiring harness which had lost the wire connection. The coach has gone another 10k miles with no problems.


I hope this helps.
Enjoy the trip and be safe.
__________________
Mahdi & Debbie
2019 Dutch Star 4018
2020 Tahoe LT
mahdi is offline   Reply With Quote
Old 07-24-2021, 05:38 AM   #3
Senior Member
 
Monaco Owners Club
Join Date: Sep 2014
Posts: 4,256
I'm so sorry to hear about your experience. It sounds like you're closing in on 20k or so.

Unfortunately, these types of problems often require a supertech. Someone that can diagnose and troubleshoot signals. Maybe you can take a little solace in knowing that almost none of us can find a supertech anymore.

Here's to hoping that they'll stumble on the problem and you'll be back on the road. Good luck.
__________________
1996 Tioga Class C
2007 Monaco Diplomat 40 PDQ
TOAD 2012 Cadillac SRX 4
okcnewbie is offline   Reply With Quote
Reply

Tags
cat, holiday rambler, need help



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Magnum Communication Error Anndrennan Winnebago Industries Owner's Forum 12 01-17-2020 06:05 AM
Tracstar 360 antena communication error Ssgritton Technology: Internet, TV, Satellite, Cell Phones, etc. 8 09-19-2013 08:44 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:34 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.