Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-26-2021, 03:33 PM   #1
Junior Member
 
Join Date: Sep 2015
Posts: 6
Cruise Control & Horn Do Not Work

Recently acquired 2011 Monaco Riptide with Ford V-10 Triton engine. Neither the horn nor the cruise control are operable. Could this be a fuse issue. If so, where is the fuse panel on this or most Class A motorhomes? Thanks very much for any guidance on this.
2020Traveler is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-26-2021, 06:23 PM   #2
Senior Member
 
bruce91's Avatar


 
Ford Super Duty Owner
Join Date: Jul 2012
Location: Port Orange, Fl
Posts: 819
Quote:
Originally Posted by 2020Traveler View Post
Recently acquired 2011 Monaco Riptide with Ford V-10 Triton engine. Neither the horn nor the cruise control are operable. Could this be a fuse issue. If so, where is the fuse panel on this or most Class A motorhomes? Thanks very much for any guidance on this.
This will be my best guess. The clock spring in the steering wheel that transfers the current.

youtube video has easy repair.
__________________
Bruce Hotaling, Lori Jones & Cocker,Maggie
2009 Thor Magellan 36R 37' F53 w/5 star tune
Toad 2010 Ford Ranger W/Rampage lift for the Harley
and 2012 Ford Fusion hybrid
bruce91 is offline   Reply With Quote
Old 04-27-2021, 06:15 AM   #3
Senior Member
 
Monaco Owners Club
Join Date: Apr 2009
Location: Where ever we stop
Posts: 828
Same thing happened to me. Had to replace the clock spring and everything worked again.
__________________
Chet
Monaco 2004 Signature 45' Castle IV Detroit 60
Towing 2021 Tesla Model Y in a 20' HaulMark trailer
super_rep is offline   Reply With Quote
Old 04-27-2021, 10:03 PM   #4
Senior Member
 
153stars's Avatar
 
Join Date: Mar 2019
Location: Braidwood Il.
Posts: 4,250
Some owners of class A report plug/ harness dislodging near base of column .
__________________
95 Monaco Crown Royale
M11 400hp, 4060 trans.
Aquahot, Generac Guardian7.5k
153stars is offline   Reply With Quote
Old 04-27-2021, 10:11 PM   #5
Registered User
 
Join Date: Nov 2005
Posts: 6,749
If this is a "Smart Wheel," I have had success taking the button clusters apart [screws on back side of steering wheel] and using the eraser end on a common pencil to scrub/clean the contacts on the multi-connector plugs....cheap and easy--and might help you.
Old Scout is offline   Reply With Quote
Reply

Tags
cruise control, horn



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn and Cruise Control Do Not Work 2020Traveler Monaco Owner's Forum 5 04-27-2021 02:08 PM
Cruise control & horn not working upsdrew Class A Motorhome Discussions 16 01-12-2018 10:32 PM
Cruise and Air Horn won't work eagleoil Class A Motorhome Discussions 3 07-14-2014 07:29 AM
Horn fuse is open, Horn doesn't work GurkaJim iRV2.com General Discussion 3 07-12-2011 06:45 AM
Cruise Control/Wiper Control/Bright Light Control cnjcampione Winnebago Industries Owner's Forum 2 05-21-2011 08:38 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:46 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.