Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-26-2020, 07:08 AM   #1
Junior Member
 
Join Date: Nov 2012
Posts: 10
Dash A/C blows hot after a 10 minutes or so

Hey everyone. You guys were so helpful on my last issue, I figured I'd give you another chance. ;-)

The dash AC on our 2004 Dutch Star stops working and blows hot air after 5 or 10 minutes. And I mean hot. Yesterday we were driving back from Myrtle Beach and it was in the low to mid 70s outside. After blowing cold air for the first 10 minutes of our trip, the AC went hot, like you would expect the heat in the winter. On the way down, it did the same thing. Occasionally it would blow cold again before returning to hot.

I don't understand what would cause this. Any ideas?
13sunstar is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-26-2020, 07:30 AM   #2
Senior Member
 
Newmar Owners Club
Spartan Chassis
Join Date: Jun 2017
Posts: 1,084
Sounds like the temperature control valve. There’s quite a few posts about troubleshooting and repairing. Here’s one from a quick search.

https://www.irv2.com/forums/f103/das...tml#post636987
__________________
2018 Newmar Mountain Aire 4531
flyboy013 is offline   Reply With Quote
Old 09-26-2020, 05:47 PM   #3
Senior Member
 
Join Date: May 2019
Location: Smithfield, VA
Posts: 295
Check to see that the condenser fan is running assuming you have a dp
__________________
Tom & Carol, Smithfield, VA
2000 Dutch Star DP 3851 Spartan
CWO2 USN-Ret
tomgrigsby is offline   Reply With Quote
Old 09-26-2020, 06:07 PM   #4
Senior Member
 
Join Date: Apr 2018
Posts: 1,790
If you had moisture in the system freezing in the expansion tube it should only blow mildly warm. Heat has to come from the heater valve being open, or in some systems the vents switching to the heater core. To verify the a/c is working find the small line going into the evaporator, just before entering the evaporator is the expansion tube or valve. Should go from hot to cold all the way out to the large hose coming out of the evaporator. Touch them while it's working, if they're the same when it quits you'll know the ac is fine.
shootist is offline   Reply With Quote
Old 09-26-2020, 06:10 PM   #5
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 5,770
It sounds like low on Freon. When the Freon is low, it expands too much and freezes the coil.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2014 Honda CRV toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 09-27-2020, 06:13 AM   #6
Member
 
Harleytoter's Avatar


 
Monaco Owners Club
Fleetwood Owners Club
Join Date: Sep 2013
Posts: 85
If your unit has heat pumps, which is what this sounds like. The reversing valve needs to be replaced. The ones for the Dometic Penguins cost about $50. This is an easy swap.
Harleytoter is offline   Reply With Quote
Old 09-27-2020, 07:11 AM   #7
Senior Member
 
RichKimball's Avatar
 
Oklahoma Boomers Club
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Feb 2012
Location: Central Arkansas
Posts: 1,093
Quote:
Originally Posted by Harleytoter View Post
If your unit has heat pumps, which is what this sounds like. The reversing valve needs to be replaced. The ones for the Dometic Penguins cost about $50. This is an easy swap.
This trouble is for his DASH A/C. No heat pumps there.

I agree with Tom on checking your condenser fan (if your rig is a DP). The fans go bad and lock up causing your symptom. Check local auto parts house or I found a good source for a/c parts is coldhose.com.
__________________
2008 Fleetwood Bounder Diesel 38S, Flat tow-2015 Cherokee Trailhawk
Richard (KG5JAQ) & Margaret Kimball w/Shih-Tzu 'Charley'
RichKimball is offline   Reply With Quote
Old 01-19-2022, 09:18 AM   #8
Junior Member
 
Join Date: Jan 2022
Posts: 1
Did you get this fixed? My 2003 fleetwood exursion does the same thing. Blows cold then 5 miles down road just blows warm air. checked fan, cycles on and off, checked freon, no leaks. someone told me it's the high or low pressure valve but I can't find them. any ideas?
bstetler is offline   Reply With Quote
Old 01-19-2022, 06:56 PM   #9
Senior Member
 
Join Date: Sep 2021
Posts: 537
Its hard to be sympathetic when we are going camping and nighttime is in the 20's lol
__________________
2004 Safari Cheetah PDQ 330 Cat
2020 Ram EcoDiesel toad
USAF SERE
Iceclimber is offline   Reply With Quote
Old 01-19-2022, 07:11 PM   #10
Senior Member
 
Mile Marker 42's Avatar
 
Join Date: May 2013
Location: S. California
Posts: 1,268
Is the compressor turning (engaged) when it blows hot? Do you have a "sight" glass you can see the freon in? Your heater valve may not be holding. Many of us have added a manual valve from home Depot.
__________________
2003 Monaco Knight 36ft PST Triple Slide- 315 ISC
2007 Jeep Grand Cherokee 3.0 Diesel 4x4
2- 2013 Yamaha VXR's 70MPH+. 2019 Sun Tracker 19ft Pontoon w/ 90hp Mercury
Mile Marker 42 is offline   Reply With Quote
Old 01-19-2022, 07:11 PM   #11
Senior Member
 
Mile Marker 42's Avatar
 
Join Date: May 2013
Location: S. California
Posts: 1,268
Quote:
Originally Posted by Iceclimber View Post
Its hard to be sympathetic when we are going camping and nighttime is in the 20's lol
Doesn't sound like camping. Sounds like survival.
__________________
2003 Monaco Knight 36ft PST Triple Slide- 315 ISC
2007 Jeep Grand Cherokee 3.0 Diesel 4x4
2- 2013 Yamaha VXR's 70MPH+. 2019 Sun Tracker 19ft Pontoon w/ 90hp Mercury
Mile Marker 42 is offline   Reply With Quote
Old 01-20-2022, 07:38 AM   #12
Junior Member
 
Join Date: Nov 2012
Posts: 10
Quote:
Originally Posted by bstetler View Post
Did you get this fixed? My 2003 fleetwood exursion does the same thing. Blows cold then 5 miles down road just blows warm air. checked fan, cycles on and off, checked freon, no leaks. someone told me it's the high or low pressure valve but I can't find them. any ideas?
I actually sold this coach back to my dad, but he got it fixed. If memory serves, it was the temperature control valve.

He put a clamp on the outlet hose to test it. There is probably a better writeup, but this article post address it. Check the post by "Bluepill": https://www.irv2.com/forums/f107/das...em-111115.html
13sunstar is offline   Reply With Quote
Old 01-20-2022, 10:35 AM   #13
Senior Member
 
Join Date: Sep 2021
Posts: 537
Quote:
Originally Posted by Mile Marker 42 View Post
Doesn't sound like camping. Sounds like survival.
Survival was doing it out of a pack. Now I have 50 amps, heat and hot water. Also fair supply of adult beverages and attractive company. So, more like a hotel. No room service ? I guess I could call Uber Eats.
__________________
2004 Safari Cheetah PDQ 330 Cat
2020 Ram EcoDiesel toad
USAF SERE
Iceclimber is offline   Reply With Quote
Old 01-20-2022, 10:56 AM   #14
Senior Member
 
-Gramps-'s Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Nov 2005
Location: Crestview FLA
Posts: 1,420
Blog Entries: 7
What dug this old 2012 post out of the closet?
__________________
08 Holiday Rambler Vacationer XL 38PLT Workhorse R-26 UFO gas pusher,
2014 Cadillac SRX AWD, SMI Smart Box braking system.
https://myrandomviews.com/
-Gramps- is offline   Reply With Quote
Reply

Tags
dash



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash A/C Blows hot air. 2004 Workhorse Scottsdale tul91562 Newmar Owner's Forum 13 08-09-2016 04:37 PM
Dash AC blows hot air GoneFishin Monaco Owner's Forum 20 12-03-2007 03:17 PM
onan 5500 shut down after 20 minutes of A/C peter griffin Winnebago Industries Owner's Forum 7 09-10-2007 01:32 PM
QD generator stopping after 2 minutes use Stretch Alpine Coach Owner's Forum 12 02-04-2006 06:55 PM
Dash AC quits after a few minutes ronboc Workhorse and Chevrolet Chassis Motorhome Forum 10 10-06-2005 05:10 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:38 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.