RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-21-2021, 02:15 PM   #1
Junior Member
 
Join Date: Apr 2020
Posts: 6
dash problem

I have a 2002 fleetwood expedition DP w/300 cummons currently winterized. Today I went out to start the coach to keep the batteries charge from sitting for a month and when it started the dash guages were not registering and the idiot lights were all on. Battery switches are in the on position and coach was working fine execpt for the dash. Anyone have a clue
jdtraveler is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-21-2021, 05:12 PM   #2
Senior Member
 
Outbound's Avatar
 
Join Date: Jun 2012
Location: NorCal
Posts: 2,410
Have you tried turning on and off switch a few times, sometimes after sitting contacts get dirty.
__________________
Outbound
2002 Monaco Executive 500 ISM
2004 GMC 2500HD 4X4
Outbound is offline   Reply With Quote
Old 02-22-2021, 09:42 AM   #3
Senior Member
 
Join Date: Sep 2011
Posts: 127
Might want to call Freightliner, I have em on speed dial. They are really nice.

On mine, there's a primitive computer in the dash, called the "LBCU" or "FUBAR" or something, and the gauges are connected in serial out of that thing. If the first one in line goes wonky, none of them work.

If you have that, Freightliner will send you a rig to hook em up in parallel. What they won't tell you is, sometimes if you hook em up in a different order (hopefully, with the bad gauge last in line) sometimes it'll start working again
__________________
2008 Tiffin Allegro Bus
Fiat 500
TampaDave is offline   Reply With Quote
Old 02-22-2021, 10:01 AM   #4
Senior Member
 
530ktm's Avatar
 
Join Date: Dec 2014
Location: High up in Arizona
Posts: 1,826
Quote:
Originally Posted by jdtraveler View Post
I have a 2002 fleetwood expedition DP w/300 cummons currently winterized. Today I went out to start the coach to keep the batteries charge from sitting for a month and when it started the dash guages were not registering and the idiot lights were all on. Battery switches are in the on position and coach was working fine execpt for the dash. Anyone have a clue
I don't know about your lights but I would keep the coach on some type of smart charger to keep batteries charged up. Just going out and starting the engine for a bit will not charge them up properly and does not do any good for the engine either. Can you not just plug in your coach while in storage?
__________________
2019 Allegro Bus 37AP towing a Jeep JK Rubicon Wrangler
530ktm is offline   Reply With Quote
Old 02-23-2021, 05:34 AM   #5
Member
 
Join Date: Oct 2019
Location: Blount County TN
Posts: 83
Check for loose ground connection under there - that can cause all sorts of issues.
__________________
Mickey Richaud
2020 Jayco Precept 31UL
2018 Wrangler JLU Sport Toad
MRichaud is online now   Reply With Quote
Old 02-24-2021, 07:11 PM   #6
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 22,126
Assuming Freightliner chassis, and gauge package ?
Attached Files
File Type: pdf Freightliner gauges operation , testing.pdf (127.9 KB, 3 views)
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Reply

Tags
dash, problem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash Air Hose/Dash Instrument Speaker Ken T. Alpine Coach Owner's Forum 6 09-08-2014 11:39 PM
Dash lights on, gauges jump. Low voltage to dash. bobioknight RV Systems & Appliances 3 05-11-2013 11:55 PM
Anyone change the tv location from below the dash to above the dash??? Born2RV MH-General Discussions & Problems 11 03-14-2010 03:53 PM
SunTek Dash Cover Discoloration of Dash vicsryd MH-General Discussions & Problems 19 08-26-2006 02:38 PM
Red Oil Pressure Signal on dash is a GM Problem in Dash Unit BEBOP Workhorse and Chevrolet Chassis Motorhome Forum 11 07-28-2005 07:47 PM


All times are GMT -6. The time now is 03:30 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.