Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-30-2021, 10:19 AM   #15
Junior Member
 
Barefoot.'s Avatar
 
Jayco Owners Club
Join Date: Dec 2020
Posts: 23
Quote:
Originally Posted by Dr. Mike View Post
There is a receptacle, but my theory (and question) were more related to the power spike on start-up.
How about a follow-up question: What are the group's thoughts about this Soft Start device?
I installed one on my AC. We had an issue with the 30 amp breaker tripping when we would try and run the AC an any high draw appliances (i.e. the microwave) I installed the Micro-air EasyStart on my AC and haven't had a breaker trip since. It was well worth the investment for me. It was a pretty easy install too.
Barefoot. is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Reply

Tags
electric, electrical



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No electrical power at one lug (3) Left Front Electrical Center RobRoy Monaco Owner's Forum 18 03-31-2017 12:59 PM
Weird electrical/noise question Carnles Winnebago Industries Owner's Forum 3 10-15-2007 02:55 PM
Electrical Question gator67 Alpine Coach Owner's Forum 4 09-19-2007 02:02 PM
2004 Brave electrical system question skipsor Winnebago Industries Owner's Forum 3 01-28-2007 09:22 AM
Electrical question Matt1616 MH-General Discussions & Problems 7 03-02-2006 06:36 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.