Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-26-2021, 07:00 AM   #1
Junior Member
 
Join Date: Jul 2021
Posts: 7
Electrical Problems

Hello I am new to the RV world. I purchased a 1998 Fleetwood Bounder with 77,000 miles on it. I went to start it the other day and the ignition, dash, steps, and levelers all are completely dead. I have checked all the batteries, they are all reading over 12.6 volts. Is there something that would cause all these things to stop working? Thank you in advance for any support.
JDHeyen is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-26-2021, 07:27 AM   #2
Senior Member
 
Lt46's Avatar
 
Winnebago Owners Club
Retired Fire Service RVer's
Join Date: Mar 2008
Location: Central Florida
Posts: 749
Check to make sure your battery disconnect switch is configured properly, it's an on/off switch located either on the dash or near the front door.
__________________
Peter
1997 F53 Adventurer 37rw
IAFF L-792 (Retired)
Lt46 is offline   Reply With Quote
Old 07-26-2021, 11:43 AM   #3
Senior Member
 
House Husband's Avatar
 
Join Date: Mar 2009
Posts: 1,144
Your battery disconnects are located above door on end of cabinet. Momentary switches. Push top of switches to turn on.
You may want to add you chassis make to your profile. No Ford F53 model year chassis manufactured in 1998. So a 1998 MH on a Ford chassis could be a 1997 460 or a 1999 V10. Or you could have a Chevy P32 chassis w/454.

Richard
__________________
95 Bounder 32H F53
460/528 Stroker Engine
House Husband is offline   Reply With Quote
Old 07-26-2021, 06:19 PM   #4
Member
 
Triple E Owners Club
Join Date: May 2021
Posts: 55
Check/clean/tighten all the battery cables.
If you did not turn something off that caused the problem (IE master disconnect) then it is likely a cable problem
Latech is offline   Reply With Quote
Old 07-26-2021, 06:30 PM   #5
Senior Member
 
Join Date: Mar 2019
Location: Lansing MI
Posts: 1,929
22 year old coach, check the grounds, all of them while you're at it. Disconnect them, clean down to bare metal and reattach with some conductive (preferred) or dielectric grease. Even if this is not your issue right now it will be in the future. Good luck.
__________________
An Old Fisherman
2017 Nexus Ghost 36DS, 2004 Ford F150 Long Bed
2007 Harley-Davidson Ultra Classic
arcaguy is offline   Reply With Quote
Old 07-26-2021, 06:44 PM   #6
Senior Member


 
Winnebago Owners Club
Join Date: Sep 2015
Posts: 1,029
Battery disconnect is where I would start. On day one of my new to me DP I was working on the tv above the dash. Suddenly no 12v. So used to mu 2000 HR gasser that had the big dial type disconnect never dawned on me. After checking voltages, I finally broke down and got the manual out. Salesmen switch on the dash. Bumped it while on the dash. Pushed it and everything worked. Gotta realize, for this old camper this thing was fancy smancy to me.
__________________
2006 Winnebago Journey
39K
Cat C7
amosnandy is offline   Reply With Quote
Old 07-26-2021, 08:14 PM   #7
Senior Member
 
Outbound's Avatar
 
Join Date: Jun 2012
Location: NorCal
Posts: 2,866
Another place to look is ignition relays.
__________________
Outbound
2002 Monaco Executive 500 ISM
2004 GMC 2500HD 4X4
Outbound is offline   Reply With Quote
Old 07-28-2021, 07:06 AM   #8
Junior Member
 
Join Date: Jul 2021
Posts: 7
Hello, Thanks to all the folks replying to my problem. I found the problem and my RV started right up. I am new to Motorhome RV. I have had a 40ft travel trailer for years. But I decide to get a motorhome. There is a lot that I do not know about it. Thank You All once again for your help.
JDHeyen is offline   Reply With Quote
Old 07-28-2021, 07:13 AM   #9
Junior Member
 
Join Date: Jul 2021
Posts: 7
I have the P32 with 454. Thank you for your help.
JDHeyen is offline   Reply With Quote
Old 07-28-2021, 07:26 AM   #10
Senior Member
 
KanzKran's Avatar


 
Join Date: Sep 2018
Posts: 1,742
Quote:
Originally Posted by JDHeyen View Post
I found the problem and my RV started right up.
What was it?
__________________
Tom & Jeri
2018 Coachmen Galleria 24T Li3
KanzKran is online now   Reply With Quote
Reply

Tags
electric, electrical, ems, problem, problems



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No electrical power at one lug (3) Left Front Electrical Center RobRoy Monaco Owner's Forum 18 03-31-2017 11:59 AM
Bounder: 2005 Bounder Electrical Problems/Questions GerryB54 Fleetwood Owner's Forum 8 09-03-2007 06:30 AM
electrical problems Buddy and Beverly Alpine Coach Owner's Forum 55 12-02-2006 11:50 AM
workhorse chassis electrical problems also! Gregg606 MH-General Discussions & Problems 20 02-12-2006 08:04 AM
Toad electrical hookup problems jor Winnebago Industries Owner's Forum 3 07-30-2005 02:10 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.