RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-29-2020, 10:04 PM   #1
Junior Member
 
Join Date: Jun 2020
Posts: 11
Fleetwood American Tradition Washing Machine/Dryer Problem

Model 40VS, Spartan Chassis. 1999 model

Bought the motorhome one month ago, leaving on 7/6 for cross country trip.

This morning I put a couple towels into the washing machine and turned it on... Fired right up and went through the wash cycle flawlessly. Disclaimer, I did NOT check the lint filter before I started the unit.

Then turned dryer on, wife put the dial to 40 minutes, but with 5 minutes left she checked the towels and they were still wet, so she turned the dial back to 50 minutes.

Couple hours later she checked the machine and it was off. Tried to restart, nothing.

I get home tonight and try it, nothing as well. Check the breaker under the master bed, wasn't tripped, but reset it anyway. Nothing...

In the morning I plan to pull the machine out and check things out on the backside...

Any help or ideas are welcome. Thank you!
__________________

ILFarmer2020 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-29-2020, 11:39 PM   #2
Decrepit Forum Advocate


 
Join Date: Jul 2003
Posts: 2,101
Hi, welcome to the forum.

What is the manufacturer of your unit ...is it a Spendide combo or is the dryer separate?

So there is power to the plug? --and checked the plug itself to see if it's seated in the socket as we've had them work loose slightly from the normal jolts and vibration of going down the road. From your description, that's probably not the problem but might be good to check anyway.

If there's power to the plug and there's good contact, is everything dead? ...or are there lights flashing (for example, on some machines blinking light patterns can indicate different things).

Have you checked to see that the machine is not set to the "delayed start" setting? On some Spendides, a blinking LED with 2 seconds on and four seconds off will indicate that it's set to "delayed start."

I'm sure others will chime in later if you can give a bit more information on the model of your unit.
__________________

theroc is offline   Reply With Quote
Old 06-30-2020, 05:42 AM   #3
Junior Member
 
Join Date: Jun 2020
Posts: 11
Re: theroc

Thank you for your response...

The unit is a Splendide 2000

On the detergent door it says : WD802M

Remember the motorhome is a 1999 model. There are no lights on the display of this washer/dryer.

Getting ready to pull it out and hope to find something obvious in the rear...
ILFarmer2020 is offline   Reply With Quote
Old 06-30-2020, 07:33 AM   #4
Senior Member
 
Monaco Owners Club
Join Date: Mar 2018
Location: Blairsville, GA & WPB, FL
Posts: 2,954
Send a message via ICQ to Ivylog
Check your 120V breakers first.
__________________
This post is my opinion, worth what you paid for it.
Our ”New” ride...08 HR Navigator 45’. A nice upgrade after 14 years with a 04 Dynasty 42’.
Ivylog is offline   Reply With Quote
Old 06-30-2020, 07:52 AM   #5
Junior Member
 
Join Date: Jun 2020
Posts: 11
Breaker Was Flipped!

Great News, my breaker was tripped!

Thanks to all.
ILFarmer2020 is offline   Reply With Quote
Old 06-30-2020, 10:27 AM   #6
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 22,421
It sounds as though you have a dryer problem regardless, so be prepared to do more diagnosis. Get the tech training manual for your Splendide model at Splendide Combo Washer Dryer Technical Education Site
__________________
Gary Brinck
Former owner of 2004 American Tradition and several other RVs
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 06-30-2020, 02:26 PM   #7
Senior Member
 
Winnebago Owners Club
Join Date: Aug 2012
Posts: 264
Assuming you have a Splendide combo unit, it sounds like the unit needs a 'washing'. The lint remaining doesn't all get in the lint filter but does restrict air flow during dry cycle. I don't have the number handy, but call Splendide (actually Western something-or-other [can't remember]) to get the 'washing' procedure. They are very helpful, located on West Coast. Process involves overfilling the machine and going thru a cycle, the repeating 2 more times (plan on half a day). Clean lint left in drum after each cycle, be amazed at how much comes out.
Then use plain vinegar instead of clothes softener from now on - breaks down lint better and reduces wrinkling. We now use vinegar at home!
Also, clean out the dryer vent. I remove the outside shield and stick vac cleaner hose down the vent. sucks out lot of lint. I do this 1/year


Skip Y
2010 Journey
WIT Club 47083, FMCA F263635
__________________

Skip Y is offline   Reply With Quote
Reply

Tags
fleetwood, problem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×