RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-03-2017, 11:01 AM   #1
Junior Member
 
Join Date: Apr 2015
Posts: 1
Generator Hour meter stopped working.

I took it out and it works fine, I had the generator starter replaced and did not check it out until the next trip, I noticed that the remote start did not work and whens tarted at the generator the hour meter also did not work. When I asked the person who did the work he tried to blow smoke (you know where) and said that nothing he did would cause that. I think it all has to be tied together. Thanks in advance for any help.
Butch Jones
dadog6575 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-03-2017, 11:43 AM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 19,926


You didn't mention what brand or model of generator you have. If the remote start and the hour meter aren't working, I'd think it's disconnected from the generator. Look up your generator brand online and see if you can find a manual with a wiring diagram. I'd start there then look at the wiring between the remote start and the generator control board. Very likely some wires are not connected.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 08-03-2017, 02:20 PM   #3
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 43,758
Hi Butch! Welcome to IRV2! We're sure glad you joined the gang!

Sorry I can't offer advice on that! Keep her between the ditches!

Good luck, happy trails, and God bless!
__________________
Joe & Annette
Sometimes I sits and thinks, sometimes I just sits.....
2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 08-04-2017, 11:48 AM   #4
Senior Member
 
computerguy's Avatar
 
Join Date: Jul 2010
Location: FT on the Road
Posts: 2,754
Quote:
Originally Posted by dadog6575 View Post
I took it out and it works fine, I had the generator starter replaced and did not check it out until the next trip, I noticed that the remote start did not work and whens tarted at the generator the hour meter also did not work. When I asked the person who did the work he tried to blow smoke (you know where) and said that nothing he did would cause that. I think it all has to be tied together. Thanks in advance for any help.
Butch Jones
My guess is that they did not reconnect a remote harness.
On mine there is a harness that the remote start switch connects to near the gen-set. Also in this harness is the wire to the remote location mounted hour meter.
Knowing what year/make/model you are referring to would certainly help.
__________________
I don't make it much on here anymore so will not see your reply to my comment. Drop me a direct message and when I come back on I will see it.
Cheers!
computerguy is offline   Reply With Quote
Old 08-04-2017, 06:48 PM   #5
Registered User
 
Join Date: Aug 2016
Posts: 3,401


In addition to listing the type of generator you have, manufacturer, year, model etc. consider this also:

Put your MH information into your signature
Take a couple of minutes to fill out your signature with information about your motorhome (MH) so we can better offer advice. This will really help in all future posts.
You do this by:
1) Going to the top of this page and click the top left tab named “User CP”
2) Look at the menu on the left and scroll down to “Settings & Options” and click “Edit Signature”
3) In that text box type all the information about your MH. Year, model, length, mileage, any aftermarket extras installed and so on.
marjoa is offline   Reply With Quote
Old 08-04-2017, 07:39 PM   #6
Senior Member
 
Coarsegold's Avatar
 
Join Date: Jul 2017
Location: Central Kalifornia
Posts: 384
Quote:
Originally Posted by computerguy View Post
My guess is that they did not reconnect a remote harness.
On mine there is a harness that the remote start switch connects to near the gen-set. Also in this harness is the wire to the remote location mounted hour meter.
Knowing what year/make/model you are referring to would certainly help.
__________________
Take me on and you take on the whole trailer park!
Coarsegold is offline   Reply With Quote
Old 08-04-2017, 07:44 PM   #7
Senior Member
 
Join Date: Mar 2011
Location: Temple Terrace
Posts: 197
When I bought our RV the hour meter didn't work so I bought a new meter. I unhooked the old meter and hooked the new one up the same way. The new one didn't work either. Got on a forum asked questions and it turns out the previous owner had hooked the meter up backwards when he had part of the dash out. Now I have a spare working meter.
BUB1988 is offline   Reply With Quote
Old 08-04-2017, 07:52 PM   #8
Senior Member
 
Join Date: Sep 2012
Posts: 8,055
Check the connector at the generator end for the remote start and hour meter. Odds are it is not plugged in or loose.

If it is solid I'd start by unplugging and replugging it a couple of times. The pins are somewhat self cleaning from sliding the male into the female.

If that did not work I'd go for some contact cleaner. If that does not work then it gets messy as somebody probably messed up harder to get to connectors at the control board or the board has a problem.

They all say they did not do it.
nothermark is offline   Reply With Quote
Reply

Tags
generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Generator Hour meter on Freightliner Dash LCD? erstanfo Winnebago Industries Owner's Forum 4 08-09-2012 11:22 PM
Generator hour meter booyah Winnebago Industries Owner's Forum 11 08-08-2012 07:56 AM
noisy generator hour meter racryf Jayco Owner's Forum 4 12-17-2011 07:26 AM
Generator hour meter not working RetiredBob Newmar Owner's Forum 6 07-28-2011 08:01 AM
Remote hour meter for onan generator David K Winnebago Industries Owner's Forum 3 07-24-2010 06:32 PM


All times are GMT -6. The time now is 12:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.