Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-27-2017, 09:19 PM   #1
Junior Member
 
Join Date: Jan 2017
Posts: 11
Has anyone had problems with generator slide.

I Have a 2011 Holiday rambler. The handle will not release so the generator can be serviced.
Jferg55 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-27-2017, 09:25 PM   #2
Community Moderator
 
TonyDi's Avatar


 
Newmar Owners Club
Join Date: Feb 2011
Location: Point Pleasant Beach, NJ
Posts: 22,852


Glad to have you here in the forum with us.

Not sure about your genny but mine has two release points. Have you previously had it out?

Happy Trails!!!
__________________
Tony & Ruth........... FMCA#F416727
2016 London Aire 4519, Freightliner chassis, Cummins ISX, 2018 Jeep Wrangler Unlimited, Blue Ox Avail with AF1. TST 507 TPMS
TonyDi is online now   Reply With Quote
Old 01-28-2017, 08:44 AM   #3
Senior Member
 
Fiesta48's Avatar
 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Nov 2010
Location: Texas
Posts: 3,250
Fleetwood Discovery 2015

Like everything, it needs to be serviced and lubricated. Ignore it and you'll have problems. I oil the rollers yearly.
__________________
Full Timers.
2015 Fleetwood Discovery 40E on a Freightliner XCS chassis with a Cummins ISL9 pulling 1 and/or 2 motorcycles, '07 Honda Accord OR a 17' Runabout Boat.
Fiesta48 is offline   Reply With Quote
Old 01-29-2017, 07:07 AM   #4
Senior Member
 
jimmy braden's Avatar
 
Texas Boomers Club
Holiday Rambler Owners Club
Join Date: Jun 2002
Location: What? Like right now? ;-)
Posts: 1,275
Mine had the same problem. Get someone to kind of give the top left or right side a strike as you tug. If all else fails crawl under it and make sure the chains are snug. They might not be releasing the latch enough. You can also release the latch from below to get it open and get a look at it. I had to adjust my front cover for the gen before it would open with out binding.
__________________
2003 Scepter 40PDBB - Roadmaster RR8S - Cummins ISC350 - purch aug16
jimmy braden is offline   Reply With Quote
Old 01-29-2017, 07:54 AM   #5
Member
 
philand's Avatar
 
Join Date: Feb 2011
Location: Mountain Home, AR
Posts: 66
I found I have to give it a nudge inward to "unload" the latch, then it releases and rolls out.
__________________
Phil, '05 Safari Cheetah 38PDQ
'11 Ford Escape (so far, so good)
philand is offline   Reply With Quote
Old 01-31-2017, 04:22 PM   #6
Member
 
Join Date: Mar 2016
Location: Smack dab in the middle
Posts: 58
Yes, they can be a little finicky at times. Last year I was having a problem with mine. It would not stay latched. Found this out during some hard braking, scared the $&@" out of me when it opened all the sudden. Somehow the chains tighten up and it would not latch.
You deffinatly need to service, lube and adjust the chains as needed. Chains typically stretch, so tightening would be needed.
Oh mine is a 99 monaco Windsor
Good luck.
Krutzmart is offline   Reply With Quote
Reply

Tags
ems, generator, problems, slide



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flat Towing a Mini Cooper Manual Transmission - has anyone had problems? MN_Traveler Toads and Motorhome Related Towing 25 08-27-2015 10:15 AM
Has anyone had problems getting warranty work done? Nedra Ford Motorhome Chassis Forum 5 08-27-2014 01:53 PM
Has anyone had a problem with Onan generator shutting down in hot weather? Dave1194 RV Systems & Appliances 11 07-13-2014 08:13 PM
Has anyone had their Monaco/HR etc serviced at Risco RV bullydogs1 Monaco Owner's Forum 2 11-24-2008 08:27 AM
Has anyone had the slide shoe glides replaced out of warranty? LK23 Winnebago Industries Owner's Forum 5 10-16-2008 02:00 PM


All times are GMT -6. The time now is 07:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.