Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-11-2016, 07:12 PM   #1
Junior Member
 
Join Date: Nov 2016
Posts: 12
HELP. 2013 Itasca Sunstar 35B NO TV

Well my wife and I are on our first adventure in our new 2013 Itasca Sunstar35B. We have cable at our campground and have hooked it up to the coax cable input outside the coach. All TV's in the coach have power but none of them have signal from the cable. What are we doing wrong? The owners manual simply states to turn off the antenna booster which we have done but we still have no TV. Any ideas???? Thanks. Mitch.
coachmitch is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-11-2016, 07:16 PM   #2
Senior Member
 
ScottyBye's Avatar
 
Join Date: Jul 2013
Location: Calgary, Alberta, Canada
Posts: 596
Do you have an audio/visual receiver. If so. It probably need to be set to cable.
__________________
2008 Fleetwood Southwind 36D
8.1L Vortec Gas with 5SP Allison Tranny
W-24 Workhorse Chassis
ScottyBye is offline   Reply With Quote
Old 11-11-2016, 07:16 PM   #3
Senior Member
 
Bill Hunt's Avatar


 
Join Date: Jun 2014
Location: Waynesboro MS
Posts: 468
I was going to suggest turning off the booster but you've done that so maybe someone else has another idea. Sorry....
__________________
Bill & Sandy Hunt
2017 Ventanna LE 4037, 2014 F-150 4 door, 2013 Jeep Wrangler
Newmar Kountry Klub, Peach State Krackers
Newmar Hoots looking for a roost
Bill Hunt is offline   Reply With Quote
Old 11-11-2016, 07:17 PM   #4
Senior Member
 
affreeman's Avatar
 
Winnebago Owners Club
Join Date: Mar 2016
Location: Wherever I go, there I am
Posts: 574
You've cycled through the inputs on the TV?
__________________
Allen "Monkeywrench" Freeman, Full-time Nomad
2011 Itasca Sunstar 35F AKA The AdventureMobile
Dragging around a 2013 Ford Edge with a Blue Ox Alpha Tow Bar and an RViBrake3
affreeman is offline   Reply With Quote
Old 11-11-2016, 07:18 PM   #5
Senior Member
 
ScottyBye's Avatar
 
Join Date: Jul 2013
Location: Calgary, Alberta, Canada
Posts: 596
HELP. 2013 Itasca Sunstar 35B NO TV

And depending on what setup you have. You may need to check and see what input on the tv utilizes the cable connection.
__________________
2008 Fleetwood Southwind 36D
8.1L Vortec Gas with 5SP Allison Tranny
W-24 Workhorse Chassis
ScottyBye is offline   Reply With Quote
Old 11-11-2016, 07:19 PM   #6
Junior Member
 
Join Date: Nov 2016
Posts: 12
I do not know if I have an AV receiver. It did not mention one in the owners manual. Again.....First RV.....First Trip. Where would it be??
coachmitch is offline   Reply With Quote
Old 11-11-2016, 07:20 PM   #7
Junior Member
 
Join Date: Nov 2016
Posts: 12
Quote:
Originally Posted by ScottyBye View Post
And depending on what setup you have. You may need to check and see what input on the tv utilizes the cable connection.
I went through the entire setup procedure on the TV. I set it to cable and it searched for channels but found none.
coachmitch is offline   Reply With Quote
Old 11-11-2016, 07:22 PM   #8
Junior Member
 
Join Date: Nov 2016
Posts: 12
Quote:
Originally Posted by ScottyBye View Post
And depending on what setup you have. You may need to check and see what input on the tv utilizes the cable connection.
I checked all of the inputs. Nothing on any of the inputs. I even hooked up the box to the coach next to mine to confirm that the outside box and cable were good. The worked on his coach.
coachmitch is offline   Reply With Quote
Old 11-11-2016, 07:25 PM   #9
Senior Member
 
ScottyBye's Avatar
 
Join Date: Jul 2013
Location: Calgary, Alberta, Canada
Posts: 596
Do you have a control box that looks like or similar to this?
Click image for larger version

Name:	ImageUploadedByiRV2 - RV Forum1478917527.029868.jpg
Views:	80
Size:	69.9 KB
ID:	144126
__________________
2008 Fleetwood Southwind 36D
8.1L Vortec Gas with 5SP Allison Tranny
W-24 Workhorse Chassis
ScottyBye is offline   Reply With Quote
Old 11-11-2016, 07:33 PM   #10
Junior Member
 
Join Date: Nov 2016
Posts: 12
Not that I can find. I have looked in all the cabinets.
coachmitch is offline   Reply With Quote
Old 11-11-2016, 07:36 PM   #11
Senior Member
 
ScottyBye's Avatar
 
Join Date: Jul 2013
Location: Calgary, Alberta, Canada
Posts: 596
I have only owned 3 motor homes. But all 3 have has a box like this. My manual calls it a video selector box. In my units it has always been located in one of the overhead compartments at the front of the coach.
Question... older CRT style tv or newer flat panel.
__________________
2008 Fleetwood Southwind 36D
8.1L Vortec Gas with 5SP Allison Tranny
W-24 Workhorse Chassis
ScottyBye is offline   Reply With Quote
Old 11-11-2016, 07:39 PM   #12
Senior Member
 
ScottyBye's Avatar
 
Join Date: Jul 2013
Location: Calgary, Alberta, Canada
Posts: 596
Because you could always check the back of the tv. If it has a direct cable connection you could try plugging in directly. Just until u figure out what's going on. Either way... the tv has to be hooked up to something. I would trace any cables that plug into the tv a see where they go.
__________________
2008 Fleetwood Southwind 36D
8.1L Vortec Gas with 5SP Allison Tranny
W-24 Workhorse Chassis
ScottyBye is offline   Reply With Quote
Old 11-11-2016, 07:43 PM   #13
Senior Member
 
affreeman's Avatar
 
Winnebago Owners Club
Join Date: Mar 2016
Location: Wherever I go, there I am
Posts: 574
I'm guessing that since it's a 2013 and it's your first trip, you bought the coach used. Do you know that the TV works with the antenna? I'm wondering if the previous owner had installed some other A/V equipment that he took out when he sold it, and there now is nothing connected to the TV.
__________________
Allen "Monkeywrench" Freeman, Full-time Nomad
2011 Itasca Sunstar 35F AKA The AdventureMobile
Dragging around a 2013 Ford Edge with a Blue Ox Alpha Tow Bar and an RViBrake3
affreeman is offline   Reply With Quote
Old 11-11-2016, 07:49 PM   #14
Senior Member
 
ScottyBye's Avatar
 
Join Date: Jul 2013
Location: Calgary, Alberta, Canada
Posts: 596
Quote:
Originally Posted by affreeman View Post
I'm guessing that since it's a 2013 and it's your first trip, you bought the coach used. Do you know that the TV works with the antenna? I'm wondering if the previous owner had installed some other A/V equipment that he took out when he sold it, and there now is nothing connected to the TV.

Definitely a possibility
__________________
2008 Fleetwood Southwind 36D
8.1L Vortec Gas with 5SP Allison Tranny
W-24 Workhorse Chassis
ScottyBye is offline   Reply With Quote
Reply

Tags
itasca



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 Itasca Sunstar 30T In Classifieds captbru Winnebago Industries Owner's Forum 0 11-02-2016 04:23 PM
Dismounting TV in 2013 Itasca Sunstar 30T Still Bill Winnebago Industries Owner's Forum 3 11-05-2014 08:35 PM
2013 Itasca Sunstar 35B Ron Frank Winnebago Industries Owner's Forum 10 04-04-2013 05:03 AM


All times are GMT -6. The time now is 04:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.