RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-20-2020, 02:15 PM   #1
Senior Member
 
Join Date: Sep 2020
Posts: 124
House battery overcharged?

Prior owner put in 3 new agm batteries 1 year ago. All looked vented and sucked in...

Chassis alternator puts out 14.3 volts... all the time...

Generator charging the batteries starts at 14.3 and goes to 13.3 presumably when done...

Buy chassis never lowers the voltage. Prior owner had lots of issues with the alternator not charging the house batteries. He had several relays replaced multiple times...

Is there a systematic way to check for issues? Or is that normal?

Chassis amp meter shows chassis batteries 100% charged, but 3 amps still flowing into them constantly...

Any help appreciated...
bpu699 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-20-2020, 02:36 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 24,178
What voltage are the chassis batteries sitting at when the 3 amps are going into them ?

A few amps is normal but the volts should be less the 14. You may be missing a battery sense wire from the chassis battery to the alternator.
twinboat is offline   Reply With Quote
Old 09-20-2020, 03:05 PM   #3
Senior Member
 
Join Date: Sep 2020
Posts: 124
Chassis battery at 14.3 or so, based on voltage from cigarette lighter outlet...
bpu699 is offline   Reply With Quote
Old 09-20-2020, 03:13 PM   #4
Senior Member
 
153stars's Avatar
 
Join Date: Mar 2019
Location: Braidwood Il.
Posts: 1,856
Alternator not charging house and charger not charging chassis seems to be most common discussed shared issue across every manufacture . A lot have replaced diode isolators , big boy solenoid and or BIRD charge relay with Bluesea ACR. Just search Bluesea many posts diagrams and pics. Lifetime warranty no one has mentioned failure. Pasted first one that popped up if seen for about $200
https://www.waytekwire.com/item/7800...hoCgikQAvD_BwE
__________________
95 Monaco Crown Royale
M11 400hp, 4060 trans.
Aquahot, Generac Guardian7.5k
153stars is offline   Reply With Quote
Old 09-20-2020, 04:48 PM   #5
Senior Member
 
Join Date: Jul 2014
Posts: 24,178
Quote:
Originally Posted by 153stars View Post
Alternator not charging house and charger not charging chassis seems to be most common discussed shared issue across every manufacture . A lot have replaced diode isolators , big boy solenoid and or BIRD charge relay with Bluesea ACR. Just search Bluesea many posts diagrams and pics. Lifetime warranty no one has mentioned failure. Pasted first one that popped up if seen for about $200
https://www.waytekwire.com/item/7800...hoCgikQAvD_BwE
What's that got to do with the subject ?
twinboat is offline   Reply With Quote
Old 09-20-2020, 04:52 PM   #6
Senior Member
 
Join Date: Jul 2014
Posts: 24,178
The alternator is overcharging. Take a look at the alternator and see if one of the smaller wires is lose or broken off.
twinboat is offline   Reply With Quote
Old 09-20-2020, 04:57 PM   #7
Senior Member
 
Join Date: Sep 2020
Posts: 124
Will do, has to wait til next weekend though...

Reading the tech notes from the non charging situation he mentions doing a jumper wire to check and that it worked fine... I do wonder if they screwed something up, making it charge... but not down regulating...

You’re taking about the voltage feedback wire to the alternator? Will check...

Sigh, when you buy something new there’s a million things to fix...
bpu699 is offline   Reply With Quote
Old 09-21-2020, 06:45 AM   #8
Senior Member
 
153stars's Avatar
 
Join Date: Mar 2019
Location: Braidwood Il.
Posts: 1,856
QUOTE=twinboat;5448528]What's that got to do with the subject ?[/QUOTE]
OP writes at end....
"Prior owner had lots of issues with the alternator not charging the house batteries. He had several relays replaced multiple times..."

Twinboat...
Pretty sure you already hit on the head as usual with alternator sense wire . Sounded like he was asking about two separate issues . I should have more clear I trying to answer the second and don't believe two are related unless sense wire somehow is tied to house batteries.[
Also I can't find or see your coach in signature or in about you stats. To see type of alternator you may have.if it has sense wire. If there is/was a diode battery isolator/combiner wires laid out like mine . Someone could have mistakenly put sense wire to house set of batts.Or if he did a lot of swapping wires around combiner solenoid .
__________________
95 Monaco Crown Royale
M11 400hp, 4060 trans.
Aquahot, Generac Guardian7.5k
153stars is offline   Reply With Quote
Old 09-21-2020, 07:26 AM   #9
Senior Member
 
Join Date: Sep 2020
Posts: 124
Quote:
Originally Posted by 153stars View Post
QUOTE=twinboat;5448528]What's that got to do with the subject ?
OP writes at end....
"Prior owner had lots of issues with the alternator not charging the house batteries. He had several relays replaced multiple times..."

Twinboat...
Pretty sure you already hit on the head as usual with alternator sense wire . Sounded like he was asking about two separate issues . I should have more clear I trying to answer the second and don't believe two are related unless sense wire somehow is tied to house batteries.[
Also I can't find or see your coach in signature or in about you stats. To see type of alternator you may have.if it has sense wire. If there is/was a diode battery isolator/combiner wires laid out like mine . Someone could have mistakenly put sense to house set of batts.Or if he did a lot of swapping wires around combiner solenoid .[/QUOTE]

Thanks all, every bit helps...

2000 winnebago ultimate advantage on freightliner chassis...


Also, does the alternator charge the chassis and house battery at the same time (ie. In parallel)? I ask as the voltage on both is identical, I would think it would be different between the two...
bpu699 is offline   Reply With Quote
Old 09-21-2020, 05:00 PM   #10
Senior Member
 
Join Date: Apr 2020
Posts: 758
You have a solenoid that connects the house and chassis batteries together when the engine is running/ when the generator is running/ when you are on shore power and the primary battery(ies) get to a certain voltage, predetermined by the BCC/BIRD
__________________
2006 Damon Daybreak 3276 35'. 3 200 Amp Lithium batteries and 2000 watt Pure wave inverter/charger.
2013 Elantra on a Master Tow dolly.
HarryStone is offline   Reply With Quote
Reply

Tags
battery



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chassis battery's overcharged meyr Class A Motorhome Discussions 8 08-16-2018 06:39 AM
overcharged house batteries? deprived MH-General Discussions & Problems 14 06-22-2016 12:31 PM
Was I overcharged by Camping World ?? TomMiller iRV2.com General Discussion 61 03-13-2015 10:02 AM
Did I get overcharged on an Allison Trans Service? Old Snipe Workhorse and Chevrolet Chassis Motorhome Forum 13 04-08-2006 03:29 PM
Cold weather experiences, overcharged batteries?? smlranger Winnebago Industries Owner's Forum 13 02-20-2006 07:23 PM


All times are GMT -6. The time now is 11:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.