Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-23-2016, 06:22 AM   #1
Senior Member
 
Join Date: Jan 2014
Location: South Carolina
Posts: 120
HR dash lights not working

As it was getting dark last night before we arrived at our destination, we realized the dash lights on our 2003 HR Endeavor are not working. Gauges and all other lights work. Suggestions on what the problem is or how to fix? Thanks.
__________________
Dan and Ann and heinz 57 pups, Petey and Patty
2020 Tiffin Allegro, 36UA
2015 Chevy Sonic LTZ or 2016 Polaris Slingshot on trailer
Dan and Ann is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-23-2016, 07:22 AM   #2
Registered User
 
Join Date: Nov 2016
Posts: 520
Quote:
Originally Posted by Dan and Ann View Post
As it was getting dark last night before we arrived at our destination, we realized the dash lights on our 2003 HR Endeavor are not working. Gauges and all other lights work. Suggestions on what the problem is or how to fix? Thanks.
From what I've read the most common cause of "no dash lights" is a bad ground wire connection.
Woodchopper is offline   Reply With Quote
Old 11-23-2016, 10:39 AM   #3
Senior Member
 
computerguy's Avatar
 
Join Date: Jul 2010
Location: FT on the Road
Posts: 2,807
I had a '05 Monaco with a similar problem. Bad/loose ground wire found and tightened to fix the issue.
__________________
I don't make it much on here anymore so will not see your reply to my comment. Drop me a direct message and when I come back on I will see it.
Cheers!
computerguy is online now   Reply With Quote
Old 11-24-2016, 07:22 AM   #4
Senior Member
 
Join Date: Jan 2014
Location: South Carolina
Posts: 120
Quote:
Originally Posted by computerguy View Post
I had a '05 Monaco with a similar problem. Bad/loose ground wire found and tightened to fix the issue.
Thank you. Where should we start looking to find the ground wire? At the light switch?
__________________
Dan and Ann and heinz 57 pups, Petey and Patty
2020 Tiffin Allegro, 36UA
2015 Chevy Sonic LTZ or 2016 Polaris Slingshot on trailer
Dan and Ann is offline   Reply With Quote
Old 11-24-2016, 08:15 PM   #5
Senior Member
 
ScottyBye's Avatar
 
Join Date: Jul 2013
Location: Calgary, Alberta, Canada
Posts: 596
Just a quick check to see if you have a grounding issue. You could always connect a temporary ground wire from the ground side of the dash lights to a good clean chassis bolt. And see if that fixes your problem.
__________________
2008 Fleetwood Southwind 36D
8.1L Vortec Gas with 5SP Allison Tranny
W-24 Workhorse Chassis
ScottyBye is offline   Reply With Quote
Old 11-24-2016, 10:09 PM   #6
Senior Member
 
ScottyBye's Avatar
 
Join Date: Jul 2013
Location: Calgary, Alberta, Canada
Posts: 596
I forgot to ask.... did you check the fuse. ??
__________________
2008 Fleetwood Southwind 36D
8.1L Vortec Gas with 5SP Allison Tranny
W-24 Workhorse Chassis
ScottyBye is offline   Reply With Quote
Reply

Tags
dash, light, lights



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash lights not working on 2001 40 Ft. Holiday Rambler allatoona Monaco Owner's Forum 11 09-26-2016 06:34 PM
Dash warning lights not working AlpineRivers Alpine Coach Owner's Forum 8 05-01-2014 04:55 PM
turn signals, running lights, tow lights side clearance lights not working gowhiz Tiffin Owner's Forum 3 02-26-2014 07:02 AM
Dash lights not working ronrico3 RV Systems & Appliances 0 07-18-2012 09:59 AM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 04:22 AM


All times are GMT -6. The time now is 07:21 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.