Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-19-2021, 03:31 PM   #1
Junior Member
 
robbier49's Avatar
 
Tiffin Owners Club
Join Date: Sep 2015
Location: Destin, Fl.
Posts: 13
LSL Amp L Start reviews and experience

I am looking for user reviews and experience on longevity.
I am on my second amp l start and I think it has quit again after 6 months.
The original instal lasted over 5 1/2 years. When it failed I had emailed LSL support and after several back and forth emails. The owner graciously sent me one of their newest models.
The original unit did not have the jumper option as the replacement “H2” version. I was able to use this to lower the cut on voltage from 13.2vdc to 12.7 vdc.
It has worked flawlessly for 6 months but now the voltage is dropping below the 12.7 and even though the charging light on the amp l start is blinking the voltage keeps dropping. I am currently using a ctek charger to float charge these chassis batteries.
The light on the amp l start stays on the blinking charge mode regardless of battery voltage from the ctek charger (12.9 to 14.7)
What has been your experience with life and reliability of these “Amp L Start maintainers?
I am starting to look at any other options out there. This is only an issue when we are parked for over a month. I hate to permanently install the battery charger and have to remember to cut it on to enable the float charging.
After being left with two dead chassis batteries last year, I am anal on monitoring these chassis batteries voltage. I installed a Victron Bluetooth device that lets me look at voltage from my phone. Which I do at least twice a day.
Anyone who has had these issues and suggestions on what they did to resolve them would be most appreciated.
I could have just got a defective amp l start and will buy another if owners think this is my best option.
Thanks to all for any input.
Robert
__________________
Robert & Bessie Roberson
2008 Allegro Bus QRP 40'
Cummins ISL400
robbier49 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-19-2021, 04:32 PM   #2
Senior Member
 
paul65k's Avatar


 
Alpine Owners Club
Join Date: Nov 2015
Location: Lake Havasu City, AZ
Posts: 2,266
Quote:
Originally Posted by robbier49 View Post
I am looking for user reviews and experience on longevity.
I am on my second amp l start and I think it has quit again after 6 months.
The original instal lasted over 5 1/2 years. When it failed I had emailed LSL support and after several back and forth emails. The owner graciously sent me one of their newest models.
The original unit did not have the jumper option as the replacement “H2” version. I was able to use this to lower the cut on voltage from 13.2vdc to 12.7 vdc.
It has worked flawlessly for 6 months but now the voltage is dropping below the 12.7 and even though the charging light on the amp l start is blinking the voltage keeps dropping. I am currently using a ctek charger to float charge these chassis batteries.
The light on the amp l start stays on the blinking charge mode regardless of battery voltage from the ctek charger (12.9 to 14.7)
What has been your experience with life and reliability of these “Amp L Start maintainers?
I am starting to look at any other options out there. This is only an issue when we are parked for over a month. I hate to permanently install the battery charger and have to remember to cut it on to enable the float charging.
After being left with two dead chassis batteries last year, I am anal on monitoring these chassis batteries voltage. I installed a Victron Bluetooth device that lets me look at voltage from my phone. Which I do at least twice a day.
Anyone who has had these issues and suggestions on what they did to resolve them would be most appreciated.
I could have just got a defective amp l start and will buy another if owners think this is my best option.
Thanks to all for any input.
Robert
Amp-L-Start here for a bout a year now. I needed to use this as I have a 24V battery bank and 12V starting batteries so the Inverter would not keep the starting batteries topped off...... it's been great, charges from the 12V bus which is fed through a 24-12V converter so the supply voltage is always at 13.4V.....been working now for about 12 months without issue and keeps the starting batteries right at 13.2-13.3V!
__________________
Paul & Jean
2001 Alpine 36FDDS (74291)-1600W Solar, 13,440Wh (525Ah @24V) LiFePO4
2019 Jeep Grand Cherokee Trailhawk (Hemi)
2006 Alpenlite 32RL - Sold
paul65k is online now   Reply With Quote
Old 10-19-2021, 07:56 PM   #3
Junior Member
 
robbier49's Avatar
 
Tiffin Owners Club
Join Date: Sep 2015
Location: Destin, Fl.
Posts: 13
Thanks for the reply Paul. I have really liked the amp l start since I installed them. But 6 months in, on this one and it appears it is failing. I hope to get some long term usage replies. Surely there are better mousetraps out there that do the same thing only better? Stay tuned, I know someone will help me out
__________________
Robert & Bessie Roberson
2008 Allegro Bus QRP 40'
Cummins ISL400
robbier49 is offline   Reply With Quote
Old 10-19-2021, 08:35 PM   #4
Senior Member
 
153stars's Avatar
 
Join Date: Mar 2019
Location: Braidwood Il.
Posts: 4,207
Good bi-directional charging solution is Bluesea ML -ACR. It would also take the place of big boy type combiner solenoid for charging and jump starting.
You would need a few control wires to dash switch to it.
__________________
95 Monaco Crown Royale
M11 400hp, 4060 trans.
Aquahot, Generac Guardian7.5k
153stars is offline   Reply With Quote
Old 10-22-2021, 11:23 PM   #5
Junior Member
 
robbier49's Avatar
 
Tiffin Owners Club
Join Date: Sep 2015
Location: Destin, Fl.
Posts: 13
I was hoping for more information on these amp l starts from multiple owners. At the least, can someone tell me is there a way to test this to see if it is working? Other than not keeping the voltage up. The owners manual says this is supposed to cut in and start charging at 12.7 vdc with the high temperature jumper on. This appears to not be cutting on as it should. Suggestions anyone?
Robert
__________________
Robert & Bessie Roberson
2008 Allegro Bus QRP 40'
Cummins ISL400
robbier49 is offline   Reply With Quote
Old 10-23-2021, 01:36 PM   #6
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 18,960
I tried Amp L products and found that after awhile the bodies swelled and they quit. Few know that Magnum makes one.

https://www.ebay.com/itm/22311338180...9071edb6aa359c
__________________
Don & Mary
2019 Newmar Dutch Star 4018 (Freightliner)
2019 Ford Raptor
Dutch Star Don is offline   Reply With Quote
Old 10-23-2021, 04:19 PM   #7
Senior Member
 
rssnape's Avatar
 
Join Date: Oct 2011
Location: Central, SC
Posts: 541
I read the instructions. I didn’t see any place to adjust voltage. This is what I’ve used on 2 coaches and one boat. All are still working.

https://www.bepmarine.com/en/~/media...9437-25323.pdf
rssnape is offline   Reply With Quote
Old 10-23-2021, 10:40 PM   #8
Junior Member
 
robbier49's Avatar
 
Tiffin Owners Club
Join Date: Sep 2015
Location: Destin, Fl.
Posts: 13
Amp l start

Has anyone used the Magnum Energy ME-SBC Smart Battery Combiner version above. They have great inverters. Would like some feedback on these if possible.
robbier49 is offline   Reply With Quote
Old 10-24-2021, 08:05 AM   #9
Senior Member
 
Join Date: Aug 2020
Posts: 415
I installed our AMP-L-Start 5yrs ago. I'm also very anal about watching my batteries all the time. I have the ability to use the jumper on the back to lower the cut on voltage but chose not to do that. The yellow charging light is mostly ON all the time. The amount of current it steals from the house batteries is very small but does keep my chassis battery topped off.
__________________
Traveling Full Timers
Gas Motorhome
Escapees, Maintenance Freak
mr.tommy is online now   Reply With Quote
Old 10-24-2021, 09:13 PM   #10
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 18,960
Quote:
Originally Posted by robbier49 View Post
Has anyone used the Magnum Energy ME-SBC Smart Battery Combiner version above. They have great inverters. Would like some feedback on these if possible.
On my Diplomat, I used the Amp L until I had issues with it and then went with the Magnum that I linked to above. It worked great for many years and I sold the coach with it still operating perfectly.
__________________
Don & Mary
2019 Newmar Dutch Star 4018 (Freightliner)
2019 Ford Raptor
Dutch Star Don is offline   Reply With Quote
Reply

Tags
view



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TETON EXPERIENCE :: 2004 Teton Experience lformby iRV2 Owners Registry 0 11-10-2018 11:57 AM
2008 lsl 425 pulsating voltmeter while driving RichnSue Cummins Engines 18 01-30-2018 09:01 AM
Question about LSL toad charge... Is a diode needed? ajlcal Toads and Motorhome Related Towing 4 01-13-2016 03:28 PM
My experience, RVing full & part time & weekends, w/costs & other problems DougCP iRV2.com General Discussion 2 07-11-2011 09:30 AM
Petty Driving Experience - WHAT AN EXPERIENCE!! WWFan Toy Haulers Discussion 18 12-06-2005 07:21 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.