RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-06-2020, 06:12 PM   #1
Member
 
bob7889's Avatar
 
Monaco Owners Club
Nor'easters Club
Join Date: Jun 2012
Posts: 33
Magnum inverter/charger issues

I have a ME2012. I don't think it is charging. I did a soft and hard reset. No good result. Green led is on but no charging amps. I have new batteries. What is the next step to test for charging amps? What is the turn around time for a repair? Who repairs these chargers? Thanks!
__________________

bob7889 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-06-2020, 08:04 PM   #2
Senior Member
 
Reacher's Avatar
 
Tiffin Owners Club
Join Date: Apr 2019
Posts: 656
Have your new batteries been charged? The magnum charger will not charge batteries unless they are at a minimum level. Also check to see if the charge function is on.
__________________

__________________
2019 Open Road 34PA
2016 Ford C-Max Energi Toad
Reacher is offline   Reply With Quote
Old 06-06-2020, 09:05 PM   #3
Member
 
bob7889's Avatar
 
Monaco Owners Club
Nor'easters Club
Join Date: Jun 2012
Posts: 33
The charge function is on. What do you call minimum level? Voltage has dropped to 11.3. How low should it go before I can expect it to start charging?
__________________
2004.5 Monaco Diplomat ISC 8.3, 4 slides, 40 PAQ
bob7889 is offline   Reply With Quote
Old 06-06-2020, 09:19 PM   #4
Senior Member
 
vito.a's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Location: Tucson, AZ
Posts: 4,206
It should charge them in various modes depending on how low the batteries are. At 11.3v it should be in bulk charge.
So, something's wrong. Check and reset the two 110v circuit breakers in your main electrical box that provide power to the inverter. Also check the white push-in circuit breaker on the side of the inverter.

Do your inverter supplied 110v outlets work?

Magnum has a great support system with phone support and repair centers around the country. I took a Magnum inverter into our Tucson repair center and they had it repaired the next day.
__________________
97 Monaco Windsor- Sold
07 Monaco Executive McKinley- Sold
04 Monaco Signature Chateau IV
vito.a is online now   Reply With Quote
Old 06-06-2020, 09:24 PM   #5
Member
 
bob7889's Avatar
 
Monaco Owners Club
Nor'easters Club
Join Date: Jun 2012
Posts: 33
The remote displays bulk charge but 0 amps. I will check a repair center about 30 minutes from me on Monday . Thanks for the info.
__________________
2004.5 Monaco Diplomat ISC 8.3, 4 slides, 40 PAQ
bob7889 is offline   Reply With Quote
Old 06-06-2020, 10:01 PM   #6
Senior Member
 
UFO Pilot's Avatar
 
Winnebago Owners Club
Workhorse Chassis Owner
Join Date: Aug 2007
Location: Sonoma County, CA
Posts: 5,669
I called Magnum tech support when I had a charging fault, they walked me thru a full test and diagnosis. They have great tech support.
__________________
Wayne & Roberta and Maggie the Miracle Dog
08 Winnebago Destination 39W Gas UFO Workhorse Chassis......
On the road of life, it's not where you go but who you're with that makes the difference.
UFO Pilot is offline   Reply With Quote
Old 06-06-2020, 10:52 PM   #7
Senior Member
 
Join Date: Feb 2010
Posts: 666
Is you green light steady or flashing at 1 time per second? If it is flashing then you need to start something with 5 watts to bring it out of search mode. If it flutters it is in reset . Have you check the circuit breaker to make sure it hasn't popped?
Are you on shore power or generator.
Have you checked to see if you have 12 volt coming into the inverter?
__________________
2008 Thor, Four Winds Mandalay 40G. Cummins 400 isl. Freightliner chassis
koda59 is offline   Reply With Quote
Old 06-07-2020, 01:27 AM   #8
Member
 
bob7889's Avatar
 
Monaco Owners Club
Nor'easters Club
Join Date: Jun 2012
Posts: 33
I am on shore power. The led is steady on. I do have 12 vdc into the inverter. The remote displays, with 4 new batteries, 11.3 v bulk charging 0 amps.
__________________
2004.5 Monaco Diplomat ISC 8.3, 4 slides, 40 PAQ
bob7889 is offline   Reply With Quote
Old 06-07-2020, 10:19 AM   #9
Senior Member
 
757driver's Avatar


 
Entegra Owners Club
Join Date: Jun 2004
Location: Cambridge, Ontario
Posts: 4,092
Quote:
Originally Posted by bob7889 View Post
I am on shore power. The led is steady on. I do have 12 vdc into the inverter. The remote displays, with 4 new batteries, 11.3 v bulk charging 0 amps.
Some other things to check.

Ensure battery cables at inverter and batteries are tight. Check for a failing class T fuse in the positive line running from the inverter to battery. Try removing power to inverter for 30 sec and reconnect. Disconnect shore power first. Caution on a Magnum inverter must remove positive cable first. Check your battery temp sensor’s temperature as compared to outside air temperature (should be close). This can be found in the TECH menu under temperatures.
__________________
Don & Gerri
2014 Entegra Anthem 44B
2014 Honda CRV Touring

1300W Solar, 1200AH LiFePO4 FMCA F443497
757driver is offline   Reply With Quote
Old 06-07-2020, 10:28 AM   #10
Senior Member
 
757driver's Avatar


 
Entegra Owners Club
Join Date: Jun 2004
Location: Cambridge, Ontario
Posts: 4,092
Also found this.

Charge amps are lower than expected, or is 0 amps DC: Measure input AC voltage and increase if the input voltage is under 90 VAC. The charge rate is reduced to try and keep the input voltage above 90 VAC; also check the Shore Max (p. 6) and 03C Max Charge Rate (p. 13) settings to determine if the current is being limited.

What shore power are you connected to? Check it’s voltage and/or try another plug. Fire up the generator and see if that power source changes things.
__________________
Don & Gerri
2014 Entegra Anthem 44B
2014 Honda CRV Touring

1300W Solar, 1200AH LiFePO4 FMCA F443497
757driver is offline   Reply With Quote
Old 06-07-2020, 11:57 AM   #11
Senior Member
 
Reacher's Avatar
 
Tiffin Owners Club
Join Date: Apr 2019
Posts: 656
11.3 volts shows your batteries as dead. The inverter charger will not charge a dead battery. You need to charge them individually with a regular charger to bring the voltage up for the charger to take over. Sometimes you can trick the unit into charging if your chassis batteries are good by using the start boost switch momentarily to start charging.
__________________
2019 Open Road 34PA
2016 Ford C-Max Energi Toad
Reacher is offline   Reply With Quote
Old 06-07-2020, 12:13 PM   #12
Senior Member
 
757driver's Avatar


 
Entegra Owners Club
Join Date: Jun 2004
Location: Cambridge, Ontario
Posts: 4,092
Quote:
Originally Posted by Reacher View Post
11.3 volts shows your batteries as dead. The inverter charger will not charge a dead battery. You need to charge them individually with a regular charger to bring the voltage up for the charger to take over. Sometimes you can trick the unit into charging if your chassis batteries are good by using the start boost switch momentarily to start charging.
If that were the case then “Dead Battery Charge” would be shown in the remote display. Also the battery bank at 11.3v should charge just fine from the Magnum charger. IF the Magnum remote panel showed 9.0 v or less then the charger would NOT kick in and an external charger would be needed to bring the indicated voltage up to 12.6v for the Magnum charger to take over.
__________________
Don & Gerri
2014 Entegra Anthem 44B
2014 Honda CRV Touring

1300W Solar, 1200AH LiFePO4 FMCA F443497
757driver is offline   Reply With Quote
Old 06-07-2020, 06:50 PM   #13
Senior Member
 
Join Date: Feb 2010
Posts: 666
After you changed you batteries and before hooking up external electrical power did you turn on your inverter by pushing the on/of button?
You low battery battery cut out is 10 volts dc.
Do you have something turned on with at least 5 amps?
__________________
2008 Thor, Four Winds Mandalay 40G. Cummins 400 isl. Freightliner chassis
koda59 is offline   Reply With Quote
Old 06-07-2020, 08:14 PM   #14
Member
 
Join Date: Jan 2017
Location: Indiana
Posts: 94
I had a inverter/charger that was passing thru a/c but not charging. I done a factory reset and then reset the battery settings and it then worked. The battery settings were correct before the factory reset but something wasn’t right with the computer of the unit. The factory reset was a hard boot and it then worked.
__________________

__________________
2015 Winnebago Journey 36M
2013 Jeep Wrangler Unlimited
Air Force One brake
vanmark is offline   Reply With Quote
Reply

Tags
charger, inverter



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
THe Charger side of my Kisae Inverter/Charger died, is a separate Charger good idea? elkski RV Systems & Appliances 0 03-31-2020 01:51 PM
Inverter+Charger or Inverter/charger blevtr RV Systems & Appliances 1 10-17-2019 11:19 AM
Upgrading from Magnum ME-2000 MSW inverter to Magnum ME-2800 PSW inverter. Stan&Jacquie MH-General Discussions & Problems 7 11-12-2015 07:54 PM
Problems with Magnum Inverter Charger Bill2 Monaco Owner's Forum 2 07-30-2010 07:56 AM
Magnum Charger/Inverter Info Dutch Star Don Monaco Owner's Forum 3 06-12-2010 12:55 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×