RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-01-2018, 06:34 PM   #1
Junior Member
 
Join Date: Jul 2018
Posts: 8
Monaco Diplomat 2012 help

Awhile back I posted about suggestions for reasons why my hazard lights would come on when I turn on my master battery switch and when I turn the key to start that coach ,the wipers come on...neither go off unless you unplug or pull the relay..
I checked all suggestions from everyone replies..I've..cleaned the connections I've checked the fuses\relays etc..
I'm thinking it's the board....

Can anyone help me locate this circuit board,
16626855
Thanks in advance...
P.S.
Still trying to figure this out
Attached Thumbnails
Click image for larger version

Name:	IMG_20180801_181050.jpg
Views:	31
Size:	534.6 KB
ID:	213498   Click image for larger version

Name:	IMG_20180801_181102.jpg
Views:	40
Size:	578.8 KB
ID:	213499  

ADuhe is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-02-2018, 06:05 AM   #2
Senior Member
 
Dsallach's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Location: Jensen Beach, Florida
Posts: 753
Before you replace a board, Have you tried Calling Monaco Technical Support at 877-466-6226, Mon-Fri from 7 a.m. to 4 p.m. PT.
__________________
Happy Camping, Safe travels and may our paths cross someday!

40' 2000 Monaco Windsor, ISC350 Cummings w/Allison 3000 6 speed and Jeep Cherokee toad. We're all old but, we keep on trucking!
Dsallach is offline   Reply With Quote
Old 08-02-2018, 10:49 AM   #3
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 43,816
Hi ! Welcome to IRV2! We're sure glad you joined the gang!

I can't help with that but wanted to say hello.

Good luck, happy trails, and God bless!
__________________
Joe & Annette
Sometimes I sits and thinks, sometimes I just sits.....
2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 08-02-2018, 12:11 PM   #4
Junior Member
 
Join Date: Jul 2018
Posts: 8
I have call numerous # for assistance but no one csll assist....including Monaco..
It seem the board is getting power at all times...regardless if the battery switch is on or off
ADuhe is offline   Reply With Quote
Old 08-02-2018, 12:30 PM   #5
Senior Member
 
Dsallach's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Location: Jensen Beach, Florida
Posts: 753
Has this system ever worked without this issue since you owner the rig? The photo is fuzzy when you zoom in. It appears that there are several identical relays on the board. Have you tried switching them to see if it changes the issue?
You hazard flashers should workable the time regardless if the ignition switch is on or off. My guess is the board should have power at all times if it controls the flashers. Do you have a wiring diagram for your unit?
You have a different unit than mine. On mine the windshield wiper controls are on the steering column. The control relays for them are on the smart wheel control board. Have you checked the steering column and ignition switch wiring. It almost sounds like you have two wires that have worn enough to jump like a spark when a sudden voltage is applied. Are the flasher controls on the column also?
__________________
Happy Camping, Safe travels and may our paths cross someday!

40' 2000 Monaco Windsor, ISC350 Cummings w/Allison 3000 6 speed and Jeep Cherokee toad. We're all old but, we keep on trucking!
Dsallach is offline   Reply With Quote
Old 08-02-2018, 07:03 PM   #6
Junior Member
 
Join Date: Jul 2018
Posts: 8
No we never had this problem before .. it was in the shop unplugged for six weeks when we went to pick it up we had this problem.. and yes the windshield wiper control and the flasher control is on the steering wheel column... ..l have the same problem even when I unplug the controller from the steering column for the hazards and windshield wiper still function.. ..yes the relays are all the same and I've tried swapping them around ,still no change ..flashers continuously stay on once the master switch is turned on and windshield wipers come on once the key is turned..
And it seems no one has a wire diagram for my 2012 Monaco diplomat..
Thank you for taking the time to help me out..
ADuhe is offline   Reply With Quote
Old 08-02-2018, 07:05 PM   #7
Junior Member
 
Join Date: Jul 2018
Posts: 8
We had a window changed due to fogging issues..
ADuhe is offline   Reply With Quote
Old 08-02-2018, 08:40 PM   #8
Senior Member
 
ThePowells's Avatar


 
Join Date: Mar 2017
Location: Zebulon, NC
Posts: 5,207


Welcome to the forum!



We're sorry that it took such a problem for you to join us and we hope that you will stay engaged in the forum after you have a resolution.
__________________
Kelly and Jerry Powell with Halo (Lethal White Aussie), Nash the Rat Terrorist, and now Reid, the "Brindle we have no idea puppy"
2020 Grand Design Solitude 390RK-R
ThePowells is offline   Reply With Quote
Old 08-03-2018, 07:22 AM   #9
Senior Member
 
Dsallach's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Location: Jensen Beach, Florida
Posts: 753
What controller are you unplugging from the column? Is it the smart wheel controller?
Just thinking out loud, Since you never had this problem before it was in the shop for repairs it seems logical that something happened while it was there. Did they short something or try to jump the rig with the cables reversed? Which window did they replace? Could they have put a screw through a wiring harness? Did they weld anything on the unit with the batteries connected? Did a mouse chew some wires? Have you talked to the shop?
It seems to me that the problem might be in the steering column or ignition switch area. Once you “pull” the relays to stop the flashers or wipers do they then operate properly with the switches on the column? Or if you plug the relays back in do the flashers and wipers come back on uncontrollably.
If you think it is the board, have you called Monaco to see if they have one?
__________________
Happy Camping, Safe travels and may our paths cross someday!

40' 2000 Monaco Windsor, ISC350 Cummings w/Allison 3000 6 speed and Jeep Cherokee toad. We're all old but, we keep on trucking!
Dsallach is offline   Reply With Quote
Old 08-11-2018, 08:10 AM   #10
Junior Member
 
Join Date: Jul 2018
Posts: 8
Sorry for the last reply..computer crashed...I've.unplugged both,,there's no wires that I can see that might have been hit....the window was the drivers front(due to fogging) no sure shop owner said no he only placed a charger in the batteries...no welding-no mouse-& yes but nothing,,(don't think he'd admit anyway)....
It's an uncontrollable action, unless there disconnected..
STILL trying to figure this out,,,seem I'm going to have to put it in the shop once again.... Wish me luck ,they find the problem, $135. Can add up very quickly...
Still trying to locate a wiring diagram on my coach with no prevail....
ADuhe is offline   Reply With Quote
Reply

Tags
monaco diplomat, monaco



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 Monaco Diplomat 36 PST DP :: 2003 Monaco Diplomat 36 PST DP Jimmmr iRV2 Owners Registry 0 05-26-2018 12:46 PM
2016 Monaco Diplomat 43SG :: 2016 Monaco Diplomat 43SG JWBranning iRV2 Owners Registry 0 07-05-2017 08:43 AM
1999 Monaco Diplomat 38A :: 1999 Monaco diplomat TGunn1 iRV2 Owners Registry 0 10-05-2016 12:06 AM


All times are GMT -6. The time now is 11:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.