Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-26-2022, 10:53 AM   #1
Junior Member
 
Join Date: Mar 2022
Posts: 19
Monaco Executive no start

I have a 2006 Monaco Executive Rainer 41 foot with a Cummings 525 ISX that was running fine. I had it at home idling while I checked the refrigerant in the dash AC. I was getting tools when the engine just shut down. Now I have a no start problem.

It is throwing communication error codes J1939, J1587, J1708, SID 231, ABS and check engine light are both on, the gauges some times are erratic.

I checked the batteries, have disconnected the batteries overnight, tried several rest procedures and sill nothing. I have seen some threads that touch on the subject but they don't have enough detailed information to help me.

I know these are communication codes and involve the computers I just don't know where the computers are located. My research also has two different color wire schemes. Not sure where to go from here. Yes it has fuel and generator runs

Bill
Monaco Bill is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-26-2022, 11:12 AM   #2
Senior Member
 
Warhorse6's Avatar
 
Join Date: Jul 2020
Posts: 450
http://www.rvtechmag.com/docs/Faultcodes_Cummins.pdf

Here are the Cummins fault codes. Hope this helps you narrow it down.
__________________
2018 Phaeton 44OH
2017 Chevy Traverse Toad
Florida
Warhorse6 is online now   Reply With Quote
Old 06-26-2022, 11:16 AM   #3
Senior Member
 
Triple E Owners Club
Join Date: May 2021
Location: Eagle Territory
Posts: 119
Here is a little insight

https://mitchell1.com/shopconnection...entifies%20the

You need a mechanic
Latech is offline   Reply With Quote
Old 06-26-2022, 11:20 AM   #4
Senior Member
 
Triple E Owners Club
Join Date: May 2021
Location: Eagle Territory
Posts: 119
https://www.noregon.com/guide-to-sae-j1939/
Latech is offline   Reply With Quote
Old 06-26-2022, 12:56 PM   #5
Junior Member
 
Join Date: Mar 2022
Posts: 19
I don't seem to have a FMI or SPN code. working with reader to try and obtain these codes.
Reader is small and inexpensive, I don't know if I need a better scanner.
Monaco Bill is offline   Reply With Quote
Old 06-26-2022, 02:10 PM   #6
Senior Member
 
Join Date: Apr 2018
Posts: 1,986
Start cleaning grounds, disconnect the ecm wiring, spray with contact cleaner, all the usual stuff before taking it to a mechanic. They could start replacing parts and you'll have a huge bill with nothing to show for it.
shootist is offline   Reply With Quote
Old 06-27-2022, 02:54 PM   #7
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 11,662
You probably need a different code reader.



When was the last time you changed fuel filters?

The last time I had a no start situation I had just changed fuel filter. I had air in the system and it took me fooooooor ever to get it to start. Ended up pulling the filters and starting from scratch before I finally got it started.
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Old 06-27-2022, 03:58 PM   #8
Senior Member
 
vito.a's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Location: Tucson, AZ
Posts: 5,883
Are you using a heavy diesel code reader?
Does the engine crank and not fire?
Next time you crank it over try pumping the throttle pedal rapidly.

The engine ECU is bolted to the engine, passenger side down low, but I would start checking fuses in the battery compartment and rear run bay.

Did you check the rear start/run switch in the engine bay?
__________________
97 Monaco Windsor- Sold
07 Monaco Executive McKinley- Sold
04 Monaco Signature Chateau IV
vito.a is offline   Reply With Quote
Old 06-29-2022, 07:26 AM   #9
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 26,937
Bill; I see you got another thread going about your A/C .

How did you resolve your no start ?
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 07-01-2022, 04:55 PM   #10
Junior Member
 
Join Date: Mar 2022
Posts: 19
5 days, 2 code readers, 3 service tec's, a lot of computer time and it was a 5 amp fuse in the very back fuse box. Nothing in this box was operating no LEDs were lit nothing. This fuse is on the trigger circuit for a rely that powers a lot of stuff including the ignition.
Monaco Bill is offline   Reply With Quote
Old 07-02-2022, 07:59 AM   #11
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 11,662
Any chance you could post a picture of the offending fuse & location.




Glad you got it fixed.



Last time I had a no start situation I looked at all the fuses twice. I had been working at the back of the engine and though I may have hit the rear start switch, which I checked but no go.

Went through everything again and even tested the rear start and that fixed it. Not sure if I didn't fulling engage the rear start switch or not but always something to remember.
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Old 07-02-2022, 10:34 AM   #12
Senior Member
 
vito.a's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Location: Tucson, AZ
Posts: 5,883
Yes, please post a picture?
__________________
97 Monaco Windsor- Sold
07 Monaco Executive McKinley- Sold
04 Monaco Signature Chateau IV
vito.a is offline   Reply With Quote
Old 07-03-2022, 07:40 PM   #13
Junior Member
 
Join Date: Mar 2022
Posts: 19
Pictures of fuse

This is a picture and a diagram of the problem fuse I had that caused Engine to just stop and then a NO START condition. It is in the very back engine compartment Fuse panel. It is the one with all of the battery relays. The fuse is on Panel P-1. It was a standard 5 amp ATO fuse. I checked the wire size and components and it will handle 10 amps. So I replaced the ATO with a resettable circuit braker which is actually shown in the color picture as burgundy.
The fuse is not actually shown on the p1 board but I am pointing at it with a pen.

I hope this helps.
Attached Thumbnails
Click image for larger version

Name:	fuse1.jpg
Views:	7
Size:	155.2 KB
ID:	370049   Click image for larger version

Name:	fuse 2.jpg
Views:	7
Size:	147.3 KB
ID:	370050  

Monaco Bill is offline   Reply With Quote
Old 07-04-2022, 06:27 AM   #14
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 11,662
Thanks,
Wonder what caused the 5 amp fuse to blow??? You may never know.


But with a resettable CB if there is a problem it will trip, you will loose power, and will be dead in the water until it resets. But if there is a continuing problem it would happen with a fuse to.

Might be an issue if your driving down the highway on a busy city at rush hour!!!
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Reply

Tags
monaco, no start



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Monaco Executive 43PBQ :: 2005 Monaco Executive PBQ Windecker iRV2 Owners Registry 0 01-20-2018 08:35 AM
Monaco Executive :: 2001 Monaco Executive cybersaab iRV2 Owners Registry 0 12-16-2017 07:36 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:32 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.