RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-13-2017, 03:50 PM   #1
Junior Member
 
Join Date: Aug 2017
Posts: 2
Monitoring Panel/Water Pump

I have an 1989 Sportcoach Pathfinder DL S. I have had issues with the monitoring panel (switch for tank info and water pump). The display sometimes lights up but fades out. Yesterday I had it all working including the water pump. Then.....today its not. Need some ideas. Today the display lit up for a bit but faded and the pump did work at all. Bad ground? Is this running off the coach batteries? Not enough juice in these batteries? Any ideas would help.
Seayakker is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-13-2017, 04:56 PM   #2
Member
 
Join Date: Jun 2015
Posts: 62
I have a rig of the same era (1987) and had the exact same problem with a Jensen monitor panel. My solution was to spray all the switches with contact cleaner-2 years later and they're still working perfectly. In my situation I had to drill the rivets on the panel cover to get to the switches.
__________________
1987 Establishment
P30 chassis 7.4L 454 V8
Rochester Quadrajet carb
Ryan7361 is offline   Reply With Quote
Old 08-14-2017, 07:17 PM   #3
Junior Member
 
Join Date: Aug 2017
Posts: 2
Thanks for the feed back. No luck. Now the display doesn't light up at all. There is a black and yellow wire coming out of the display and there were two red wires (looks like they go back to the pump). I have a wiring diagram but all it shows is the yellow going to the pump. Black is the ground. Does the black go back to the pump too or ground on the chassis? Thoughts? Last question. Is there a fuse box for the headlights, turn signals, dash lights, etc.. I have search everywhere
Seayakker is offline   Reply With Quote
Reply

Tags
panel, water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Illuminating the systems monitoring panel Playtime III MH-General Discussions & Problems 4 05-06-2014 07:49 PM
Monitoring Panel Replacement Azarius RV Systems & Appliances 3 04-09-2014 01:45 PM
Solar panel monitoring light w diode donnyjay MH-General Discussions & Problems 2 03-28-2014 10:44 AM
Georgie Boy Monitoring Panel goffrobert Class A Motorhome Discussions 2 09-29-2012 02:28 PM
Monitoring Panel JoJim Newmar Owner's Forum 8 03-27-2007 09:15 AM


All times are GMT -6. The time now is 12:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.