Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-07-2017, 08:24 PM   #1
Junior Member
 
Join Date: Nov 2017
Posts: 23
Need diagnostic help!

First, I have a 40' Tiffin Phaeton QDH with a 350 Caterpiller motor. Now, my problem; I took my coach on a short 100 mile trip and had zero problems. I arrived home and closed it up as I have for the past ten years. Two days later I started it up and notice some it would not air up. Bought a new governor and put it on. Now my Coach won't turn over. Power all the back to the starter. When you turn the key it makes the normal clicking sounds and all the dash lights come on but will not turn over...I replaced the starter. Same thing. Checked all the fuses and breakers and could find nothing wrong. Batteries are new and tested good. Any suggestions on where I can go from here? Thanks in advance.
Bob310 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-07-2017, 08:25 PM   #2
Junior Member
 
Join Date: Nov 2017
Posts: 23
Also, chassis batteries are turn on.
Bob310 is offline   Reply With Quote
Old 11-07-2017, 08:33 PM   #3
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Jan 2013
Location: michigan-tip of the mitt
Posts: 1,444
sounds like a solenoid.
In a elctric bay, sometimes on the driver side in front of the front tire, you should find a couple of solenoids. Check if power is passing through when key is turned on. If you find a bad one it needs a constant duty solenoid. NOT a starter solenoid. Power is passing through all the time key is on and a starter solenoid will melt the points in about 20 minutes.
Good luck
__________________
2003 Class C, 29' Gulfstream
Next stop?
Previous rigs..2 Pickup campers,2 TT's, 3 DP MH's
t55watson is offline   Reply With Quote
Old 11-07-2017, 08:36 PM   #4
Senior Member
 
Join Date: Sep 2016
Posts: 683
Check your neutral safety switch. If it doesn't see neutral it will NOT crank. Period
AITG is offline   Reply With Quote
Old 11-07-2017, 08:37 PM   #5
Junior Member
 
Join Date: Nov 2017
Posts: 23
Thank you, it reads neutral.
Bob310 is offline   Reply With Quote
Old 11-07-2017, 08:41 PM   #6
Junior Member
 
Join Date: Nov 2017
Posts: 23
Ok, I think I know which solenoids you are talking about. Will check first thing in the morning. Thx
Bob310 is offline   Reply With Quote
Old 11-08-2017, 10:14 AM   #7
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 51,772
Hi Bob! Welcome to IRV2! We're sure glad you joined the gang!

Sorry I can't help with your problem but just wanted to say hello. Keep her between the ditches!

Good luck, happy trails, and God bless!
__________________
Joe & Annette
Sometimes I sits and thinks, sometimes I just sits.....
2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 11-08-2017, 08:20 PM   #8
Member
 
Join Date: Feb 2011
Location: milford va
Posts: 94
starting

Nuetral safety switch is in the transmission computer.Check fuses for it and also put it in d or r and back into nuetral.Go to the starter and short the little wire to the one that goes to the battery.Should crank.Last could be a bad ikgnition switch,or possibly a relay.In my 03 phaeton fuses and relays behind draws in front console area.Hope this helps......Ronster
ronster is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atwood G6A-7E circuit board diagnostic help needed jduffey5 RV Systems & Appliances 3 05-23-2016 06:51 AM
Diagnostic Help needed Steve in WI Class A Motorhome Discussions 14 01-28-2015 04:24 PM
Bounder: 2000 Bounder 34T owners..Help, can't find diagnostic port herowen1 Fleetwood Owner's Forum 2 07-01-2012 06:03 PM
diagnostic plug location help!! moty Winnebago Industries Owner's Forum 4 09-23-2011 08:12 PM
Just bought VMSpc, Can't find Diagnostic Connector! HELP!!!! dapperphil Monaco Owner's Forum 6 06-30-2010 08:30 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.