Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-14-2022, 01:25 AM   #1
BEB
Junior Member
 
Join Date: Aug 2022
Posts: 3
New class A owner

I have a 2002 Dutch Star Newmar 38í we got it and left on a 2800 plus miles A maiden voyage. On the way back home I stopped and fueled up and then started rig up and all was good. Then went over to a Walmart and went in came back out and started rig up and the buzzer for low air did not buzz and the lights on the alarm panel did not come on and I could not reset my mileage back to zero for my last fill up. My fuel gage does not work so the gage set on empty and the low fuel late would always be on also. But Spence the Walmart stop nothing has worked on the alarm panel and no buzzers. When we got home and shut down the fed slide started to go out by itself when no one touched the button and the lock arms were locked but it kept trying so I killed all power and I managed to bring in the slide manually and got the bottom back in and the I unlocked the arms and the it went out. But now I canít get it to operate to come back in. I did change the voice slide motherboard but it still will not operate. Is there another control board somewhere?or please help with any suggestions. Thank you muches
BEB is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-14-2022, 06:06 AM   #2
Senior Member
 
Country Road's Avatar
 
Join Date: May 2021
Location: Brenham, Texas
Posts: 1,099
Quote:
Originally Posted by BEB View Post
I have a 2002 Dutch Star Newmar 38í we got it and left on a 2800 plus miles A maiden voyage. On the way back home I stopped and fueled up and then started rig up and all was good. Then went over to a Walmart and went in came back out and started rig up and the buzzer for low air did not buzz and the lights on the alarm panel did not come on and I could not reset my mileage back to zero for my last fill up. My fuel gage does not work so the gage set on empty and the low fuel late would always be on also. But Spence the Walmart stop nothing has worked on the alarm panel and no buzzers. When we got home and shut down the fed slide started to go out by itself when no one touched the button and the lock arms were locked but it kept trying so I killed all power and I managed to bring in the slide manually and got the bottom back in and the I unlocked the arms and the it went out. But now I canít get it to operate to come back in. I did change the voice slide motherboard but it still will not operate. Is there another control board somewhere?or please help with any suggestions. Thank you muches
Glad you made it home and welcome to the forum. Someone will give you ideas soon.
__________________
Eddie and Jomaye, Retired
2018 Newmar Ventana 4369
2021 Jeep 4 dr Wrangler
Country Road is offline   Reply With Quote
Old 08-14-2022, 12:19 PM   #3
Senior Member
 
Toribk's Avatar
 
Join Date: Oct 2011
Posts: 730
BEB,

All you are experiencing is related to voltage received from your chassis (starting) batteries.

From my experience, most electrical anomalies like this begin when the batteries are going south, lug connections are loose or corroded at the terminals, chassis grounding terminal is loose or corroded or connections at the large in-line fuses or at the Battery Control Center are loose or corroded.

This all attributes to electrical gremlins....so start at your source of power (ie chassis batteries) and work your way forward.

Over time, moisture and condensation can invade electrical connections, cause them short through corrosion and that's usually the case when you see slides opening on their own, generators starting on their own, awnings deploying on their own etc etc....or a group of dash components not functioning because they are all on the same large multi-pin molex connection.

A lot of these connections are found either behind the steering column along the dash or on the opposite side of the dash mounted to the firewall.

I have attached a photo of what happens inside these molex connections. This coach owner was experiencing all kinds of wierd electrical problems up until this was uncovered at the firewall.

Just some things to start with.Click image for larger version

Name:	IMG_7087.jpg
Views:	19
Size:	58.7 KB
ID:	373616
Toribk is offline   Reply With Quote
Old 08-14-2022, 01:47 PM   #4
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 51,433
Hi ! Welcome to IRV2! We're sure glad you joined us!

I agree with toribk that this sounds like a low-battery problem. Have you used a voltmeter to check the battery voltage?

Good luck, happy trails, and God bless!
__________________
Joe & Annette
Sometimes I sits and thinks, sometimes I just sits.....
2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 08-14-2022, 09:15 PM   #5
Senior Member
 
Join Date: May 2013
Posts: 202
Re-post your post in the Newmar owners section. You will some very good and specific replies to your problem from very knowledgeable Newmar owners who have likely experienced the same problem. I use the Entegra owners section all the time and the Entegra owners have been so helpful
__________________
Jim & Carol C
2014 Anthem DLQ
2015 Jeep Cherokee Trailhawk
Guernsey is offline   Reply With Quote
Old 08-15-2022, 07:50 AM   #6
Senior Member
 
Workhorse Chassis Owner
Join Date: Jul 2005
Location: USA
Posts: 3,462
Welcome aboard!
__________________
TandW
TandW is offline   Reply With Quote
Old 08-16-2022, 09:26 AM   #7
BEB
Junior Member
 
Join Date: Aug 2022
Posts: 3
New class A motor home owner

Thank you all for your response. I did go through all the connections and cleaned them from the batteries to the front of unit. In the front I found a large plug with many wires in it and when I took it apart there was some corrosion on the pins and sockets. So I cleaned all that up and then took the other plug apart and found one of the pins a socket corroded. So I cleaned that plug up as well. Went and put battery connections back on batteryís and went in and turned the key on and my alarm panel came on and the buzzer and started unit and buzzer stayed on until air built up. So thank you for the info in leading me in the right direction.
But I still have a issue with my slide not operating. Is there a relay somewhere that needs to operate in order for the controller to know which way the slide motor needs to go?
The slide motor is good I can jump it to a battery and it operates both directions. To me itís something to do with from slide switch to the controller like through a relay. Any ideas??
BEB is offline   Reply With Quote
Old 08-18-2022, 03:17 PM   #8
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 27,484
The slide controller module in my 99 , is under the kitchen sink , on the opposite wall from the main slide . The fuse for the slide motor is in a rear 12 volt fuse panel beside the , 120 volt circuit breaker box , in the bed room on my coach.
Photo is the slide controller .

BTW : Dutch Star diesel pushers can be on Spartan or Freightliner chassis , so it's important to include that info when asking questions about chassis wiring .

Please take a few mins and fill out a signature line with your coach info and it'll automatically come up on the bottom of your posts , as mine does below this one.
Attached Thumbnails
Click image for larger version

Name:	IMG_0294 (640x360).jpg
Views:	10
Size:	138.4 KB
ID:	374028  
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is online now   Reply With Quote
Old 08-19-2022, 03:30 PM   #9
BEB
Junior Member
 
Join Date: Aug 2022
Posts: 3
New class a owner BEB

Thank you Skip426 your info was helpful I found the slide out controller under the aft bench of table I took cushions off and lifted that cover and there it was mounted to the wall. I took it off and opened it up and part of the mother board was burned up. So I am very grateful for your info and everyone elseís.
I do have the Dutch Star Newmar with the Freightliner chassis. Thanks again so much I can quit pulling my hair out and I donít got much. Lol
BEB is offline   Reply With Quote
Old 08-19-2022, 05:57 PM   #10
Senior Member
 
Join Date: Nov 2011
Posts: 390
For the wonderful Molex connector tin pins as well as the main AC power connectors, I use DeOxit. The best oxide remover and connector lube I have found.
__________________
Marc
2013 Thor Palazzo 33.2
2013 Honda CRV
mlpeloquin is offline   Reply With Quote
Reply

Tags
class a



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Greetings, new forum member, new Class 3 owner, new camper svt4cam New Member Check-In 2 05-30-2019 09:55 AM
NEW THOR OWNER THREAD -- Things every new Thor owner must know MEWright Palazzo Motorhomes 14 10-12-2018 12:46 PM
New Newmar owner questions from Owner's Manual TarheelGal Newmar Owner's Forum 14 07-05-2018 08:25 PM
Video: Overview Class A vs Class B vs Class C pros and cons for new RVers themoreweexplore New Member Check-In 8 08-03-2015 04:14 PM
Old NRV owner wanting to be a new NRV owner. hutchman National RV Owner's Forum 2 01-05-2013 06:18 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 09:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.