RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-08-2018, 02:40 PM   #1
Member
 
Join Date: Apr 2006
Location: beaumont,tx
Posts: 35
no power

coming home yesterday my 2000 newmar would no go over 55mph. could this be a fuelfilter problem current one has 11,000 on it. cummins 350
max77713 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-08-2018, 02:43 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 24,795
Most likely and cheap to change out and test run.
twinboat is offline   Reply With Quote
Old 04-08-2018, 02:46 PM   #3
Member
 
Join Date: Apr 2006
Location: beaumont,tx
Posts: 35
Unhappy no power

coming home yesterday my 2000 newmar would not go over 55mph, could this be a fuel filter problem the current one has 11,000 miles on it, cummins 350
max77713 is offline   Reply With Quote
Old 04-08-2018, 02:47 PM   #4
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 14,931
Any problems with acceleration?

Fuel filters are often first go to item for power loss issues.
__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is online now   Reply With Quote
Old 04-08-2018, 02:50 PM   #5
Senior Member
 
palehorse89's Avatar
 
Newmar Owners Club
Join Date: Oct 2009
Posts: 8,940
11k on the filter's, yes they need changed......100% sure that is your problem based on your post. 11k on the filter's, how old/long since they have been changed?
__________________
2012 Essex 4544 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006 Ultra & 1989 Springer
palehorse89 is offline   Reply With Quote
Old 04-08-2018, 09:17 PM   #6
Senior Member
 
Ilvmygt's Avatar
 
Join Date: Oct 2017
Posts: 231
I had a similar situation where the coach would buck going up the hills on the freeway. It was fine on the flats. I changed both filters when I got home and that solved the problem.
__________________
Country Coach 2000 MAGNA C10
Ilvmygt is offline   Reply With Quote
Old 04-08-2018, 10:21 PM   #7
Senior Member
 
Join Date: Feb 2015
Posts: 1,766
I too had problems with no power going up hill. Thought it was the filter too but turned out it was an electronic module to the filter. Took an hour to change at a cost of $100.
__________________
2015 Itasca Ellipse 42QD
2017 Jeep Wrangler Rubicon Hard Rock
2011 Harley Davidson CVO Street Glide
TXTiger is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shore power power not providing power to air conditioner jjhenley RV Systems & Appliances 6 06-21-2016 10:08 AM
Intermittent electrical problem - no mirror power or camera power born2camp Workhorse and Chevrolet Chassis Motorhome Forum 5 07-14-2008 04:45 PM
No Eletrical Power from Power Tech Generator Field Trip Newmar Owner's Forum 5 09-27-2005 06:23 PM
No Power Mirror, radio, temp, power window, and Jacks. RVDriver Winnebago Industries Owner's Forum 4 08-02-2005 11:20 AM


All times are GMT -6. The time now is 09:18 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.