RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-19-2020, 08:59 AM   #1
Junior Member
 
Newmar Owners Club
Holiday Rambler Owners Club
Join Date: Feb 2019
Location: Clayton, NC
Posts: 9
Oasis Zone Heating problem

We have an Oasis system in our '15 Newmar Ventana, of which I have very little practical knowledge. I had its annual service a few months ago at a local dealer in the Grand Rapids area, and have not used the furnace since (I have no reason to doubt the work done). But as it's gotten colder, I turned the furnace on overnight. The bedroom maintained temperature, the main cabin was blowing cool air all night. I looked at the system this morning, and from what little I could tell, it was on (!), and the control panel with indicator lights showed green for everything that was relevant, except that the thermostat for zone 2 (which I think is the cab - zone 1 on the dometic control) was not lit. Zone 4 (bedroom, I believe) was. I'm running the HP in zone 1 and it is warming fine, which I think is telling me the thermocouple is operating. I appreciate any information anyone can provide.
Ralph & Meredith Reddick
'15 Ventana, Volvo XC-60 on a dolly
[Gal 2:20]
__________________
Ralph & Meredith
2105 Newmar Ventana
2016 Holiday Rambler Endeavor
RalphR01 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-19-2020, 11:50 AM   #2
Senior Member
 
Join Date: Feb 2013
Location: Graham, WA
Posts: 714
You say that the Oasis is on, but what’s on? If the diesel is running, it’s totally noticeable. Unit is not totally quiet and the exhaust is hot. If you’re running on the electric element, you may not have enough BTU to heat the entire coach. You also said that the front was blowing cold air so presumable the thermostat is calling for heat. My HydoHot has a green light on the status board that shows each zone. If the thermostat is calling for heat then the pump for that zone should be pumping.

FYI, mine says to run the diesel monthly to keep the system fully functional.

Good luck,
Dennis
__________________
2006 Gulfstream Friendship G7, Cat C7 and Allison 6 spd
Honda VTX and Cruiser Lift on the back
Blue Ox Aladdin, Brake Buddy, 2019 Chevy Blazer RS toad
Dennis4809 is offline   Reply With Quote
Old 09-19-2020, 02:05 PM   #3
Junior Member
 
Newmar Owners Club
Holiday Rambler Owners Club
Join Date: Feb 2019
Location: Clayton, NC
Posts: 9
Thank you

thank you for the reply.

The unit itself is on, both electric and burner. I can hear it running and the bedroom is blowing hot air. The living area is blowing cool area and should be hot because it's under the set temperature on the Dometic controller in the main area. Sorry if I wasn't clear.
__________________
Ralph & Meredith
2105 Newmar Ventana
2016 Holiday Rambler Endeavor
RalphR01 is offline   Reply With Quote
Old 09-20-2020, 09:12 AM   #4
Senior Member
 
Join Date: Feb 2013
Location: Graham, WA
Posts: 714
Has it worked properly in the past and now a sudden change or has it alwaYs been this way. Our front zone never put out the heat that it should and we finally found a kinked line that almost shut off the flow of boiler fluid. Replaced a section of the tubing and is now fine.
If itís a sudden change Iíd figure out which pump handles that zone to see if itís running. If itís not, check power and if necessary replace pump. If it is running, carefully tap on the valve at the output of the pump. They occasionally stick, especially if not used periodically.

Remember that Iím talking from a Hydohot perspective but suspect that Oasis is similar.

Dennis
__________________
2006 Gulfstream Friendship G7, Cat C7 and Allison 6 spd
Honda VTX and Cruiser Lift on the back
Blue Ox Aladdin, Brake Buddy, 2019 Chevy Blazer RS toad
Dennis4809 is offline   Reply With Quote
Reply

Tags
heat, heating, oasis, problem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oasis Zone Heating problem RalphR01 RV Systems & Appliances 0 09-19-2020 06:20 AM
Ventana 3436, Heating zone 2 issues (Oasis) MCRV Passion Newmar Owner's Forum 1 10-12-2017 11:20 AM
Heating zone problem jeffnjay Entegra Owner's Forum 4 05-26-2017 08:32 PM
Oasis Heating Zone Issue BonanzaFlyer Newmar Owner's Forum 3 04-08-2015 09:32 AM
Oasis Hydronic Heating System Zone problems ubfj RV Systems & Appliances 3 11-13-2011 12:58 PM


All times are GMT -6. The time now is 01:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.