Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-10-2011, 08:51 AM   #15
Senior Member
 
Triker56's Avatar
 
Fleetwood Owners Club
Join Date: Jun 2009
Posts: 4,031
Quote:
Originally Posted by BABrede View Post
I suspected water in the filter, I was correct. Had it changed at a Speedco location and had them dump contents into a clear container, sure nuff, had water in filter.
Kerry
WOW! Getting water in a fuel filter that picks up its fuel 1/4 the way up the tank.
That would mean there is a lot of water in the tank.
Water being heaver then fuel.
How often do you have to change the engine fuel filters?

When your tank gets low. You may want to drain some of the water out of it.
Triker56 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-11-2011, 02:37 PM   #16
Senior Member
 
Join Date: Mar 2011
Posts: 180
Put fuel filter in today. Ran it under load for 2 hours plus with no promblem. It maybe several weeks before I can check it with the coach underway. Wish me luck.
expedition1 is offline   Reply With Quote
Old 06-20-2011, 03:00 PM   #17
Senior Member
 
Join Date: Mar 2011
Posts: 180
Finally took the coach for a ride today and sure enough the same promblem again. Does anyone have any further ideas? Thanks.
expedition1 is offline   Reply With Quote
Old 06-20-2011, 05:53 PM   #18
Senior Member
 
steved44's Avatar
 
Join Date: Nov 2007
Posts: 190
I agree with triker, there has got to be a lot of water in your main fuel tank to cause something like that. I don't know how your main engine is still running. It probably has a water seperator filter, but they can't handle much moisture. If you check the generator filter and it has water in it again, then you had better look in your main fuel tank for the problem. good luck Steve
steved44 is offline   Reply With Quote
Old 06-20-2011, 06:15 PM   #19
Senior Member
 
Join Date: Mar 2011
Posts: 180
I do have a water seperator but have never seen any water in it. My coach engine runs fine.
expedition1 is offline   Reply With Quote
Old 06-20-2011, 06:24 PM   #20
Senior Member
 
Join Date: Mar 2011
Posts: 180
I should have also said that when I did replace the genset fuel filter I did not see any water in it.
expedition1 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan genset emerald I RonS1985 MH-General Discussions & Problems 6 09-15-2010 03:32 PM
Onan diesel generator engine smokes BAD.. Swannee MH-General Discussions & Problems 1 09-03-2010 01:05 PM
Onan 5500W genset - auto mode problem KTM Guy Technology: Internet, TV, Satellite, Cell Phones, etc. 0 08-26-2010 05:00 PM
Onan 7.5 QD (Quiet Diesel) Generator GStream40 RV Systems & Appliances 11 06-15-2008 07:10 PM
ONAN Genset starting issue Fried MH-General Discussions & Problems 15 11-21-2007 02:15 PM


All times are GMT -6. The time now is 04:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.