Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-12-2017, 12:51 PM   #1
Junior Member
 
Join Date: Jun 2017
Posts: 9
ONAN Diesel Generator quits running

I recently purchased a Class A with a 7.5Kw ONAN Diesel generator. I can start the generator and apply power. Whether power is applied or not the generator will shut down within several minutes. When I check the fault code it says it has over temped. The antifreeze reservoir is full. the cooling fan is running. What is causing this code? Also the generator will start right back up after coding and shutting down.
davepoint62 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-12-2017, 12:56 PM   #2
Senior Member
 
Monaco Owners Club
Join Date: Sep 2014
Posts: 4,532



You should be able to find the service manual here;

Index of /~n0nas/manuals/onan


The onan manuals have great troubleshooting trees and theory of operation.

Good luck!
__________________
1996 Tioga Class C
2007 Monaco Diplomat 40 PDQ
TOAD 2012 Cadillac SRX 4
okcnewbie is offline   Reply With Quote
Old 06-12-2017, 12:57 PM   #3
Senior Member
 
lllkrob's Avatar
 
Join Date: Nov 2008
Posts: 3,344
Need facts about this generator. How old is it? how many hours of use? What is the oil level? It's probably got a bad temp sensor but more facts are needed.
__________________
2013 Tiffin Phaeton 40QBH
2016 Chevrolet Equinox LTZ AWD V6
lllkrob is online now   Reply With Quote
Old 06-12-2017, 01:08 PM   #4
Senior Member
 
bruceisla's Avatar
 
Join Date: Oct 2012
Location: Foley AL
Posts: 7,138
Quote:
Originally Posted by okcnewbie View Post



You should be able to find the service manual here;

Index of /~n0nas/manuals/onan


The onan manuals have great troubleshooting trees and theory of operation.

Good luck!
.... yup .... 1/2 hr with the manual nailed my problem. Took me longer to drive to the Onan Parts Center than to fix it. But ... changing the belts was a horror show ....
__________________
2005 Newmar Essex 4502, 2013 Caddy SRX
1997 HR Endeavor 37, CAT, 1996 Geo Tracker
bruceisla is offline   Reply With Quote
Old 06-12-2017, 01:10 PM   #5
Senior Member
 
FIRE UP's Avatar


 
Join Date: Dec 2009
Location: Out there, somewhere
Posts: 9,321
As has been stated, a bit more info is needed for a possible accurate answer. What is the code number? The Temp sensor is the most likely culprit on issues of overtemp but, not always.
Scott
__________________
2004 ITASCA HORIZON 36GD, 2011 GMC Sierra 1500 4x4 Toad '18 Honda Africa Twin Adventure Sports DCT
Retired-29.5 yrs, SDFD, Ham - KI6OND
Me, Karla and the Heidi character, (mini Schnauzer)!
FIRE UP is offline   Reply With Quote
Old 06-12-2017, 01:45 PM   #6
Junior Member
 
Join Date: Jun 2017
Posts: 9
The code is a single flash. Book says that is a "high engine coolant temp". The generator is a 2005. It has no hour meter. Oil level is at full as is the coolant level.
davepoint62 is offline   Reply With Quote
Old 06-12-2017, 01:57 PM   #7
Member
 
alounsbe's Avatar
 
Holiday Rambler Owners Club
Join Date: Mar 2016
Posts: 71
You should check the belt for the water pump I once lost my belt and that was the symptom I had it would run for a while and then over temp and shut down. Removing the top pully makes it a lot easier to get the new belt on I tried rolling on the belt first that did not work at all.
alounsbe is offline   Reply With Quote
Old 06-12-2017, 01:57 PM   #8
Senior Member
 
lllkrob's Avatar
 
Join Date: Nov 2008
Posts: 3,344
Quote:
Originally Posted by davepoint62 View Post
The code is a single flash. Book says that is a "high engine coolant temp". The generator is a 2005. It has no hour meter. Oil level is at full as is the coolant level.
It's got an hour meter either on the generator itself next to the start/stop toggle switch or on the dash of the coach or in a overhead cabinet.
__________________
2013 Tiffin Phaeton 40QBH
2016 Chevrolet Equinox LTZ AWD V6
lllkrob is online now   Reply With Quote
Old 06-12-2017, 03:02 PM   #9
Junior Member
 
Join Date: Jun 2017
Posts: 9
OK that may be what the electronic plate is under the radio. I will go look. The belt is in place. Changing the temp sensor will be a bear. Will it require dropping the generator down out of the RV?
davepoint62 is offline   Reply With Quote
Old 06-12-2017, 03:09 PM   #10
Senior Member
 
HR2004's Avatar
 
Join Date: May 2014
Posts: 762
When cool remove radiator cap. Pull hose all the way out first. Coolant should be up to the cap. Just because overflow has enough does not mean radiator is full. I fixed a friends a few days ago that way. Been running steady for 2 days now.
HR2004 is offline   Reply With Quote
Old 06-12-2017, 03:10 PM   #11
Junior Member
 
Join Date: Jun 2017
Posts: 9
The hour meter on the dash says 119
davepoint62 is offline   Reply With Quote
Old 06-12-2017, 03:12 PM   #12
Junior Member
 
Join Date: Jun 2017
Posts: 9
I had the cap out and off. It showed full. How far out should it be?. I had it through the opening about 7-8 inches.
davepoint62 is offline   Reply With Quote
Old 06-12-2017, 03:19 PM   #13
Junior Member
 
Join Date: Jun 2017
Posts: 9
It only runs about 3 minutes before shutting down. If it was low on coolant, bad pump, belt or thermostat it would have to run until it gets hot. I am leaning towards the temp sensor being bad and shutting it down. The exhaust pipe doesn't even have time to get hot.
davepoint62 is offline   Reply With Quote
Old 06-12-2017, 03:28 PM   #14
Senior Member
 
znt1186's Avatar
 
Join Date: Nov 2014
Posts: 1,047
Check the fuel filter(s) as well. Mine had 2, the one on the generator and an inline one that Tiffin added.
__________________
Zeb and Teena
2005 Mandalay, 2013 Ford Edge
znt1186 is offline   Reply With Quote
Reply

Tags
diesel, generator, onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Genarac 09592-2 Generator quits after running 10 minutes ddavis RV Systems & Appliances 5 04-23-2017 05:04 AM
8 KW Onan diesel generator randomly quits thirdwall MH-General Discussions & Problems 8 08-03-2014 11:57 AM
Generator quits running lacritch Country Coach Owners Forum 2 07-27-2012 10:10 PM
Generator quits while engine running gator67 Alpine Coach Owner's Forum 5 06-21-2012 04:01 PM
Onan Generator Quits On Start With No Load Birddog Pilot Alpine Coach Owner's Forum 26 08-11-2008 10:49 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.