RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-02-2020, 03:13 PM   #1
Junior Member
 
Join Date: Aug 2019
Posts: 3
Onan Gen Will crank, but not start

I have an Onan Generator on my 2017 Forrest River Georgetown 24W3
Model 4KYFA - 26100P with 40 Hrs on it. It will crank all day, but won't start. have changed the spark plug, air filter, oil, gas is flowing thru the fuel filter. Don't know what else it could be. Would appreciate any help!
deleon57 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-02-2020, 03:42 PM   #2
Senior Member
 
Unplanned's Avatar


 
Join Date: May 2016
Location: Kamloops, BC, 60 miles from the Center of the Universe
Posts: 3,969
How long since it was running?
Squirt a little gas into the air intake, and see if it tries to start.
Common problem is gummed up carb jets from sitting.
__________________
Happy Glamping.Norman, 2008 Winnebago Adventurer 38J, W24, dozens of small thirsty ponies. Retired after 40 years wrenching on trucks! 2010 Ford Ranger toad with bicycles or KLR 650 in the back. Easy to spot an RVer, they always walk around with a screwdriver or wrench in one hand!
Unplanned is online now   Reply With Quote
Old 09-02-2020, 03:46 PM   #3
Senior Member
 
bob caldwell's Avatar


 
Join Date: May 2017
Location: Vancouver Wash
Posts: 7,060
Have you checked for spark?
__________________
2010 Rockwood Sig Ultra lite 5er 8280......'99 Ram 2500, Cummins. 4x4.....Pullrite Superglide.........
bob caldwell is offline   Reply With Quote
Old 09-02-2020, 04:10 PM   #4
Member
 
Join Date: May 2018
Posts: 81
Have you checked fuse in the front switch panel?
__________________
2004 Newmar KSDP 3905
Cummings ISC-330, MM Chassis
Dave_H is offline   Reply With Quote
Old 09-02-2020, 05:15 PM   #5
Junior Member
 
Join Date: Aug 2019
Posts: 3
it's been 5 months since I started it last, All good questions, haven't tried any of these possible solutions, but I will, thanks for the suggestions.
deleon57 is offline   Reply With Quote
Old 09-02-2020, 07:38 PM   #6
Senior Member
 
Corc's Avatar
 
Thor Owners Club
Freightliner Owners Club
Join Date: Feb 2018
Location: Huntsville, AL.
Posts: 146
You canít let gas sit for 5 months. Might need to check out new carb on Amazon.

If itís going to sit you need to either drain fuel or treat it or you will be disappointed once again.
__________________
Huntsville, Alabama
2018 Thor Palazzo 33.2
2009 Jeep Liberty
Corc is offline   Reply With Quote
Old 09-02-2020, 07:57 PM   #7
Senior Member


 
Join Date: Jun 2017
Posts: 2,760
I assume you have primed it?
tfryman is offline   Reply With Quote
Old 09-03-2020, 08:53 AM   #8
Senior Member
 
Join Date: Jan 2017
Posts: 122
check the battery switch on the dash. I had the same problem. finally check the battery switch and it was off.
__________________
1992 Winnebago Adventure 34 RQ
REDEYE50 is offline   Reply With Quote
Old 09-27-2020, 08:02 AM   #9
Junior Member
 
Join Date: Jun 2015
Posts: 19
Hi, did you find the fault? You probably have it fixed I'm sure..However another chk is for a low oil switch if fitted - Disconnect wire from that as they can fail despite oil level is ok.

Also chk the ohms reading of the ignition coil. Connect multimeter on resistance range between earth and primary terminal (where small coloured but not black wire connects) and then earth and sparkplug wire terminal inside plug cover.

Mine is a KYFR...B and correct primary ohms is .05 and sparkplug 1100 ohms. Anything very close to these figs means coil is probably ok.

Cheers from OZ
__________________
1995 35' A Class Australian built Winnebago "Classic Freeway"
Cummins 6B intercooled turbo pusher, Allison 4 spd on Spartan Chassis
Aussie Mike is offline   Reply With Quote
Old 09-27-2020, 04:38 PM   #10
Senior Member
 
Join Date: Apr 2020
Posts: 160
Double check oil level.
Fast E is offline   Reply With Quote
Reply

Tags
onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
91 Airex Crank But No Start Issue... 91airex Rexhall RV Owner's Forum 24 05-17-2018 07:44 AM
2003 TS , Onan 12.5 diesel gen, crank no start HELP wernie1 Travel Supreme Owner's Forum 6 05-04-2016 10:44 AM
Old Crank Sat Out New Automatic In - Crank Replaced With... Nomad Mike MH-General Discussions & Problems 4 11-02-2015 01:11 AM
Onan Gen won't crank Boat Builder RV Systems & Appliances 4 01-31-2014 12:45 AM
Marquis 7000 Generator Will Crank But Will Not Start Freedom7 Class A Motorhome Discussions 4 07-30-2011 12:48 PM


All times are GMT -6. The time now is 07:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.