Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-15-2016, 05:21 PM   #1
TIC
Junior Member
 
Join Date: Sep 2016
Posts: 4
Power Inverter/Battery Problems

Craziest thing, I went to my coach the other day, 2004 TS 40DS04, and the battery was dead and the coach would not crank even though it had been supplied with shore power (50amp) the entire time. The remote to my XANTREX Freedom 458 said the batteries were low. Luckily the generator fired and in about 10 minutes the coach cranked. I went camping all week and did not have anymore problems.

Upon my return home, I stored the coach and plugged the power back in. I decided to check the batteries (all were good) since I had a hard time cranking the coach prior to my trip. One of the batteries was low with water so I filled it up and plugged the power back in.

Fast forward 2 hours, I noticed the smell of acid and checked the batteries and 1 was boiling. I checked the batteries and 2 were bad. I decided to change all 4 today (Trojans) and after I installed them the inverter is not working properly.

The interior remote said the battery power was low but they had just been charged fully prior to me installing them. At the main inverter the power was charging but the batteries are getting hot again. I decided unplug the shore power and fire up the genertor. When the power kicked in on the generator, the invertor did not kick in and the remote went hay wire. The lights on the remote started blinking randomly, all of the lights.

The lights in the coach are all dim even while on shore power or generator running.

I called tech support, they had me unplug the remote and try to reset the system. Now the remote is totally out and will not even light up.

I have not disconnected the inverter yet, thats my next move.

I did not know if anyone has experience a issue like this.
TIC is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-15-2016, 06:39 PM   #2
Senior Member
 
Tiffin Owners Club
Appalachian Campers
Mid Atlantic Campers
Coastal Campers
Freightliner Owners Club
Join Date: Jan 2015
Posts: 1,615
Do you have a digital voltmeter, so you can understand what your resting battery voltages are, as well as your charging voltage?
__________________
DaveB, Raleigh, NC
2015 Tiffin RED 33AA, w/Honda CRV
VMSpc, Magnum BMK/ARC50
Kiawah is offline   Reply With Quote
Old 11-22-2016, 05:29 AM   #3
TIC
Junior Member
 
Join Date: Sep 2016
Posts: 4
I got it figured out, a battery wire was crossed and burned out the remote to the inverter.
TIC is offline   Reply With Quote
Reply

Tags
battery, ems, inverter, power, problems



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Inverter or battery problems or both? boltdave Winnebago Industries Owner's Forum 2 10-31-2015 10:30 PM
Another battery question - chassis battery and inverter cvbdsl Class A Motorhome Discussions 12 04-06-2015 04:30 PM
Inverter/Battery problems--confused AARONDENISE Class A Motorhome Discussions 10 06-05-2012 10:25 AM
inverter/battery problems millwright 5th Wheel Discussion 38 06-20-2011 09:05 AM
Charger/inverter battery problems HD4Mark Winnebago Industries Owner's Forum 15 03-09-2010 09:32 AM


All times are GMT -6. The time now is 11:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.