Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-24-2017, 10:04 AM   #1
epj
Senior Member
 
epj's Avatar
 
Join Date: Nov 2014
Posts: 273
Progressive Industries EMS failure

It's the 50 amp portable model, less than two years old. Got weird voltage readings on L1, and an error code of 10. Progressive replaced it very promptly and at no cost. Being curious, one of my friends removed the cover and discovered that it had 2-3 tablespoons of water in it. It is of some concern that the cover had no gasket of any sort. Also, the new one has a clear plastic cover over the receptacle that the older one did not have. He's going to let it dry in the sun for a day and then retest. I doubt that will fix it, but you never know.
__________________
2005 Phaeton 40'
epj is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-24-2017, 11:02 AM   #2
Senior Member
 
whitetop's Avatar
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Jan 2012
Location: Virginia Beach,Virginia
Posts: 261
I also have one of those, and had no idea they leak. I know you can not submerge them, but it should not hurt to be in the elements.
__________________
2002 Holiday Rambler Imperial
38 PWD 370 ISL
whitetop is offline   Reply With Quote
Old 08-24-2017, 11:05 AM   #3
Senior Member
 
Join Date: Jul 2017
Location: Show Low, Arizona
Posts: 131
Good on Progressive for a fast replacement. This is why companies like them stay in business and have cult like followings.

Good on your for investigating. Keep us posted after it dries out
__________________
1999 Monaco Signature Classic FSBO 45'
Cummins N14/Allison Series 4000
AquaHot/12.5kw Onan/Cummins GenSet
offtosleep is offline   Reply With Quote
Old 08-24-2017, 01:38 PM   #4
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 19,927
I'd call PI and let them know what you discovered and ask if it should have a gasket. My experiences with them suggest they'll be very forthright about the issue.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 08-24-2017, 03:48 PM   #5
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 50,889
Glad that Progressive took care of you!
__________________
Joe & Annette
Sometimes I sits and thinks, sometimes I just sits.....
2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 08-25-2017, 06:50 PM   #6
Senior Member
 
Dave-Oh's Avatar
 
Join Date: May 2015
Location: Silver Spring, MD
Posts: 602
the right side lights on my 50A SSP-XL stopped working. Sent back to PI, they sent be a new one in less than a week. I'm very happy with them.
__________________
2022 Imagine 22 MLE
2022 F150 Powerboost wi 7.2 KW
Dave-Oh is offline   Reply With Quote
Reply

Tags
ems



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Progressive Industries EMS - hardwired or inline? Jerry J RV Systems & Appliances 8 10-27-2009 08:40 AM
Progressive Industries EMS-LC-HW50 jayhade Newmar Owner's Forum 9 12-31-2008 12:48 PM
Progressive Industries EMS Rick Coleman Alpine Coach Owner's Forum 20 09-01-2008 08:02 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 09:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.