RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-06-2020, 04:44 PM   #1
Senior Member
 
Nohurry's Avatar
 
Join Date: Aug 2018
Location: Wa state
Posts: 165
Replaced house batteries, now no connection. Any ideas?

Replaced house batteries, seemed to Work for a few , now nothing. Generator runs with engine on. Turn off engine and it dies in three minutes. Very frustrated right now. Any ideas? Did the batteries come to me dead? Not sure. I was trying to charge them up. Havenít tried plugging in yet at storage.
__________________

Nohurry is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-06-2020, 04:48 PM   #2
Member
 
Join Date: Jul 2015
Location: College Station TX
Posts: 78
Probably some thing wired wrong when you hook things up. Did you take pictures of all the wires so youíre certain how they should be hooked up? Check to make sure all the batteries are oriented correctly and that you are sure which post is plus and which post is minus on each battery
__________________

Rodzent is offline   Reply With Quote
Old 06-06-2020, 04:55 PM   #3
Senior Member
 
Nohurry's Avatar
 
Join Date: Aug 2018
Location: Wa state
Posts: 165
Yes, thanks. I did take a picture and it is hooked up correctly.
Nohurry is offline   Reply With Quote
Old 06-06-2020, 05:27 PM   #4
Senior Member
 
Join Date: Jul 2014
Posts: 22,372
Send a picture of the battery hookup.
twinboat is online now   Reply With Quote
Old 06-06-2020, 06:30 PM   #5
Senior Member
 
Nohurry's Avatar
 
Join Date: Aug 2018
Location: Wa state
Posts: 165
Ok, I’m such an idiot. I had one of the batteries turned around backwards. I feel so stupid and I hope when this thread is seen in the future it will help others to open their eyes and pay attention. Thanks all
__________________
2007 National RV, Sea Breeze 1321, Ford F53,
Followed by a 2013 Wrangler JK Moab edition
Nohurry is offline   Reply With Quote
Old 06-06-2020, 06:55 PM   #6
Senior Member
 
Join Date: Jun 2017
Posts: 102
Quote:
Originally Posted by Nohurry View Post
Ok, Iím such an idiot. I had one of the batteries turned around backwards. I feel so stupid and I hope when this thread is seen in the future it will help others to open their eyes and pay attention. Thanks all

You know what Forrest Gump said. It does happen.
__________________
99 Tradewinds, 37ft, pushed by 04 Saturn ION, connected by Brute Elite tow bar.
lockinload is offline   Reply With Quote
Old 06-07-2020, 08:36 AM   #7
Senior Member
 
Join Date: Feb 2020
Posts: 170
Quote:
Originally Posted by Nohurry View Post
Ok, Iím such an idiot. I had one of the batteries turned around backwards. I feel so stupid and I hope when this thread is seen in the future it will help others to open their eyes and pay attention. Thanks all
That will do it!

Glad you figured it out.
__________________
2020 Georgetown GT7 36D7
GT7 Jim is offline   Reply With Quote
Old 06-07-2020, 09:18 AM   #8
Senior Member
 
deandec's Avatar


 
Country Coach Owners Club
Join Date: Jan 2006
Location: Northern California
Posts: 4,526
Its not about making mistakes, its about how you fix them!

Thanks for the follow up post, it will help some folks.
__________________
Dean
1995 38' CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Old 06-07-2020, 10:08 AM   #9
Senior Member
 
Domo's Avatar
 
Join Date: Sep 2018
Location: Full Timers
Posts: 946
I bet your were pretty POSITIVE that you would get NEGATIVE feedback after posting your solution!

I apologize for the pun - however, we all laugh at ourselves, at least we should certainly learn to do that.

You solved the issue - good job. You shared the story so others can learn - even better job!
__________________
2008 Phaeton 36QSH, Safe-t-Plus, Quadra Bigfoot
2017 Jeep Cherokee Trailhawk w/ flat tow wiring mod.
Blue ox, BrakeMaster + BrakeAway, diode lights and charge.
Domo is online now   Reply With Quote
Old 06-17-2020, 12:37 PM   #10
Member
 
Join Date: Jul 2015
Location: College Station TX
Posts: 78
Glad you were able to correct the orientation on the batteries.

Be safe out there.
__________________

Rodzent is offline   Reply With Quote
Reply

Tags
ace, batteries, house batteries, replace



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm out of ideas, any ideas what's causing my problem larliebler Technology: Internet, TV, Satellite, Cell Phones, etc. 12 12-30-2019 11:37 AM
Replaced house batteries but we're connected wrong...now have electrical issues?? Cileine Class C Motorhome Discussions 15 06-15-2017 02:08 PM
Replaced batteries, tried to close slide out, now batteries make a clicking sound nicole14 MH-General Discussions & Problems 39 03-23-2017 08:21 PM
Alternator replaced, now house batteries aren't getting charged! n9bk Winnebago Industries Owner's Forum 9 06-30-2016 07:37 PM
replaced house batteries, now gas gage bad stryker17 MH-General Discussions & Problems 8 11-05-2009 09:31 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:26 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×